[Solved] Boot Issue
poster avatar
2014-07-12 09:57

I have just installed Deepin 2014 from a pen drive onto my HP Pavilion TouchSmart laptop.  The machine originally had Windows 8 which I removed to install Ubuntu 14.04.  I did not use the Expert Mode during the install rather just picked the EXT4 partition to install to.  Two other partitions were visible on the installer screen.....One for EFI and another for swap.

What I am trying to accomplish is a full install of Deepin 2014 and removing Ubuntu leaving only Deepin as the sole OS.  Once the install was complete, I rebooted my machine and got the grub prompt.  If I reboot and hit F9 to change the boot sequence I see Ubuntu then linuxdeepin2014, then my pen drive and such.  I can navigate to the Deepin listing and hit enter and the system boots just fine.

Lastly, my question: How do I get the machine to simply boot Deepin without having to go to the boot order?  I have read some posts on this forum and others and the instructions are way above my head.  I'm not new to Linux but understanding what is really wrong and how to fix it has been confusing.

Please help as I just love Deepin and want to make it my only OS!

Reply Favorite View the author
All Replies
2014-07-12 11:43
You'll have to be in Expert Mode, delete existing partitions, create a new set of partitions, then install it.

Note that the partitions you create will be MBR type, not GPT, so the installation will not be UEFI-aware.
Reply View the author
2014-07-12 18:11
See http://www.linuxbsdos.com/2014/07/11/ma ... epin-2014/

That should answer all your questions.
Reply View the author
2014-07-14 21:38
Please enter the boot manager options in Control Centre to choose Deepin as the first boot option.
Reply View the author