[Seek Help] "Deepin 20" stops hard drive
Community Discussion198 views ·3 replies
Tofloor
doited_boy
deepin
2021-11-02 21:57
Author

Hi, guys!

First of all, thank you very much for that magnificent and beautiful operating system - Deepin 20 . It's really a great job, and most of your native applications are just incredibly good.

However I have some baffling issue with the Power Saving feature of your system Deepin 20, and need your help therefore.

I have Desktop PC with two different SATA hard drives inside of it. My main hard drive sda is SSD HDD formated in EXT4 file system, with Deepin 20 installed. My second hard drive sdb is standard mechanical HDD formated in NTFS, which has no specific operating system on it; it contains some supplementary files, videos, pictures and so on.

The problem is - Deepin 20 stops my second HDD when it's inactive for a couple of seconds. And then starts it again if the drive is activeted. Such a start/stop practice is very dangerous and harmful for a mechanism of any standard HDD drive.

I've tried different solutions. The changing of Power Management Setttings in the main menu of Deepin 20 didn't help. Then I've manually edited the settings of hdparm utility to the level of 254 for my sdb drive. Well, It has been helpful for some hours... However any restart or reboot of my system Deepin 20 brings the setting of hdparm to the level of 1 again. Moreover, even if I stick some USB flash drive into my PC, the same thing happens - complete reset of hdparm settings to the extremities of power saving.

Could you tell me please, is there any possible way to "pin" the settings of hdparm on the constant level of 254? I really need to avoid that start/stop way of working.

Well, thank you anyway if you paid any attention to my particular problem. Best regards :)

ReplyFavoriteView the author
Comments
wtz
2021-11-03 00:46
Would you please check the power setting in the Deepin Control Center? The "power saving mode" might be the cause. (Sorry I'm temporarily not able to post a reply so I just left a comment here)
All Replies
kingskill
deepin
2021-11-03 06:26
#1

Record_select-area_20211103142609.gif

ReplyView the author
doited_boy
deepin
2021-11-04 01:22
#2

Thank you very much, guys. I've read your suggestions. However all that methods doesn't work, alas. I had already changed the power settings to the "Balanced" scheme in the main menu of Deepin 20 many times before - it didn't help.

The chief problem, as it seems to me, does lie in the constant reseting of "hdparm" settings to it's default level of "1".

ReplyView the author
doited_boy
deepin
2021-11-16 04:13
#3

Well, ladies and gentlemen... =)

I have some good news...

After some experiments i've found the right decision.

To avoid continuos start/stop issue of any hard drive on the system "Deepin 20", we need the following instructions:

  1. Open the terminal and type "sudo apt remove hdparm". This simple command shall just disable the HDD-PowerSaving utility "Hdparm".

    1. Reboot the "Deepin 20" system.

      1. Open the System's Main Menu and click on the "Power" compartment. Then click on the "High Performance" section. NOT "BALANCED" OR "POWER SAVER"!

        Now, that's all. I hope the information is going to be helpful for other users of "Deepin 20". Farewell !

ReplyView the author
Use Markdown Editor
Loading