[Seek Help] deepin20.3上安装星火商店缺失依赖且无法修复?
Experiences and Insight141 views ·2 replies
Tofloor
星辰使者
deepin
2021-11-26 02:20
Author

安装星火商店3.0时,提示缺失包gdebi-core,出现以下错误:

 

 

$ sudo apt -f install '/home/test/Downloads/spark-store_3.0.3-5_amd64.deb'

正在读取软件包列表... 完成

正在分析软件包的依赖关系树

正在读取状态信息... 完成

注意,选中 'spark-store' 而非 '/home/test/Downloads/spark-store_3.0.3-5_amd64.deb'

有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是

因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件

包尚未被创建或是它们已被从新到(Incoming)目录移出。

下列信息可能会对解决问题有所帮助:

 

下列软件包有未满足的依赖关系:

spark-store : 依赖: gdebi-core 但无法安装它

E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

 

使用sudo apt -f install或sudo apt --fix-broken install都无法解决依赖问题,无法安装@ 神末shenmo  @ 忘记、过去

ReplyFavoriteView the author
All Replies
星辰使者
deepin
2021-11-26 02:41
#1

解决了。。。。。。

 

先用 sudo apt-get install 安装gdebi-core,成功

 

再用同样的命令安装星火商店,成功

 

话说为啥apt命令强制安装依赖却解决不了,真是奇怪。

另外官方的包安装管理器居然也不能解决依赖问题?建议官方弄个二次确认,告知安全风险后自动安装所需依赖。。。 @ 忆往

ReplyView the author
星辰使者
deepin
2021-11-26 03:05
#2

星火商店里安装应用,如旧版影院,报缺失依赖,头疼

test@test-PC:~$ sudo apt-get install '/tmp/spark-store/deepin-movie-legacy_3.2.20-1_amd64.deb'
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
注意,选中 'deepin-movie-legacy' 而非 '/tmp/spark-store/deepin-movie-legacy_3.2.20-1_amd64.deb'
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
deepin-movie-legacy : 依赖: libdmr (= 5.7.6.3-1) 但是 5.9.1-1 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

ReplyView the author
Use Markdown Editor
Loading