[Topic DIscussion] 请教各位大佬:deepin V20.3 安装weblate错误'ffi.h' file seen at
deepin Talks 174 views · 4 replies
Tofloor
poster avatar
深圳市耀影科技有限公司
deepin
2022-01-12 13:18
Author

ask for help

尝试过这里的各种方法,不行

https://stackoverflow.com/questions/62658237/it-seems-that-the-version-of-the-libffi-library-seen-at-runtime-is-different-fro

=2.0
  Using cached user_agents-2.2.0-py3-none-any.whl (9.6 kB)
Collecting openpyxl!=3.0.2,<3.1,>=2.6.0
  Using cached openpyxl-3.0.9-py2.py3-none-any.whl (242 kB)
Collecting social-auth-core==4.1.0
  Using cached social_auth_core-4.1.0-py3-none-any.whl (333 kB)
Collecting pyicumessageformat<1.1.0,>=1.0.0
  Using cached pyicumessageformat-1.0.0-py3-none-any.whl (8.9 kB)
Collecting hiredis<2.1.0,>=1.0.1
  Using cached hiredis-2.0.0.tar.gz (75 kB)
Collecting django-appconf<1.1,>=1.0.3
  Using cached django_appconf-1.0.5-py3-none-any.whl (6.4 kB)
Collecting Cython<0.30,>=0.29.14
  Using cached Cython-0.29.26-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.manylinux_2_24_x86_64.whl (1.9 MB)
Collecting Django[argon2]<4.1,>=3.2
  Using cached Django-4.0.1-py3-none-any.whl (8.0 MB)
Collecting filelock<3.5.0,>=3.0.0
  Using cached filelock-3.4.2-py3-none-any.whl (9.9 kB)
Collecting diff-match-patch==20200713
  Using cached diff_match_patch-20200713-py3-none-any.whl (61 kB)
Collecting python-redis-lock<3.8.0,>=3.6.0
  Using cached python_redis_lock-3.7.0-py2.py3-none-any.whl (12 kB)
Collecting borgbackup<1.2.0,>=1.1.9
  Using cached borgbackup-1.1.17.tar.gz (3.8 MB)
Collecting django-filter<22.0.0,>=2.4.0
  Using cached django_filter-21.1-py3-none-any.whl (81 kB)
Collecting django-compressor<3.2,>=2.4
  Using cached django_compressor-3.1-py2.py3-none-any.whl (149 kB)
Collecting pyparsing<3.1.0,>=3.0.5
  Using cached pyparsing-3.0.6-py3-none-any.whl (97 kB)
Collecting pyahocorasick<1.5,>=1.4
  Using cached pyahocorasick-1.4.2.tar.gz (321 kB)
Collecting Pygments<3.0,>=2.0
  Using cached Pygments-2.11.2-py3-none-any.whl (1.1 MB)
Collecting celery[redis]<5.3,>=5.0.3
  Using cached celery-5.2.3-py3-none-any.whl (405 kB)
Collecting cssselect<1.2.0,>=1.0.0
  Using cached cssselect-1.1.0-py2.py3-none-any.whl (16 kB)
Collecting translation-finder<3.0,>=2.7
  Using cached translation_finder-2.10-py3-none-any.whl (82 kB)
Collecting sentry-sdk<1.6.0,>=0.13.0
  Using cached sentry_sdk-1.5.2-py2.py3-none-any.whl (142 kB)
Collecting pygobject>=3.27.0
  Using cached PyGObject-3.42.0-cp310-cp310-linux_x86_64.whl
Collecting weblate-language-data>=2021.5
  Using cached weblate_language_data-2022.1-py3-none-any.whl (1.9 MB)
Collecting python-dateutil>=2.8.1
  Using cached python_dateutil-2.8.2-py2.py3-none-any.whl (247 kB)
Collecting django-redis<6.0.0,>=4.11.0
  Using cached django_redis-5.2.0-py3-none-any.whl (30 kB)
Collecting weblate-schemas==0.7
  Using cached weblate_schemas-0.7-py3-none-any.whl (8.8 kB)
Collecting django-crispy-forms<1.13.1,>=1.9.0
  Using cached django_crispy_forms-1.13.0-py3-none-any.whl (122 kB)
Collecting djangorestframework<3.14.0,>=3.11.0
  Using cached djangorestframework-3.13.1-py3-none-any.whl (958 kB)
Collecting html2text<2020.1.17,>=2019.8.11
  Using cached html2text-2020.1.16-py3-none-any.whl (32 kB)
Collecting GitPython<3.2.0,>=2.1.15
  Using cached GitPython-3.1.26-py3-none-any.whl (180 kB)
Collecting lxml<4.8.0,>=4.6.3
  Using cached lxml-4.7.1-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.manylinux_2_24_x86_64.whl (6.9 MB)
Collecting translate-toolkit<3.6.0,>=3.5.1
  Using cached translate-toolkit-3.5.2.tar.gz (6.0 MB)
Collecting bleach<5.0.0,>=3.1.1
  Using cached bleach-4.1.0-py2.py3-none-any.whl (157 kB)
Collecting jellyfish!=0.8.3,!=0.8.4,!=0.8.5,!=0.8.6,!=0.8.7,!=0.8.8,<0.9.1,>=0.7.2
  Using cached jellyfish-0.9.0.tar.gz (132 kB)
Collecting requests<2.28.0,>=2.20.0
  Using cached requests-2.27.1-py2.py3-none-any.whl (63 kB)
Collecting social-auth-app-django==5.0.0
  Using cached social_auth_app_django-5.0.0-py3-none-any.whl (24 kB)
Collecting siphashc<3.0,>=1.2
  Using cached siphashc-2.1.tar.gz (6.6 kB)
Collecting jsonschema<4.4.0,>=3.0.0
  Using cached jsonschema-4.3.3-py3-none-any.whl (71 kB)
Collecting misaka<2.2.0,>=2.1.0
  Using cached misaka-2.1.1.tar.gz (125 kB)
Collecting Pillow<10.0.0,>=6.0.0
  Using cached Pillow-9.0.0-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (4.3 MB)
Collecting oauthlib>=1.0.3
  Using cached oauthlib-3.1.1-py2.py3-none-any.whl (146 kB)
Collecting python3-openid>=3.0.10
  Using cached python3_openid-3.2.0-py3-none-any.whl (133 kB)
Collecting cryptography>=1.4
  Using cached cryptography-36.0.1-cp36-abi3-manylinux_2_24_x86_64.whl (3.6 MB)
Collecting defusedxml>=0.5.0rc1
  Using cached defusedxml-0.7.1-py2.py3-none-any.whl (25 kB)
Collecting requests-oauthlib>=0.6.1
  Using cached requests_oauthlib-1.3.0-py2.py3-none-any.whl (23 kB)
Collecting PyJWT>=2.0.0
  Using cached PyJWT-2.3.0-py3-none-any.whl (16 kB)
Collecting packaging
  Using cached packaging-21.3-py3-none-any.whl (40 kB)
Collecting six>=1.9.0
  Using cached six-1.16.0-py2.py3-none-any.whl (11 kB)
Collecting webencodings
  Using cached webencodings-0.5.1-py2.py3-none-any.whl (11 kB)
Collecting setuptools<59.7.0,>=59.1.1
  Using cached setuptools-59.6.0-py3-none-any.whl (952 kB)
Collecting vine<6.0,>=5.0.0
  Using cached vine-5.0.0-py2.py3-none-any.whl (9.4 kB)
Collecting click-plugins>=1.1.1
  Using cached click_plugins-1.1.1-py2.py3-none-any.whl (7.5 kB)
Collecting click<9.0,>=8.0.3
  Using cached click-8.0.3-py3-none-any.whl (97 kB)
Collecting billiard<4.0,>=3.6.4.0
  Using cached billiard-3.6.4.0-py3-none-any.whl (89 kB)
Collecting click-repl>=0.2.0
  Using cached click_repl-0.2.0-py3-none-any.whl (5.2 kB)
Collecting kombu<6.0,>=5.2.3
  Using cached kombu-5.2.3-py3-none-any.whl (189 kB)
Collecting click-didyoumean>=0.0.3
  Using cached click_didyoumean-0.3.0-py3-none-any.whl (2.7 kB)
Collecting pytz>=2021.3
  Using cached pytz-2021.3-py2.py3-none-any.whl (503 kB)
Collecting redis!=4.0.0,!=4.0.1,>=3.4.1
  Using cached redis-4.1.0-py3-none-any.whl (171 kB)
Collecting prompt-toolkit
  Using cached prompt_toolkit-3.0.24-py3-none-any.whl (374 kB)
Collecting cffi>=1.12
  Using cached cffi-1.15.0-cp310-cp310-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (446 kB)
Collecting pycparser
  Using cached pycparser-2.21-py2.py3-none-any.whl (118 kB)
Collecting rcssmin==1.1.0
  Using cached rcssmin-1.1.0-cp310-cp310-manylinux1_x86_64.whl (43 kB)
Collecting rjsmin==1.2.0
  Using cached rjsmin-1.2.0-cp310-cp310-manylinux2014_x86_64.whl (47 kB)
Collecting sqlparse>=0.2.2
  Using cached sqlparse-0.4.2-py3-none-any.whl (42 kB)
Collecting asgiref<4,>=3.4.1
  Using cached asgiref-3.4.1-py3-none-any.whl (25 kB)
Collecting argon2-cffi>=19.1.0
  Using cached argon2_cffi-21.3.0-py3-none-any.whl (14 kB)
Collecting argon2-cffi-bindings
  Using cached argon2_cffi_bindings-21.2.0-cp36-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (86 kB)
Collecting gitdb<5,>=4.0.1
  Using cached gitdb-4.0.9-py3-none-any.whl (63 kB)
Collecting smmap<6,>=3.0.1
  Using cached smmap-5.0.0-py3-none-any.whl (24 kB)
Collecting pyrsistent!=0.17.0,!=0.17.1,!=0.17.2,>=0.14.0
  Using cached pyrsistent-0.18.0-cp310-cp310-linux_x86_64.whl
Collecting attrs>=17.4.0
  Using cached attrs-21.4.0-py2.py3-none-any.whl (60 kB)
Collecting amqp<6.0.0,>=5.0.9
  Using cached amqp-5.0.9-py3-none-any.whl (50 kB)
Collecting et-xmlfile
  Using cached et_xmlfile-1.1.0-py3-none-any.whl (4.7 kB)
Collecting deprecated>=1.2.3
  Using cached Deprecated-1.2.13-py2.py3-none-any.whl (9.6 kB)
Collecting wrapt<2,>=1.10
  Using cached wrapt-1.13.3-cp310-cp310-manylinux_2_5_x86_64.manylinux1_x86_64.manylinux_2_12_x86_64.manylinux2010_x86_64.whl (81 kB)
Collecting urllib3<1.27,>=1.21.1
  Using cached urllib3-1.26.8-py2.py3-none-any.whl (138 kB)
Collecting certifi>=2017.4.17
  Using cached certifi-2021.10.8-py2.py3-none-any.whl (149 kB)
Collecting charset-normalizer~=2.0.0
  Using cached charset_normalizer-2.0.10-py3-none-any.whl (39 kB)
Collecting idna=1.1.9 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 2)) (1.1.17)
Requirement already satisfied: celery[redis]<5.3,>=5.0.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 3)) (5.2.3)
Requirement already satisfied: cssselect<1.2.0,>=1.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 4)) (1.1.0)
Requirement already satisfied: Cython<0.30,>=0.29.14 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 5)) (0.29.26)
Requirement already satisfied: diff-match-patch==20200713 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 6)) (20200713)
Requirement already satisfied: django-appconf<1.1,>=1.0.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 7)) (1.0.5)
Requirement already satisfied: django-compressor<3.2,>=2.4 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 8)) (3.1)
Requirement already satisfied: django-crispy-forms<1.13.1,>=1.9.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 9)) (1.13.0)
Requirement already satisfied: django-filter<22.0.0,>=2.4.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 10)) (21.1)
Requirement already satisfied: django-redis<6.0.0,>=4.11.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 11)) (5.2.0)
Requirement already satisfied: Django[argon2]<4.1,>=3.2 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 12)) (4.0.1)
Requirement already satisfied: djangorestframework<3.14.0,>=3.11.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 13)) (3.13.1)
Requirement already satisfied: filelock<3.5.0,>=3.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 14)) (3.4.2)
Requirement already satisfied: GitPython<3.2.0,>=2.1.15 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 15)) (3.1.26)
Requirement already satisfied: hiredis<2.1.0,>=1.0.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 16)) (2.0.0)
Requirement already satisfied: html2text<2020.1.17,>=2019.8.11 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 17)) (2020.1.16)
Requirement already satisfied: jellyfish!=0.8.3,!=0.8.4,!=0.8.5,!=0.8.6,!=0.8.7,!=0.8.8,<0.9.1,>=0.7.2 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 19)) (0.9.0)
Requirement already satisfied: jsonschema<4.4.0,>=3.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 20)) (4.3.3)
Requirement already satisfied: lxml<4.8.0,>=4.6.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 21)) (4.7.1)
Requirement already satisfied: misaka<2.2.0,>=2.1.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 22)) (2.1.1)
Requirement already satisfied: openpyxl!=3.0.2,<3.1,>=2.6.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 23)) (3.0.9)
Requirement already satisfied: Pillow<10.0.0,>=6.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 24)) (9.0.0)
Requirement already satisfied: pyahocorasick<1.5,>=1.4 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 25)) (1.4.2)
Requirement already satisfied: pycairo>=1.15.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 26)) (1.20.1)
Requirement already satisfied: Pygments<3.0,>=2.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 27)) (2.11.2)
Requirement already satisfied: pygobject>=3.27.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 28)) (3.42.0)
Requirement already satisfied: pyicumessageformat<1.1.0,>=1.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 29)) (1.0.0)
Requirement already satisfied: pyparsing<3.1.0,>=3.0.5 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 30)) (3.0.6)
Requirement already satisfied: python-dateutil>=2.8.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 31)) (2.8.2)
Requirement already satisfied: python-redis-lock<3.8.0,>=3.6.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 32)) (3.7.0)
Requirement already satisfied: requests<2.28.0,>=2.20.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 33)) (2.27.1)
Requirement already satisfied: sentry_sdk<1.6.0,>=0.13.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 34)) (1.5.2)
Requirement already satisfied: siphashc<3.0,>=1.2 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 35)) (2.1)
Requirement already satisfied: social-auth-app-django==5.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 36)) (5.0.0)
Requirement already satisfied: social-auth-core==4.1.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 37)) (4.1.0)
Requirement already satisfied: translate-toolkit<3.6.0,>=3.5.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 38)) (3.5.2)
Requirement already satisfied: translation-finder<3.0,>=2.7 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 39)) (2.10)
Requirement already satisfied: user-agents<2.3,>=2.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 40)) (2.2.0)
Requirement already satisfied: weblate-language-data>=2021.5 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 41)) (2022.1)
Requirement already satisfied: weblate-schemas==0.7 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements.txt (line 42)) (0.7)
Collecting aeidon<1.11.0,>=1.9.0
  Using cached aeidon-1.10.1-py3-none-any.whl (148 kB)
Collecting boto3<1.21.0,>=1.15.0
  Using cached boto3-1.20.33-py3-none-any.whl (131 kB)
Collecting chardet<5,>=3.0.4
  Using cached chardet-4.0.0-py2.py3-none-any.whl (178 kB)
Collecting django-auth-ldap<4.1.0,>=1.3.0
  Using cached django_auth_ldap-4.0.0-py3-none-any.whl (20 kB)
Collecting django-zxcvbn-password==2.1.1
  Using cached django_zxcvbn_password-2.1.1-py2.py3-none-any.whl (409 kB)
Collecting fluent.syntax<0.19,>=0.18.1
  Using cached fluent.syntax-0.18.1-py2.py3-none-any.whl (16 kB)
Collecting git-review>=1.27.0
  Using cached git_review-2.2.0-py3-none-any.whl (48 kB)
Collecting google-cloud-translate<3.7.0,>=3.0.0
  Using cached google_cloud_translate-3.6.1-py2.py3-none-any.whl (111 kB)
Collecting iniparse==0.5
  Using cached iniparse-0.5-py3-none-any.whl (24 kB)
Collecting Mercurial>=5.2
  Using cached mercurial-6.0.1-cp310-cp310-linux_x86_64.whl
Collecting phply==1.2.5
  Using cached phply-1.2.5-py2.py3-none-any.whl (74 kB)
Collecting psycopg2-binary<2.10.0,>=2.7.7
  Using cached psycopg2_binary-2.9.3-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (3.0 MB)
Collecting python-akismet<0.5,>=0.4.2
  Using cached python-akismet-0.4.2.tar.gz (9.4 kB)
Collecting python3-saml>=1.2.1
  Using cached python3_saml-1.12.0-py3-none-any.whl (76 kB)
Requirement already satisfied: ruamel.yaml<0.18.0,>=0.16.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from -r /home/yaoying/weblate/requirements-optional.txt (line 33)) (0.17.20)
Collecting tesserocr>=2.3.0
  Using cached tesserocr-2.5.2.tar.gz (57 kB)
Collecting zeep<4.2.0,>=3.2.0
  Using cached zeep-4.1.0-py2.py3-none-any.whl (100 kB)
Requirement already satisfied: requests-oauthlib>=0.6.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from social-auth-core==4.1.0->-r /home/yaoying/weblate/requirements.txt (line 37)) (1.3.0)
Requirement already satisfied: oauthlib>=1.0.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from social-auth-core==4.1.0->-r /home/yaoying/weblate/requirements.txt (line 37)) (3.1.1)
Requirement already satisfied: python3-openid>=3.0.10 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from social-auth-core==4.1.0->-r /home/yaoying/weblate/requirements.txt (line 37)) (3.2.0)
Requirement already satisfied: defusedxml>=0.5.0rc1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from social-auth-core==4.1.0->-r /home/yaoying/weblate/requirements.txt (line 37)) (0.7.1)
Requirement already satisfied: cryptography>=1.4 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from social-auth-core==4.1.0->-r /home/yaoying/weblate/requirements.txt (line 37)) (36.0.1)
Requirement already satisfied: PyJWT>=2.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from social-auth-core==4.1.0->-r /home/yaoying/weblate/requirements.txt (line 37)) (2.3.0)
Collecting zxcvbn
  Using cached zxcvbn-4.4.28.tar.gz (407 kB)
Requirement already satisfied: six in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from iniparse==0.5->-r /home/yaoying/weblate/requirements-optional.txt (line 19)) (1.16.0)
Collecting ply
  Using cached ply-3.11-py2.py3-none-any.whl (49 kB)
Collecting python-jose>=3.0.0
  Using cached python_jose-3.3.0-py2.py3-none-any.whl (33 kB)
Requirement already satisfied: packaging in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from bleach<5.0.0,>=3.1.1->-r /home/yaoying/weblate/requirements.txt (line 1)) (21.3)
Requirement already satisfied: webencodings in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from bleach<5.0.0,>=3.1.1->-r /home/yaoying/weblate/requirements.txt (line 1)) (0.5.1)
Requirement already satisfied: kombu<6.0,>=5.2.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (5.2.3)
Requirement already satisfied: click-plugins>=1.1.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (1.1.1)
Requirement already satisfied: pytz>=2021.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (2021.3)
Requirement already satisfied: setuptools<59.7.0,>=59.1.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (59.6.0)
Requirement already satisfied: click<9.0,>=8.0.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (8.0.3)
Requirement already satisfied: click-didyoumean>=0.0.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (0.3.0)
Requirement already satisfied: billiard<4.0,>=3.6.4.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (3.6.4.0)
Requirement already satisfied: click-repl>=0.2.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (0.2.0)
Requirement already satisfied: vine<6.0,>=5.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (5.0.0)
Requirement already satisfied: redis!=4.0.0,!=4.0.1,>=3.4.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (4.1.0)
Requirement already satisfied: rjsmin==1.2.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from django-compressor<3.2,>=2.4->-r /home/yaoying/weblate/requirements.txt (line 8)) (1.2.0)
Requirement already satisfied: rcssmin==1.1.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from django-compressor<3.2,>=2.4->-r /home/yaoying/weblate/requirements.txt (line 8)) (1.1.0)
Requirement already satisfied: sqlparse>=0.2.2 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from Django[argon2]<4.1,>=3.2->-r /home/yaoying/weblate/requirements.txt (line 12)) (0.4.2)
Requirement already satisfied: asgiref<4,>=3.4.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from Django[argon2]<4.1,>=3.2->-r /home/yaoying/weblate/requirements.txt (line 12)) (3.4.1)
Requirement already satisfied: argon2-cffi>=19.1.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from Django[argon2]<4.1,>=3.2->-r /home/yaoying/weblate/requirements.txt (line 12)) (21.3.0)
Requirement already satisfied: gitdb<5,>=4.0.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from GitPython<3.2.0,>=2.1.15->-r /home/yaoying/weblate/requirements.txt (line 15)) (4.0.9)
Requirement already satisfied: attrs>=17.4.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from jsonschema<4.4.0,>=3.0.0->-r /home/yaoying/weblate/requirements.txt (line 20)) (21.4.0)
Requirement already satisfied: pyrsistent!=0.17.0,!=0.17.1,!=0.17.2,>=0.14.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from jsonschema<4.4.0,>=3.0.0->-r /home/yaoying/weblate/requirements.txt (line 20)) (0.18.0)
Requirement already satisfied: cffi>=1.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from misaka<2.2.0,>=2.1.0->-r /home/yaoying/weblate/requirements.txt (line 22)) (1.15.0)
Requirement already satisfied: et-xmlfile in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from openpyxl!=3.0.2,<3.1,>=2.6.0->-r /home/yaoying/weblate/requirements.txt (line 23)) (1.1.0)
Requirement already satisfied: certifi>=2017.4.17 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from requests<2.28.0,>=2.20.0->-r /home/yaoying/weblate/requirements.txt (line 33)) (2021.10.8)
Requirement already satisfied: charset-normalizer~=2.0.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from requests<2.28.0,>=2.20.0->-r /home/yaoying/weblate/requirements.txt (line 33)) (2.0.10)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from requests<2.28.0,>=2.20.0->-r /home/yaoying/weblate/requirements.txt (line 33)) (1.26.8)
Requirement already satisfied: idna<4,>=2.5 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from requests<2.28.0,>=2.20.0->-r /home/yaoying/weblate/requirements.txt (line 33)) (3.3)
Requirement already satisfied: ua-parser>=0.10.0 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from user-agents<2.3,>=2.0->-r /home/yaoying/weblate/requirements.txt (line 40)) (0.10.0)
Collecting s3transfer<0.6.0,>=0.5.0
  Using cached s3transfer-0.5.0-py3-none-any.whl (79 kB)
Collecting botocore<1.24.0,>=1.23.33
  Using cached botocore-1.23.33-py3-none-any.whl (8.5 MB)
Collecting jmespath<1.0.0,>=0.7.1
  Using cached jmespath-0.10.0-py2.py3-none-any.whl (24 kB)
Collecting python-ldap>=3.1
  Using cached python_ldap-3.4.0-cp310-cp310-linux_x86_64.whl
Collecting google-cloud-core<3.0.0dev,>=1.3.0
  Using cached google_cloud_core-2.2.1-py2.py3-none-any.whl (29 kB)
Collecting proto-plus>=0.4.0
  Using cached proto_plus-1.19.8-py3-none-any.whl (45 kB)
Collecting google-api-core[grpc]<3.0.0dev,>=1.28.0
  Using cached google_api_core-2.4.0-py2.py3-none-any.whl (111 kB)
Collecting isodate>=0.5.0
  Using cached isodate-0.6.1-py2.py3-none-any.whl (41 kB)
Collecting xmlsec>=1.0.5
  Using cached xmlsec-1.3.12-cp310-cp310-linux_x86_64.whl
Requirement already satisfied: ruamel.yaml.clib>=0.2.6 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from ruamel.yaml<0.18.0,>=0.16.0->-r /home/yaoying/weblate/requirements-optional.txt (line 33)) (0.2.6)
Collecting requests-file>=1.5.1
  Using cached requests_file-1.5.1-py2.py3-none-any.whl (3.7 kB)
Collecting requests-toolbelt>=0.7.1
  Using cached requests_toolbelt-0.9.1-py2.py3-none-any.whl (54 kB)
Collecting cached-property>=1.3.0
  Using cached cached_property-1.5.2-py2.py3-none-any.whl (7.6 kB)
Collecting platformdirs>=1.4.0
  Using cached platformdirs-2.4.1-py3-none-any.whl (14 kB)
Requirement already satisfied: argon2-cffi-bindings in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from argon2-cffi>=19.1.0->Django[argon2]<4.1,>=3.2->-r /home/yaoying/weblate/requirements.txt (line 12)) (21.2.0)
Requirement already satisfied: pycparser in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from cffi>=1.0.0->misaka<2.2.0,>=2.1.0->-r /home/yaoying/weblate/requirements.txt (line 22)) (2.21)
Requirement already satisfied: prompt-toolkit in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from click-repl>=0.2.0->celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (3.0.24)
Requirement already satisfied: smmap<6,>=3.0.1 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from gitdb<5,>=4.0.1->GitPython<3.2.0,>=2.1.15->-r /home/yaoying/weblate/requirements.txt (line 15)) (5.0.0)
Collecting google-auth<3.0dev,>=1.25.0
  Using cached google_auth-2.3.3-py2.py3-none-any.whl (155 kB)
Collecting protobuf>=3.12.0
  Using cached protobuf-3.19.3-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (1.1 MB)
Collecting googleapis-common-protos<2.0dev,>=1.52.0
  Using cached googleapis_common_protos-1.54.0-py2.py3-none-any.whl (207 kB)
Collecting grpcio<2.0dev,>=1.33.2
  Using cached grpcio-1.43.0-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (4.1 MB)
Collecting grpcio-status<2.0dev,>=1.33.2
  Using cached grpcio_status-1.43.0-py3-none-any.whl (10.0 kB)
Collecting rsa<5,>=3.1.4
  Using cached rsa-4.8-py3-none-any.whl (39 kB)
Collecting cachetools<5.0,>=2.0.0
  Using cached cachetools-4.2.4-py3-none-any.whl (10 kB)
Collecting pyasn1-modules>=0.2.1
  Using cached pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
Requirement already satisfied: amqp<6.0.0,>=5.0.9 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from kombu<6.0,>=5.2.3->celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (5.0.9)
Collecting pyasn1<0.5.0,>=0.4.6
  Using cached pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
Collecting ecdsa!=0.15
  Using cached ecdsa-0.17.0-py2.py3-none-any.whl (119 kB)
Requirement already satisfied: deprecated>=1.2.3 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from redis!=4.0.0,!=4.0.1,>=3.4.1->celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (1.2.13)
Requirement already satisfied: wrapt<2,>=1.10 in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from deprecated>=1.2.3->redis!=4.0.0,!=4.0.1,>=3.4.1->celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (1.13.3)
Requirement already satisfied: wcwidth in ./.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages (from prompt-toolkit->click-repl>=0.2.0->celery[redis]<5.3,>=5.0.3->-r /home/yaoying/weblate/requirements.txt (line 3)) (0.2.5)
Using legacy 'setup.py install' for python-akismet, since package 'wheel' is not installed.
Using legacy 'setup.py install' for tesserocr, since package 'wheel' is not installed.
Using legacy 'setup.py install' for zxcvbn, since package 'wheel' is not installed.
Installing collected packages: pyasn1, rsa, pyasn1-modules, protobuf, cachetools, jmespath, grpcio, googleapis-common-protos, google-auth, grpcio-status, google-api-core, ecdsa, botocore, zxcvbn, xmlsec, s3transfer, requests-toolbelt, requests-file, python-ldap, python-jose, proto-plus, ply, platformdirs, isodate, google-cloud-core, chardet, cached-property, zeep, tesserocr, python3-saml, python-akismet, psycopg2-binary, phply, Mercurial, iniparse, google-cloud-translate, git-review, fluent.syntax, django-zxcvbn-password, django-auth-ldap, boto3, aeidon
    Running setup.py install for zxcvbn ... done
    Running setup.py install for tesserocr ... done
    Running setup.py install for python-akismet ... done
Successfully installed Mercurial-6.0.1 aeidon-1.10.1 boto3-1.20.33 botocore-1.23.33 cached-property-1.5.2 cachetools-4.2.4 chardet-4.0.0 django-auth-ldap-4.0.0 django-zxcvbn-password-2.1.1 ecdsa-0.17.0 fluent.syntax-0.18.1 git-review-2.2.0 google-api-core-2.4.0 google-auth-2.3.3 google-cloud-core-2.2.1 google-cloud-translate-3.6.1 googleapis-common-protos-1.54.0 grpcio-1.43.0 grpcio-status-1.43.0 iniparse-0.5 isodate-0.6.1 jmespath-0.10.0 phply-1.2.5 platformdirs-2.4.1 ply-3.11 proto-plus-1.19.8 protobuf-3.19.3 psycopg2-binary-2.9.3 pyasn1-0.4.8 pyasn1-modules-0.2.8 python-akismet-0.4.2 python-jose-3.3.0 python-ldap-3.4.0 python3-saml-1.12.0 requests-file-1.5.1 requests-toolbelt-0.9.1 rsa-4.8 s3transfer-0.5.0 tesserocr-2.5.2 xmlsec-1.3.12 zeep-4.1.0 zxcvbn-4.4.28
WARNING: You are using pip version 21.2.4; however, version 21.3.1 is available.
You should consider upgrading via the '/home/yaoying/.pyenv/versions/3.10.1/envs/weblate/bin/python3.10 -m pip install --upgrade pip' command.                                                                                            
(weblate) yaoying@yaoying-PC:~$ weblate migrate
[2022-01-12 12:04:17,093: WARNING/89265] Handled exception: SystemError: ffi_prep_closure(): bad user_data (it seems that the version of the libffi library seen at runtime is different from the 'ffi.h' file seen at compile-time)
Traceback (most recent call last):
  File "/home/yaoying/.pyenv/versions/weblate/bin/weblate", line 33, in 
    sys.exit(load_entry_point('Weblate', 'console_scripts', 'weblate')())
  File "/home/yaoying/weblate/weblate/runner.py", line 34, in main
    utility.execute()
  File "/home/yaoying/.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages/django/core/management/__init__.py", line 401, in execute
    django.setup()
  File "/home/yaoying/.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages/django/__init__.py", line 24, in setup
    apps.populate(settings.INSTALLED_APPS)
  File "/home/yaoying/.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages/django/apps/registry.py", line 114, in populate
    app_config.import_models()
  File "/home/yaoying/.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages/django/apps/config.py", line 300, in import_models
    self.models_module = import_module(models_module_name)
  File "/home/yaoying/.pyenv/versions/3.10.1/lib/python3.10/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "", line 1050, in _gcd_import
  File "", line 1027, in _find_and_load
  File "", line 1006, in _find_and_load_unlocked
  File "", line 688, in _load_unlocked
  File "", line 883, in exec_module
  File "", line 241, in _call_with_frames_removed
  File "/home/yaoying/weblate/weblate/accounts/models.py", line 40, in 
    from weblate.accounts.data import create_default_notifications
  File "/home/yaoying/weblate/weblate/accounts/data.py", line 20, in 
    from weblate.accounts.notifications import (
  File "/home/yaoying/weblate/weblate/accounts/notifications.py", line 41, in 
    from weblate.utils.markdown import get_mention_users
  File "/home/yaoying/weblate/weblate/utils/markdown.py", line 24, in 
    import misaka
  File "/home/yaoying/.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages/misaka/__init__.py", line 3, in 
    from .api import *
  File "/home/yaoying/.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages/misaka/api.py", line 10, in 
    from .callbacks import python_callbacks, to_string
  File "/home/yaoying/.pyenv/versions/3.10.1/envs/weblate/lib/python3.10/site-packages/misaka/callbacks.py", line 10, in 
    def cb_blockcode(ob, text, lang, data):
SystemError: ffi_prep_closure(): bad user_data (it seems that the version of the libffi library seen at runtime is different from the 'ffi.h' file seen at compile-time)

ReplyFavoriteView the author
All Replies
Feng Yu
deepin
2022-01-12 16:24
#1

你应该是自己搞过依赖,而且还自己搞坏了

it seems that the version of the libffi library seen at runtime is different from the 'ffi.h' file seen at compile-time

这句话是说你的libffi类库和你编译时指定的ffi.h头文件的版本不匹配。如果你实在搞不定编译安装,我看官方文档提供了Docker进行运行,还提供了现成的docker-compose配置模板,直接用Docker环境运行算了

ReplyView the author
深圳市耀影科技有限公司
deepin
2022-01-13 04:49
#2
Feng Yu

你应该是自己搞过依赖,而且还自己搞坏了

it seems that the version of the libffi library seen at runtime is different from the 'ffi.h' file seen at compile-time

这句话是说你的libffi类库和你编译时指定的ffi.h头文件的版本不匹配。如果你实在搞不定编译安装,我看官方文档提供了Docker进行运行,还提供了现成的docker-compose配置模板,直接用Docker环境运行算了

  • 依赖的话,我用的是 虚拟环境, 我晚点用一个全新的系统来试试
    • DOCER这个不会用,,之前学过,后面忘记啦,但是总是感觉看不到的东西,不安全
ReplyView the author
深圳市耀影科技有限公司
deepin
2022-01-13 14:59
#3
Feng Yu

你应该是自己搞过依赖,而且还自己搞坏了

it seems that the version of the libffi library seen at runtime is different from the 'ffi.h' file seen at compile-time

这句话是说你的libffi类库和你编译时指定的ffi.h头文件的版本不匹配。如果你实在搞不定编译安装,我看官方文档提供了Docker进行运行,还提供了现成的docker-compose配置模板,直接用Docker环境运行算了

不行啊 我全新系统安装依旧报错

ReplyView the author
深圳市耀影科技有限公司
deepin
2022-01-13 15:41
#4
深圳市耀影科技有限公司
  • 依赖的话,我用的是 虚拟环境, 我晚点用一个全新的系统来试试
    • DOCER这个不会用,,之前学过,后面忘记啦,但是总是感觉看不到的东西,不安全

具体是什么原因,不知道,

在源码项目上回复了一个方法有效:https://github.com/WeblateOrg/weblate/issues/7082

尝试在不使用二进制轮的情况下重新安装 cffi:

pip install --force-reinstall --no-binary :all: cffi

PS:也发布在 SO 上:https : //stackoverflow.com/a/70694565/225718

ReplyView the author
Use Markdown Editor
Loading