[Seek Help] Intel Video Card - VAAPI not work
Community Discussion 613 views · 5 replies
Tofloor
poster avatar
su******rt@gmail.com
deepin
2022-01-25 16:24
Author

Hello there,

I would like to use Geforce Now in Deepin, but that is run fluid, it need HW decode in Chrome browser. On Fedora, i able to use it, but on Deepin, i can not start it via VAAPI support.

I install non-free Intel drivers and set all flags, that need, but not work...

Somebody able to use it in Deepin?

Reply Favorite View the author
All Replies
pi******ak@gmail.com
deepin
2022-01-26 15:39
#1

Hi There, not exactly the same scenario but I've installed libva packages from debian testing (versions 2.13) and updated the 2.4 installed version and hardware decode started working for me.

Kind regards

Reply View the author
pi******ak@gmail.com
deepin
2022-01-26 16:40
#2

Follow this link: https://packages.debian.org/search?keywords=libva&searchon=names&suite=all§ion=all

I've personally installed:

libva-drm2_2

libva-glx2_2

libva-wayland2_2

libva-x11-2_2

libva2_2

You can try installing 2.10 versions from debian stable as deepin is based on it apparently and it may work as well. Good luck

Reply View the author
su******rt@gmail.com
deepin
2022-01-27 14:51
#3
pi******ak@gmail.com

Follow this link: https://packages.debian.org/search?keywords=libva&searchon=names&suite=all§ion=all

I've personally installed:

libva-drm2_2

libva-glx2_2

libva-wayland2_2

libva-x11-2_2

libva2_2

You can try installing 2.10 versions from debian stable as deepin is based on it apparently and it may work as well. Good luck

It solve the problem, thanks!!

(i think if V23 will be avaliable, not need to do this type of "trick")

Reply View the author
pi******ak@gmail.com
deepin
2022-01-27 20:53
#4

Glad I could help :)

That's right, I'm running V23 right now where packages according to versions seem to be based on debian stable, not like 20.4s debian old stable. Decoding works out of the box.

Reply View the author
su******rt@gmail.com
deepin
2022-03-11 11:46
#5

It broke it again... with google 99.x release, it need libva 2.14 version. (it only found in debian unstable branch)

V23 provide 2.10 libva.

If possible, please update it.

Reply View the author
Use Markdown Editor
Loading