[Seek Help] Can't install libc6-amd64 >=2.28
Community Discussion 344 views · 2 replies
Tofloor
poster avatar
shixx01
deepin
2022-05-09 19:04
Author

Hi at all,

first of all, I'm a noobie using linux and the terminal ect.

I tried to install the KXStudio repositories but it didn't work. Nor with the .deb package as well as with the terminal.

sudo apt-get update

# Install required dependencies if needed
sudo apt-get install apt-transport-https gpgv wget

# Download package file
wget https://launchpad.net/~kxstudio-debian/+archive/kxstudio/+files/kxstudio-repos_11.0.1_all.deb

# Install it
sudo dpkg -i kxstudio-repos_11.0.1_all.deb

At the last step my output ist:

tom@tom-PC:~$ sudo dpkg -i kxstudio-repos_11.0.1_all.deb
Passwort:
Verifizierung erfolgreich
dpkg: Vor-Abhängigkeitsproblem betreffend kxstudio-repos_11.0.1_all.deb, welches kxstudio-repos enthält:
 kxstudio-repos hängt (vorher) von libc6 (>= 2.31~) ab
  libc6:amd64 ist installiert, ist aber Version 2.28.19-1+dde.

dpkg: Fehler beim Bearbeiten des Archivs kxstudio-repos_11.0.1_all.deb (--install):
 Vor-Abhängigkeitsproblem - kxstudio-repos wird nicht installiert
Fehler traten auf beim Bearbeiten von:
 kxstudio-repos_11.0.1_all.deb

If I understand this correctly, there is a dependency from libc6 (>= 2.31~) but version libc6 2.28.19 is installed.
If i try this:

sudo apt-get update -y
sudo apt-get install -y libc6-amd64

my output is:

tom@tom-PC:~$ sudo apt-get install -y libc6-amd64
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.   
Statusinformationen werden eingelesen.... Fertig
libc6-amd64:i386 ist schon die neueste Version (2.28.19-1+dde).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 336 nicht aktualisiert.

It seems that 2.28.19 is the newest version I can install. But why is this so?

OS: Deepin 20.3

Reply Favorite View the author
All Replies
babyfengfjx
deepin testing team
2022-05-10 03:39
#1

I am sorry that the current system does not provide a higher version of libc6, so perhaps you can only try by installing a higher version yourself in some other way.

Reply View the author
shixx01
deepin
2022-05-10 19:22
#2

thanks for your reply. Can you give me a hint how I can try this "other way" to install a higher Version?

Reply View the author
Use Markdown Editor
Loading