[Newbies] Change default audio sample rate
Newbies 211 views · 3 replies
Tofloor
poster avatar
zerrax
deepin
2022-05-17 09:12
Author

Hi all,

I would like to change my default audio sample rate to 32bit 192 kHz because I would like to record my Vinyl LP's
I have Huawei MateBook X Pro running Deepin Linux 20.5
I want to use analogue input, with stereo 3.5 mm mini jack cable which is connected to my phone preamp (cinch)
Can anybody help me to change the default audio recording settings to 24/32bit 192kHz?

I installed "Pavucontrol"
sudo apt install pavucontrol

But I can't change the default recording sample rate there...

When list my audio hardware with the "arecord" command I get:

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC256 Analog [ALC256 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

I have "HDA Intel PCH" sound card in my Huawei MateBook X Pro

The command "aplay" gives the following info:

aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC256 Analog [ALC256 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0

The command: lsmod|grep audio -i gives the following info:

ledtrig_audio 16384 3 snd_hda_codec_generic,huawei_wmi,snd_sof

image.png

Reply Favorite View the author
All Replies
babyfengfjx
deepin testing team
2022-05-18 02:23
#1

Hi, I'm very sorry to see your question only now, for the setting of recording parameters, you should need professional audio editing software to handle it, maybe this application can help you:https://github.com/audacity/audacity/releases

Reply View the author
zerrax
deepin
2022-05-28 14:01
#2

example.png

Changing a higher bit rate into Audiacity doesn't make your recording better sound quaility... see exanple
Still the "default bitrate" (32bit 44.1 kHz will be used...
The internal Intel HDA soundcard can record in 32bit 192 kHz, so I would like to change the " default audio bitrate" to the max setting possible....
I would like to know how the change it in Deepin OS

Reply View the author
zerrax
deepin
2022-06-01 18:48
#3

I found the solution, in terminal type:

sudo nano /etc/pulse/daemon.conf

Then change it to these settings:

default-sample-format = float32le
default-sample-rate = 192000
alternate-sample-rate = 192000

(Crtl +O) to save

Now it works! I can record in Highest Audio quality

Reply View the author
Use Markdown Editor
Loading