[Topic DIscussion] Reinstall NVIDIA Video Driver (Help needed) Deepin 20.6
deepin Talks 503 views · 6 replies
Tofloor
poster avatar
fa******en@use.startmail.com
deepin
2022-06-01 10:46
Author

I upgraded to deepin 20.6 using sudo apt update && sudo apt upgrade instead of using the " CONTROL PANEL / UPDATE TOOL"

I endedup with a NON FULLY FUNCTIONNAL Video driver

I sudo apt-get remove --purge '^nvidia-.*'

After a few reboot Deeping was working again

I then tried sudo apt install nvidia-driver nvidia-smi nvidia-settings

Result, my deepin (that was very stable before I messed it up) does not recognize my 2nd monitor anymore, I can't change screen resolution and I've got some " White underscores" (white bar) blinking on my screens in an intermittent way

QUESTION : HOW COULD I REINSTALL THE RIGHT NVIDIA DRIVER and make sure everything is ok? Deepin still work well but my NVISIA video driver installation is not right.

Tks for helping fixing my stupide moves...

Yoda

Reply Favorite View the author
All Replies
fa******en@use.startmail.com
deepin
2022-06-01 14:09
#1

if I try to install NVidia ver 510... myself

WARNING: The NVIDIA GeForce GT 710 GPU installed in this system is supported through the NVIDIA 470.xx legacy Linux graphics drivers. Please visit http://www.nvidia.com/object/unix.html
for more information. The 510.39.01 NVIDIA Linux graphics driver will ignore this GPU.

Reply View the author
fa******en@use.startmail.com
deepin
2022-06-01 14:26
#2

if I try to install the NVIDIA ver 470.... I get this

You appear to be running an X server; please exit X before installing. For further details, please see the section INSTALLING THE NVIDIA DRIVER in the README available on the
Linux driver download page at www.nvidia.com.

Reply View the author
fa******en@use.startmail.com
deepin
2022-06-01 14:26
#3
It has been deleted!
lixiaobai
deepin
2022-06-04 06:05
#4

按照NVIDIA官方的说法,基于开普勒架构的GeForce600和GeForce700系列,在2021年8月开始停止功能更新,在2024年9年彻底停止更新了。也就是说,这2个系列的驱动,应该就永远停留在470.xx版本了。我看你的显卡是GT710,那你的显卡适用这个policy的。

这次deepin 20.6升级,把显卡驱动升级为510版本了,所以出现这个问题了。我理解官方应该在仓库保留470.xx作为Legacy的版本,不知道深度官方有没有意识到这个问题。

我也遇到了这个问题,最大的影响是分辨率不能调整了,是那种800*600很低的那种。我是自己下载官网的驱动解决了。

Reply View the author
lixiaobai
deepin
2022-06-04 06:10
#5

To reply to you in English, you have to install Nvidia driver version 470.xx, bacause the current version 510.xx doesn't support your GPU. For now, there is no official soluation, and you can download the version 470.xx driver from Nvidia official website and install by yourself.

Reply View the author
root
deepin
2022-06-05 13:19
#6

GT710 = GT520 (Fermi)

470.xx and 510.xx will not work

Fermi use nvidia-legacy-390xx-driver

sudo apt install nvidia-legacy-390xx-driver

Reply View the author
Use Markdown Editor
Loading