[Share Experiences] Energy profile - My solution - Suggestion
Experiences and Insight 524 views · 2 replies
Tofloor
poster avatar
tt******ng@hotmail.com
deepin
2022-06-25 17:02
Author

With the power profile selection in the control center, currently only 2 options "powersave" and "balanced".
When I selected "powersave" the CPU usage was very high, very slow with low frequency and low cpu temperature and little fan use and when I switched to "balanced" it increased the frequency a lot and very high the temperature and a lot of fan use with minimal processes.

I found a solution on the web, which works fine for me, and I share it and it would be good that in the next updates, in the energy profile, more profiles can be selected, such as

Power save
Conservative
Balanced
Performance

My solution ,Use with care, at your risk

All in terminal

for supported profile

$ grep . /sys/devices/system/cpu/cpufreq/policy*/energy_performance*

and then make according to the desired energy profile

"POWERSAVE"

$ echo powersave | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

$ echo power | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

$ grep . /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

"CONSERVATIVE"
$ echo powersave | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
$ echo balance_power | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

$ grep . /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

"ONDEMAND"
$ echo powersave | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
$ echo balance_performance | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

$ grep . /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

"PERFORMANCE"
$ echo powersave | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
$ echo performance | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
$ echo performance | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

$ grep . /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

and finally an executable file at startup

#!/bin/sh
echo powersave | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
echo balance_performance | sudo tee /sys/devices/system/cpu/cpufreq/policy*/energy_performance_preference

power.png

balance_power.png

balance_performance.png

performance.png

vacio 0.png

Dispositivo.png

Reply Favorite View the author
All Replies
Octavian-Q
deepin
2022-06-30 09:13
#1

Performance Mode is already available for some desktop devices. I am not sure yet why not all of them have it 🤔

2CA9EDA9-25E2-40C0-989E-08739508DA45.png

Anyway good suggestions

Reply View the author
tt******ng@hotmail.com
deepin
2022-06-30 17:09
#2

ok, maybe it's because in a notebook , only 2 configuration options is poor , when there is the possibility of minimum having four, without managing the turbo boost, the frequency range is 0.4GHz - 2.4GHz and with 4.2GHz turbo. In balanced works in 2.7GHz at 3.9Ghz and about 60 C - 85 C , with little demand for work.

I tried Ubuntu on the same computer, it has 3 configuration options and it works very fine in balanced

Captura de pantalla_dde-control-center_20220630134411.png

Reply View the author
Use Markdown Editor
Loading