[Seek Help] HP打印机驱动装不上,好烦啊,有没有老哥来帮忙
Experiences and Insight 414 views · 26 replies
Tofloor
poster avatar
135******26
deepin
2022-06-28 08:44
Author

截图_选择区域_20220628163746.jpg

用自动安装的失败了,但是故障排查是全绿

截图_选择区域_20220628164150.jpg

手动选择驱动后又报另外个错,故常排查也是全绿

截图_选择区域_20220628164338.jpg

应用商店里已经有驱动了,就是添加不了打印机,老哥们是什么问题啊

Reply Favorite View the author
All Replies
吉吉如律令
Moderator
2022-06-28 10:42
#1

要不试试去官网找找有没有官方的linux驱动?

Reply View the author
qq8645
deepin
2022-06-28 10:51
#2

试一下以下方法吧

(1)删除已安装的驱动;

安装hplip-gui:sudo apt install hplip-gui;接着输入:hp-plugin, 在显示的信息中找到打印系统版本,如:

...Printing System (ver. 3.20.11)...

(2)到https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/网站下载对应版本2个plugin文件:hplip-3.20.11-plugin.run和asc(貌似需要用下载器下载);

(3)在弹出的plug-in installer界面中,选择第二种安装方式,即...(advanced),选择下载的plugin文件进行安装

(4)添加打印机

Reply View the author
186******75
deepin
2022-06-28 11:24
#3
qq8645

试一下以下方法吧

(1)删除已安装的驱动;

安装hplip-gui:sudo apt install hplip-gui;接着输入:hp-plugin, 在显示的信息中找到打印系统版本,如:

...Printing System (ver. 3.20.11)...

(2)到https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/网站下载对应版本2个plugin文件:hplip-3.20.11-plugin.run和asc(貌似需要用下载器下载);

(3)在弹出的plug-in installer界面中,选择第二种安装方式,即...(advanced),选择下载的plugin文件进行安装

(4)添加打印机

按你的方法,但是选择了后,下一步的按钮是灰色的呀,不能点击。

Reply View the author
186******75
deepin
2022-06-28 11:32
#4
186******75

按你的方法,但是选择了后,下一步的按钮是灰色的呀,不能点击。

截图_选择区域_20220628192858.png

Reply View the author
qq8645
deepin
2022-06-28 12:04
#5
186******75

截图_选择区域_20220628192858.png

确保那2个文件的版本号与系统显示的一致,确保2个文件在同一文件夹。不下20次安装,没有失败。

Reply View the author
186******75
deepin
2022-06-28 13:15
#6
qq8645

确保那2个文件的版本号与系统显示的一致,确保2个文件在同一文件夹。不下20次安装,没有失败。

截图_20220628211350.png
截图_20220628211148.png还是灰色的

Reply View the author
186******75
deepin
2022-06-28 13:42
#7

你最好安装一下相应打印型号的ppd文件,一般会成功的。

Reply View the author
135******26
deepin
2022-06-29 01:10
#8
吉吉如律令

要不试试去官网找找有没有官方的linux驱动?

官网没有这个型号的打印机驱动,太绝了,连Windows的驱动都没

Reply View the author
qq8645
deepin
2022-06-29 02:07
#9
186******75

截图_20220628211350.png
截图_20220628211148.png还是灰色的

显示的打印系统版本明明是ver.3.18.12,你下载的版本却是3.20.11。

Reply View the author
135******26
deepin
2022-06-29 02:14
#10
qq8645

试一下以下方法吧

(1)删除已安装的驱动;

安装hplip-gui:sudo apt install hplip-gui;接着输入:hp-plugin, 在显示的信息中找到打印系统版本,如:

...Printing System (ver. 3.20.11)...

(2)到https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/网站下载对应版本2个plugin文件:hplip-3.20.11-plugin.run和asc(貌似需要用下载器下载);

(3)在弹出的plug-in installer界面中,选择第二种安装方式,即...(advanced),选择下载的plugin文件进行安装

(4)添加打印机

截图_选择区域_20220629101117.jpg

老哥,我按你的指导装上驱动了,添加打印机报这个错,是防火墙问题吗

Reply View the author
186******75
deepin
2022-06-29 02:55
#11
qq8645

显示的打印系统版本明明是ver.3.18.12,你下载的版本却是3.20.11。

因为打印机比较新ver.3.18.12没有驱动,因此只能下3.20.11,最后我总结出来了,只要在hplip-3.20.11-plugin.run文件中提取ppd文件,然后安装ppd文件是最方便的。

Reply View the author
135******26
deepin
2022-06-29 03:17
#12
186******75

因为打印机比较新ver.3.18.12没有驱动,因此只能下3.20.11,最后我总结出来了,只要在hplip-3.20.11-plugin.run文件中提取ppd文件,然后安装ppd文件是最方便的。

怎么提取PPD文件啊老哥

Reply View the author
186******75
deepin
2022-06-29 06:04
#13
135******26

怎么提取PPD文件啊老哥

你打印机是什么型号的?

Reply View the author
186******75
deepin
2022-06-29 06:11
#14

https://bbs.deepin.org/post/206429

Reply View the author
135******26
deepin
2022-06-29 06:12
#15
186******75

你打印机是什么型号的?

用终端命令看的是这个型号 hplip-3.18.12-plugin

打印机型号是HP LaserJet MFP M72625dn

Reply View the author
186******75
deepin
2022-06-29 06:14
#16
135******26

用终端命令看的是这个型号 hplip-3.18.12-plugin

打印机型号是HP LaserJet MFP M72625dn

hplip-3.18.12-plugin版本太旧了,你这个可能是新机型。

Reply View the author
135******26
deepin
2022-06-29 06:17
#17
186******75

hplip-3.18.12-plugin版本太旧了,你这个可能是新机型。

你那个3.20.11我能用吗

Reply View the author
186******75
deepin
2022-06-29 06:30
#18

3.20.11也没有你那个型号,可能你那款是刚出来的

Reply View the author
135******26
deepin
2022-06-29 06:33
#19
186******75

3.20.11也没有你那个型号,可能你那款是刚出来的

https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/

这个网站里的驱动怎么看有没有我这个型号的驱动啊,完全无从下手😭

Reply View the author
186******75
deepin
2022-06-29 06:42
#20
135******26

https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/

这个网站里的驱动怎么看有没有我这个型号的驱动啊,完全无从下手😭

你把打印机插上,然后到hp的官网去找一下驱动,这样可能性大一些!一般匹配的好一点

Reply View the author

1 / 2
To page
Use Markdown Editor
Loading