[Share Experiences] [已解决]6月28前后新装20.6商店TIM微信QQ安装提示依赖不足方案一 Resolved
Experiences and Insight 379 views · 9 replies
Tofloor
poster avatar
滢泷迷雾
deepin
2022-06-29 08:11
Author

经过替换默认要安装的依赖包版本(就是 sudo apt-cache madison 查询然后挨个试)一直递归。

终于成功了,不知道能否适用与所有用户,暂时分享出来仅供参考:

根据倒推顺序先安装一个

sudo apt install l*coregtk-4.0-18=2.36.0.4-3+dde

再安装依赖它的一个包

sudo apt install libwebkit2gtk-4.0-37=2.36.0.4-3+dde

然后应该就能安装你们想安装的软件了,

加上 =版本号就是因为这两个包最新版的依赖在仓库里解决不了,只好退而求其次版本

Reply Favorite View the author
All Replies
babyfengfjx
deepin testing team
2022-06-29 08:16
#1

非常棒!

晚上就会推出更新解决依赖问题了。

Reply View the author
滢泷迷雾
deepin
2022-06-29 08:19
#2
babyfengfjx

非常棒!

晚上就会推出更新解决依赖问题了。

我觉得我的思路还是有用的😄

Reply View the author
181******81
deepin
2022-06-29 08:45
#3

这是贡献。哈哈

Reply View the author
滢泷迷雾
deepin
2022-06-29 09:01
#4
181******81

这是贡献。哈哈

此方法只能应急使用,最终还是要补全新版软件的依赖。

Reply View the author
deepin-superuser
深度内测组
2022-06-29 09:05
#5

加入内测貌似也可以

Reply View the author
yuyiwas
deepin
2022-06-29 09:14
#6

大佬牛66666666666666

,推荐官方自动集成wine,直接运行exe文件吧,现在还要我们自己定向deepin-wine6-stable默认程序

Reply View the author
hotime
deepin
2022-06-29 09:52
#7
babyfengfjx

非常棒!

晚上就会推出更新解决依赖问题了。

这依赖了libicu70的应该传到内测仓库吧?正式仓库中可以先把这俩包给它去掉,以避免对其他软件安装产生的影响,等依赖libicu63的版本做好了再发布到正式仓库是不是好点?

Reply View the author
babyfengfjx
deepin testing team
2022-06-30 00:58
#8
hotime

这依赖了libicu70的应该传到内测仓库吧?正式仓库中可以先把这俩包给它去掉,以避免对其他软件安装产生的影响,等依赖libicu63的版本做好了再发布到正式仓库是不是好点?

嗯嗯,主要是跟随QT6的依赖推出去的,今天应该是解决了。

Reply View the author
hotime
deepin
2022-06-30 01:04
#9
babyfengfjx

嗯嗯,主要是跟随QT6的依赖推出去的,今天应该是解决了。

嗯嗯刚看到内测的libicu70已将传到正式仓库了like

Reply View the author
Use Markdown Editor
Loading