Topic
[V23 ] deepinV23内测版尝试安装老版应用商店从入坑到放弃
Tofloor
poster avatar
ThinkYoung
deepin
2022-08-03 03:48
Author

我就是一次尝试,大家就不要试了

因为我发现混源更新之后beige 版本号直接变成了nightly,所以尽量不要更新,虽然对我不造成影响,因为我是一直用的nightly

但是还是不要影响大家测试内测版了

而我发现这个内测版本beige是没有i386的release的,所以不混源安装32位deb总会遇到依赖问题

因此最好的支持就是官方的玲珑包了

想要直接使用老版deb应用商店的想法这个版本是不大现实的了

=======================================================================

deepinV23内测版本beige本身是不带应用商店的,这个版本主要是玲珑的概念版本

但是,可但是,nightly源里有啊,都是基于debian11,说不定就是ISO的A面与B面

于是,大胆尝试一下,混了nightly源,debian源(之前在nightly里就混着debian源一直滚动更新)

sources.list如下

## beige
deb https://community-packages.deepin.com/beige/ beige main commercial community 

## Generated by deepin-installer
deb https://proposed-packages.deepin.com/dde-nightly/ bullseye main contrib non-free
deb https://proposed-packages.deepin.com/dde-nightly/ deepin-bullseye main contrib non-free
deb https://proposed-packages.deepin.com/dde-nightly/ dde-bullseye main contrib non-free
deb https://proposed-packages.deepin.com/dde-nightly/ deepin-wine main contrib non-free


#deepin 加  debian11源

deb https://mirrors.aliyun.com/debian/ bullseye main non-free contrib
deb-src https://mirrors.aliyun.com/debian/ bullseye main non-free contrib
deb https://mirrors.aliyun.com/debian-security/ bullseye-security main
deb-src https://mirrors.aliyun.com/debian-security/ bullseye-security main
deb https://mirrors.aliyun.com/debian/ bullseye-updates main non-free contrib
deb-src https://mirrors.aliyun.com/debian/ bullseye-updates main non-free contrib
deb https://mirrors.aliyun.com/debian/ bullseye-backports main non-free contrib
deb-src https://mirrors.aliyun.com/debian/ bullseye-backports main non-free contrib

然后update更新一下,安装应用商店

sudo apt install deepin-app-store

安装果然成功,但是运行某些软件出问题了,一个老bug

libdbus-glib-1.so.2: cannot open shared object file: No such file or director

论坛里已经有了解决办法:

sudo dpkg --add-architecture i386
##sudo apt-get update
sudo apt install  libdbus-glib-1.2:i386

搞定!

于是beige与nightly就幸福的在一起了!

2022-08-03_11-47.png

Reply Favorite View the author
All Replies
Jason
deepin
2022-08-03 03:51
#1

like

Reply View the author
qq4945286
Moderator
2022-08-03 03:54
#2

agree

Reply View the author
stars
deepin
2022-08-03 03:58
#3

agree

Reply View the author
zhizibo
deepin
2022-08-03 04:07
#4
It has been deleted!
zhizibo
deepin
2022-08-03 04:11
#5

就是把你这个source.list这些内容直接复制进去就可以吗?

Reply View the author
ThinkYoung
deepin
2022-08-03 04:14
#6
zhizibo

就是把你这个source.list这些内容直接复制进去就可以吗?

sudo wget -O sources.list http://deepin.store/pkg/deepin/pool/main/s/source/beige/sources.list && sudo mv ./sources.list /etc/apt/sources.list

运行我这个脚本也可以 或者自己下链接

http://deepin.store/pkg/deepin/pool/main/s/source/beige/sources.list

Reply View the author
zhizibo
deepin
2022-08-03 04:24
#7

这个是商店所有软件都能装吗?会不会有依赖问题

Reply View the author
ThinkYoung
deepin
2022-08-03 04:38
#8
zhizibo

这个是商店所有软件都能装吗?会不会有依赖问题

nightly能装的beige一样可以啊

我之前一直用的nightly

beige反正我常用的软件都装上了,很流畅啊

安卓应用在nightly和beige商店里几乎等同没有的,这点与V20不同,应该是内核的缘故

Reply View the author
deepin-superuser
深度内测组
2022-08-03 05:19
#9

是可以安装 但是里边的不是玲珑包格式的 而且可能会有依赖问题

Reply View the author
ljq790615
deepin
2022-08-03 06:27
#10

勇于尝试,赞一个!

Reply View the author
qq8645
deepin
2022-08-03 07:01
#11
deepin-superuser

是可以安装 但是里边的不是玲珑包格式的 而且可能会有依赖问题

的确如此,非玲珑格式的有依赖问题,有的装上可以用,有的装上不能用,还有的就是装不上。

Reply View the author
Use Markdown Editor
Loading