[Android Apps] UEngine运行器2.1.1——修复UEngine安装程序在非深度/UOS的问题
Tofloor
poster avatar
gfdgd_xi
Moderator
Ecological co-builder
2023-07-07 02:48
Author

介绍

        新版本Deepin/UOS发布后,可以在应用商店安装部分官方已适配的安卓应用,对爱好者来说,不能自己安装APK软件包始终差点意思,本程序可以为Deepin/UOS上的UEngine安卓运行环境安装自定义APK软件包,并能发送安装的APK包启动菜单到桌面或系统菜单。

图片.png

更新内容

※1、修复在 Ubuntu/Debian 安装 UEngine 时提示“该脚本不支持 deepin”的问题;
※2、修复 UEngine 在 debian12 安装无法正常开启 UEngine 的问题;
※3、修复在 UEngine 程序菜单检查到 UEngine 不存在但是无法安装的问题;
※4、修复了 https://gitee.com/gfdgd-xi/uengine-runner/issues/I6B6C8 的问题;
※5、优化了 postinst 和 postrm 脚本;
6、添加 zenity 依赖;
7、屏蔽在更新程序过程中杀死程序中输出的错误;
8、修改下载 dtk 的网址。

图片.png

图片.png

Deepin23 Alpha2/Beta缺依赖怎么办?

最简单的方法

从星火应用商店安装

手动补充依赖

下载下方链接的 deb 包并安装即可

https://gfdgdxi.lanzoue.com/b01qiu22f 拉取依赖

密码:dihl

UEngine 运行器

蓝奏云:https://gfdgdxi.lanzoui.com/b01oaxnbi,密码:2rh3
诚通网盘:https://url79.ctfile.com/d/31540479-51790586-eac899?p=2061 (访问密码: 2061)

Github:https://github.com/gfdgd-xi/uengine-runner
Gitee:https://gitee.com/gfdgd-xi/uengine-runner
星火应用商店:spk://store/tools/spark-uengine-runner
UEngine 运行器内部更新:可以使用 UEngine 运行器自带的更新程序进行更新(只支持 1.6.0 及以上版本)

star
现在新增了通过包名值获取应用适配情况的功能,查看链接:https://gfdgd-xi.github.io/uengine-runner-info/ ,如何贡献自己的适配情况?在 UEngine 运行器进行评分即可

附:Debian 10、Debian 11、Ubuntu 20.04 需要从 http://dtk.gfdgdxi.top/ 下载 dtk(版本≥5.5)并安装才能通过运行器的安装程序正确安装 UEngine

Reply Favorite View the author
All Replies
1 / 2
To page
阿尼樱奈奈
Moderator
2023-07-07 02:56
#1

这个一定要支持like

Reply View the author
gfdgd_xi
Moderator
Ecological co-builder
2023-07-07 02:57
#2
阿尼樱奈奈

这个一定要支持like

blush 感谢支持

Reply View the author
秋胜春朝
deepin
2023-07-07 03:04
#3
It has been deleted!
秋胜春朝
deepin
2023-07-07 03:04
#4

like

Reply View the author
gfdgd_xi
Moderator
Ecological co-builder
2023-07-07 03:17
#5
秋胜春朝

like

blush

感谢支持

Reply View the author
青稚°
Moderator
2023-07-07 03:34
#6
gfdgd_xi

blush

感谢支持

必须支持xilike

Reply View the author
世鹏已被封杀
deepin
2023-07-07 03:44
#7
It has been deleted!
gfdgd_xi
Moderator
Ecological co-builder
2023-07-07 03:54
#8
It has been deleted!
gfdgd_xi
Moderator
Ecological co-builder
2023-07-07 03:55
#9
青稚°

必须支持xilike

blush 感谢支持

Reply View the author
hanzn-zzx
deepin
2023-07-07 04:16
#10

感谢大佬!like

Reply View the author
gfdgd_xi
Moderator
Ecological co-builder
2023-07-07 15:05
#11
hanzn-zzx

感谢大佬!like

blush 感谢支持

Reply View the author
云的眼泪
deepin
2023-07-07 16:31
#12

thanks

但是目前UEngine的主要问题是版本太老(7.1),兼容性差,这两点亟待解决。

Reply View the author
dgmenghuan
deepin
2023-07-07 17:43
#13

applaud

Reply View the author
浪云
deepin
2023-07-07 17:51
#14

楼主测试一下能正常使用抓饭直播安卓APP看直播吗?

Reply View the author
gfdgd_xi
Moderator
Ecological co-builder
2023-07-09 01:00
#15
云的眼泪

thanks

但是目前UEngine的主要问题是版本太老(7.1),兼容性差,这两点亟待解决。

这得等官方了

Reply View the author
gfdgd_xi
Moderator
Ecological co-builder
2023-07-09 01:00
#16
dgmenghuan

applaud

blush 感谢支持

Reply View the author
坐井观天下
deepin beta test group
2023-07-12 16:43
#17

通过星火商店一直没完成安装,手动下载安装,终于成功。执行时出错,缺少python的PIL库,pip安装后就ok了,感谢。

Reply View the author
gfdgd_xi
Moderator
Ecological co-builder
2023-07-12 16:48
#18
坐井观天下

通过星火商店一直没完成安装,手动下载安装,终于成功。执行时出错,缺少python的PIL库,pip安装后就ok了,感谢。

能给一下安装 pillow 库的命令吗
我这不止一个用户反馈这个问题了,但是 apt 依赖+postinst都重复安装 pillow 库了,不知道为什么还是不行

Reply View the author
坐井观天下
deepin beta test group
2023-07-12 17:35
#19
gfdgd_xi

能给一下安装 pillow 库的命令吗
我这不止一个用户反馈这个问题了,但是 apt 依赖+postinst都重复安装 pillow 库了,不知道为什么还是不行

pip install pillow

这是python的库

Reply View the author
坐井观天下
deepin beta test group
2023-07-14 22:52
#20

安装APK成功之后,桌面上生成一个未知应用图标None.desktop

Reply View the author
1 / 2
To page