[problem help] Installation Panels are blank
Tofloor
poster avatar
j***e@gmail.com
deepin
2024-05-27 18:34
Author

Hi

Attempting the install via the bootup desktop, or diretly from the boot menu I m presented with blank white panels/windows. From the boot to desktop option the desktop loads with all icons, menu bars, etc., but choosing installer the panel/window is blank white. Booting directly into an installation option (Kernel v6), the language menu is seen, I select English and the next panel/window is blank white.

PC is a Dell Inspiron 1545 Laptop 64bit with 6GB RAM, 500GB HDD

Any help please

Reply Favorite View the author
All Replies
Owensuwu
deepin
2024-05-28 07:57
#1

Hey there,

It sounds like you're having some trouble with the Deepin installer showing blank white screens. This is a bit of a head-scratcher, but there are a few things you can try:

  1. If you're using a USB drive, try creating a new one with a different tool (like Rufus or Etcher). It's possible the current one is corrupted. You could also try downloading a fresh copy of the ISO just in case.
  2. Sometimes, compatibility issues with graphics drivers can cause weird display problems during installation. If your laptop has both Intel integrated graphics and a dedicated GPU (like Nvidia), try booting the installer with the "nomodeset" option. You can usually do this by pressing "e" at the boot menu, finding the line that starts with "linux", and adding "nomodeset" to the end.
  3. Experiment with different boot options. Some people have had success by adding "acpi=off" or "noapic" to the boot parameters (like we did with "nomodeset").
  4. It's a long shot, but make sure your laptop's RAM is seated properly. You could also try temporarily removing one stick if you have two. Faulty hardware can sometimes cause strange errors like this.

Hope this helps! Don't give up, you'll get Deepin up and running eventually!

Reply View the author
j***e@gmail.com
deepin
2024-05-28 15:16
#2

Thanks 'Owensuwu' ..... I'll give these suggestions a try.

As this is the only 'distro' that seems to present these issues (yesterday installed Elementary 7.1 to eliminate potential hardware issues -- all fine). It is weird though, all panels/windows/drop down menus are blank, even using the USB 'live' boot. Image was cut using Belena Etcher v.1.10.6. I'll install the latest version, may make a difference 🤞

Reply View the author
j***e@gmail.com
deepin
2024-05-31 03:54
#3

Hi ..... looks like the issue is with the Laptop + Deepin 'combo'. Basically they don't get on 😭 , installations from other distro's are fine (Zorin, Elementary, MX, etc.). Installation media works fine on my two full sized floor standing PC's, and I am pleased with the installation. My final thought was that it didn't like overlaying a previous Linux install and drive mapping/installation, but even 'flattening' the HDD with GPart back to 'bare bones' had no effect.

Reply View the author