Topic
深度商店 V.40安装失败的解决方法
Tofloor
poster avatar
snyh1010
deepin
2015-12-18 02:57
Author
目前深度商店出现的安装失败,,绝大多数问题是2个原因:
  • 仓库依赖不满足.
  • lastore-daemon (商店后端服务) 0.9.5 之前有一个下载的严重Bug,导致有几率出现下载文件错误,进而无法成功安装。

其中
  1.  我们会在一两个月内通过改进仓库机制,确保所有应用都可以正常安装后才进行推送更新。虽然没有从源头解决依赖问题,但通过自动测试+人工修复,将依赖问题与最终用户进行隔离。
  2.  lastore-daemon的Bug是今天早上(2015-12-18早上9点30左右进行的紧急推送)更新后的用户应该已经OK。若依旧出现此问题,可以通过以下方式尝试手动修复。终端执行:
  1. sudo apt-get clean
  2. sudo apt-get update
  3. sudo apt-get install lastore-daemon
  4. sudo killall lastore-daemon
Copy the Code




Reply Favorite View the author
All Replies
q155128
deepin
2015-12-18 05:04
#1
原来如此,早上收到个补丁,最后终于装上火狐了
Reply View the author
Nicho
deepin
2015-12-18 10:38
#2
甚好!回家试试!还有就是搜狗漏字的问题,不能忍啊~~~
Reply View the author
nalan
deepin
2015-12-18 15:40
#3
火狐浏览器安装成功,微信网页版依旧失败。
Reply View the author
bobo
deepin
2015-12-19 17:38
#4
libreoffice 依旧无法安装。命令行安装报错
  1. ome packages could not be installed. This may mean that you have
  2. requested an impossible situation or if you are using the unstable
  3. distribution that some required packages have not yet been created
  4. or been moved out of Incoming.
  5. The following information may help to resolve the situation:

  6. The following packages have unmet dependencies:
  7. libreoffice : Depends: libreoffice-base but it is not going to be installed
  8.                Depends: libreoffice-calc but it is not going to be installed
  9.                Depends: libreoffice-core (= 1:5.0.4~rc2-1) but it is not going to be installed
  10.                Depends: libreoffice-draw but it is not going to be installed
  11.                Depends: libreoffice-impress but it is not going to be installed
  12.                Depends: libreoffice-math but it is not going to be installed
  13.                Depends: libreoffice-report-builder-bin but it is not going to be installed
  14.                Depends: libreoffice-writer but it is not going to be installed
  15.                Depends: libreoffice-avmedia-backend-gstreamer but it is not going to be installed or
  16.                         libreoffice-avmedia-backend-vlc but it is not going to be installed
  17.                Depends: libreoffice-java-common (>= 1:5.0.4~rc2~) but it is not going to be installed
  18.                Depends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed
  19.                Recommends: libpaper-utils
  20. E: Unable to correct problems, you have held broken packages.
Copy the Code
Reply View the author
fuyao
deepin
2015-12-20 02:12
#5
按照此方法还是不行
Reply View the author
snyh1010
deepin
2015-12-20 12:15
#6
https://bbs.deepin.org/post/34215
按照此方法还是不行

具体点是哪里挂了?  apt-get install直接安装呢?
Reply View the author
snyh1010
deepin
2015-12-20 12:16
#7
https://bbs.deepin.org/post/34215
火狐浏览器安装成功,微信网页版依旧失败。

https://bbs.deepin.org/post/34272 
不会和这个一样的问题吧?  
这个我今天装了2次系统都是Ok的。  
一次是通过内网的pools.corp.  一次是外网的packages.deepin.com
Reply View the author
182******97
deepin
2015-12-20 15:59
#8
把依赖包打包吧
Reply View the author
fuyao
deepin
2015-12-21 03:59
#9
https://bbs.deepin.org/post/34215
具体点是哪里挂了?  apt-get install直接安装呢?

具体哪里挂了我也不知道,我时从a2升级上来的。点击各个软件分类啥也没有,而且商店点右上角x关不掉,只能在dock上右键关闭所有才行。另外sudo aptget应该没问题,就是太慢了,超不过200k/s。下面是两个截图。




Reply View the author
snyh1010
deepin
2015-12-22 02:51
#10
https://bbs.deepin.org/post/34215
具体哪里挂了我也不知道,我时从a2升级上来的。点击各个软件分类啥也没有,而且商店点右上角x关不掉,只能 ...

你这个是商店界面挂了。
  RC后应该就没问题了。    目前你简单的执行下deepin-appstore -c清理一下cache吧
Reply View the author
fuyao
deepin
2015-12-22 03:51
#11
https://bbs.deepin.org/post/34215
你这个是商店界面挂了。
  RC后应该就没问题了。    目前你简单的执行下deepin-appstore -c清理一下cache ...

还是等RC吧,清理了也不好使。。
Reply View the author
haimencun
deepin
2017-09-26 13:04
#12
打开商店系统就重启!!大神帮忙看看
Reply View the author
Use Markdown Editor
Loading