发新帖

INTERNET VERY SLOW.... (VIA WIFI)(URGENT)

cktv8822 / 2016-9-15 01:09
浏览: 8958 / 回复: 20
查看: 8958|回复: 20

INTERNET VERY SLOW.... (VIA WIFI)(URGENT)

[复制链接]
收藏
跳转到指定楼层
<English>
SLOW CONNECTIONS INTERNET (WIFI)

The internet connection is very slow, and only happens when I am connected via wifi, cable connection is stable.

help, because this problem was already solved in Deepin 15.2.

Too slow Internet connection: Connect to the Internet to browse or download files via Google Chrome and doing speed test.

WIFI check internal controller kernel. because the controller work properly in Deepin 15.2

<Spanish>
Conexión a Internet vía WIFI es Super Lenta

la conexiòn de internet es muy lenta, y solo pasa cuando estoy conectado via wifi, la conexión por cable es estable.

ayuda, pues este problema ya estaba solucionado en Deepin 15.2.

Conexion a internet demasiado lenta: Conectarme al internet para navegar o descargar archivos via Google Chrome  y haciendo test de velocidad.

Revisar controlador interno WIFI kernel. ya que el controlador funcionaba correctamente en Deepin 15.2

1

主题

2

帖子

7

积分

-r--------

Rank: 1

积分
7
interfacenode 发表于 2016-9-15 03:50:23 | 显示全部楼层
Edited by interfacenode at 2016-9-15 03:53

Please tell me which wifi-dongle you are using; if possible.

Is it Realtek by any chance? I bet it is
The reason? IN 15.3 Deepin is using drivers that had debuffed power-management in regards to some wifi-dongle.

<Spanish>

Dime cuál es tu modelo de wifi dispositivo.

1

主题

2

帖子

7

积分

-r--------

Rank: 1

积分
7
interfacenode 发表于 2016-9-15 04:02:02 | 显示全部楼层
ay que lindo... I thought you were in a rush?

Me too, I'm curious to confirm what I think.. let me know soon senor

1

主题

4

帖子

33

积分

-r--------

Rank: 1

积分
33
cktv8822 发表于 2016-9-16 02:12:28 | 显示全部楼层
Network controller                : Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Ethernet controller                : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)

1

主题

4

帖子

33

积分

-r--------

Rank: 1

积分
33
cktv8822 发表于 2016-9-16 02:13:15 | 显示全部楼层
Wireless - Very Slow Internet.
Ethernet - Internet Stable

1

主题

2

帖子

7

积分

-r--------

Rank: 1

积分
7
interfacenode 发表于 2016-9-16 15:12:48 | 显示全部楼层
cktv8822 replied at 2016-9-16 02:13
Wireless - Very Slow Internet.
Ethernet - Internet Stable

Open terminal and issue the following

sudo su && echo "options ath9k nohwcrypt=1" >> /etc/modprobe.d/ath9k.conf

Then restart, tell me if this resolves wifi errors.

1

主题

4

帖子

33

积分

-r--------

Rank: 1

积分
33
cktv8822 发表于 2016-9-17 02:36:45 | 显示全部楼层
Not working,

although improving the connection is not enough:
Current bandwidth: 10MB
Before: 0.5MB
after 1MB
:(
Is there any other solution?

15

主题

76

帖子

762

积分

-r--r--r--

Rank: 3Rank: 3

积分
762
Favaro 发表于 2016-9-17 03:24:42 | 显示全部楼层
i have to this Problem

6

主题

23

帖子

287

积分

-r--r-----

Rank: 2

积分
287
horvan 发表于 2016-9-17 03:26:12 | 显示全部楼层
Try sudo modprobe ath9k && dmesg | grep ath

主题

帖子

0

积分

-r--------

Rank: 1

积分
0
infuscomus 发表于 2016-9-17 03:40:54 | 显示全部楼层
you might want to try a kernel update,

a new kernel module for your wifi might fix some things

1

主题

4

帖子

33

积分

-r--------

Rank: 1

积分
33
cktv8822 发表于 2016-9-17 04:10:20 | 显示全部楼层

as upgrade?

1

主题

4

帖子

33

积分

-r--------

Rank: 1

积分
33
cktv8822 发表于 2016-9-17 04:44:27 | 显示全部楼层
<Spanish>
Solucioné el problema de la siguiente forma:

Desinstale  Firmware-athero y Wireless-tools

sudo apt-get remove --purge  firmware-atheros
sudo apt remove --purge wireless-tools

Gracias por la ayuda...

<english>

Y ahora puedo navegar con el ancho de banda completo. 10/10

I solved the problem as follows:

Uninstall Firmware-athero and Wireless-tools

sudo apt-get remove --purge  firmware-atheros
sudo apt remove --purge wireless-tools

Thanks for the help...

主题

帖子

0

积分

-r--------

Rank: 1

积分
0
infuscomus 发表于 2016-9-17 13:15:34 | 显示全部楼层
if that doesn't work you can grab a more recent kernel here

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.7.4/

I'll be grabbing this one to fix the missing kernel module for my soundcard

主题

帖子

10

积分

-r--------

Rank: 1

积分
10
doctorfreeman 发表于 2016-9-17 16:54:53 | 显示全部楼层
So much time, by the way... if you have an Atheros K (see it with "lshw -C network"), use the following on terminal:

echo "options ath9k nohwcrypt=1" | sudo tee  /etc/modprobe.d/ath9k.conf
sudo modprobe -rfv ath9k

sudo modprobe -v ath9k

1

主题

4

帖子

33

积分

-r--------

Rank: 1

积分
33
cktv8822 发表于 2016-10-19 05:12:51 | 显示全部楼层
not working your solution...  I had to uninstall again the firmware-atheros

0

主题

8

帖子

109

积分

-r--------

Rank: 1

积分
109
ing_alexander 发表于 2017-9-11 03:53:28 | 显示全部楼层
Hello, this thread have some time but don't have any solution, I found a solution that is working for me and don't need uninstall anything

my case is for the device Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

when we install deepin the defaul config of the device is the next
  1. grep -iR [[:alnum:]] /sys/module/ath9k/parameters
复制代码
  1. /sys/module/ath9k/parameters/bt_ant_diversity:0
  2. /sys/module/ath9k/parameters/nohwcrypt:0
  3. /sys/module/ath9k/parameters/blink:0
  4. /sys/module/ath9k/parameters/btcoex_enable:0
  5. /sys/module/ath9k/parameters/led_active_high:-1
  6. /sys/module/ath9k/parameters/ps_enable:0
复制代码

but, for the driver ath9k on this device that have wifi and bluetooth combo this configuration is wrong, this device has support of bluetooth coexistence
https://wireless.wiki.kernel.org/en/users/drivers/ath9k/btcoex
so, is necesary enable this feature for the bluetooth not interfere with wifi, the simplest way to see if this is the problem is disable bluetooth  in deepin control panel, only with this the wifi speed improve a lot.

but for solve the issue the correct way is to enable the feature
  1. sudo nano /etc/modprobe.d/ath9k.conf
复制代码
in this file we need put these options
  1. options ath9k nohwcrypt=1
  2. options ath9k btcoex_enable=1
复制代码

It's important to know that when bluetooth is active searching devices the speet of wifi drop down but not like when btcoex_enable is disabled, the problem now is the deepin control panel, it force the bluettoth device search for looooong time, that interfere with the wifi, to solve this we can install blueman
  1. sudo apt install blueman
复制代码


now, start de program blueman
next disable bluetooth from deepin control panel
now start bluetooth from blueman bluetooth menu
with this, blueman take care of the search of devices and deepin control panel stop interfer with the wifi


sorry for my bad english


评分

参与人数 1贡献 +2 收起 理由
melodyzou + 2 glad that there is a way to solve the is

查看全部评分

1

主题

9

帖子

38

积分

-r--------

Rank: 1

积分
38
zhangsh 发表于 2017-10-11 13:17:32 | 显示全部楼层
ing_alexander 发表于 2017-9-11 03:53
Hello, this thread have some time but don't have any solution, I found a solution that is working fo ...

thanks, but it doesn't work for me, sad.

0

主题

17

帖子

56

积分

-r--------

Rank: 1

积分
56
arcanjobra 发表于 2017-10-12 07:16:48 | 显示全部楼层
use program ukuu update kernel 4.13.5

38

主题

811

帖子

3419

积分

lr--------

积分
3419
melodyzou 发表于 2017-10-12 15:02:09 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
欢迎来到深度科技社区!


发帖求助前,请先阅读:深度操作系统新手指引(FAQ)

1

主题

9

帖子

38

积分

-r--------

Rank: 1

积分
38
zhangsh 发表于 2017-10-13 13:06:45 | 显示全部楼层
melodyzou 发表于 2017-10-12 15:02
What is your issue? slow network? Could you please be more specific?

https://bbs.deepin.org/forum.php?mod=viewthread&tid=146540&extra=

这个问题,我已经StackOverflow提问解决了。谢谢关注
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部