发新帖

Please help!!

issam / 2017-6-19 19:39
浏览: 600 / 回复: 25
查看: 600|回复: 25

Please help!!

[复制链接]
收藏
跳转到指定楼层
I don't know how to fix this problem, I've searched for it on google and no hope
any help :)


DeepinScreenshot20170619113746.png

11

主题

623

帖子

1610

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1610
duanyao 发表于 2017-6-19 19:55:16 | 显示全部楼层
Are you using a local proxy server? If so, it seems no longer running.
If not, seems your DNS setting is messed up; please show the content of `/etc/resolv.conf`.

4

主题

162

帖子

718

积分

-r--r--r--

Rank: 3Rank: 3

积分
718
nipos 发表于 2017-6-19 19:57:14 | 显示全部楼层
There is something wrong with your /etc/apt/sources.list or your DNS.
It tries to download the packages from the IP 127.0.0.1 which is the localhost.
That can't work.
I think the problem is the DNS because first it says packages.deepin.com.
Write "hostname 80.80.80.80(new line)hostname 80.80.81.81" into /etc/resolv.conf and try again.
Do NOT reconnect or reboot after the change as DHCP may reset the config to the old DNS!

4

主题

17

帖子

89

积分

-r--------

Rank: 1

积分
89
issam 发表于 2017-6-19 23:17:28 | 显示全部楼层
duanyao replied at 2017-6-19 19:55
Are you using a local proxy server? If so, it seems no longer running.
If not, seems your DNS settin ...

No, I'm not
Here is the file
DeepinScreenshot20170619181610.png

4

主题

17

帖子

89

积分

-r--------

Rank: 1

积分
89
issam 发表于 2017-6-19 23:24:41 | 显示全部楼层
nipos replied at 2017-6-19 19:57
There is something wrong with your /etc/apt/sources.list or your DNS.
It tries to download the packa ...

I can't edit "/etc/resolv.conf " it's read only!

4

主题

162

帖子

718

积分

-r--r--r--

Rank: 3Rank: 3

积分
718
nipos 发表于 2017-6-20 00:04:22 | 显示全部楼层
Start the editor with root rights.
If you are using Gedit,try this command:
sudo gedit /etc/resolv.conf

主题

帖子

0

积分

-r--------

Rank: 1

积分
0
akito 发表于 2017-6-20 00:16:06 | 显示全部楼层
nipos replied at 2017-6-20 00:04
Start the editor with root rights.
If you are using Gedit,try this command:
sudo gedit /etc/resolv.c ...
  1. gksu gedit /etc/resolv.conf
复制代码

4

主题

17

帖子

89

积分

-r--------

Rank: 1

积分
89
issam 发表于 2017-6-20 01:21:39 | 显示全部楼层
Edited by issam at 2017-6-20 01:23

I've edited the file using the code, But when I tried to install vlc, I've got the same problem in the result.
Thanks for help :)

10

主题

134

帖子

447

积分

-r--r--r--

Rank: 3Rank: 3

积分
447
QQ
billstark 志愿者 发表于 2017-6-20 01:44:14 | 显示全部楼层
I had also met this before, try:

sudo apt-get install vlc --fix-missing

then:

sudo apt-get update

the problem should be solved
一只闲着没事干的码农
-----------------------
C/C++/qt
web全栈
-----------------------
00后一只 | 尝试吸取建议

11

主题

623

帖子

1610

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1610
duanyao 发表于 2017-6-20 13:51:27 | 显示全部楼层
本帖最后由 duanyao 于 2017-6-20 13:53 编辑
issam 发表于 2017-6-19 23:17
No, I'm not
Here is the file

So the DNS server 192.168.1.1 has some problem. If you access Internet via a home router or AP, the DNS server is probably in it. Try to reboot it and see.

You can also investigate this problem by the following steps:

1. `ping 8.8.8.8` to see whether you can reach the Internet (it's a google DNS server).
2. `nslookup deepin.com 8.8.8.8` to see whether you can resolve a domain name via 8.8.8.8. The result should looks like:
```
Server:                8.8.8.8
Address:        8.8.8.8#53

Non-authoritative answer:
Name:        deepin.com
Address: 114.215.101.12
```
The last "Address" should not be a local address like 127.0.0.1 or 192.168.*.

3. `nslookup deepin.com 192.168.1.1` to see whether your DNS server on home router or AP work correctly. If the result is still not correct even if you reboot your router or AP, you may ask your ISP for help.

4

主题

162

帖子

718

积分

-r--r--r--

Rank: 3Rank: 3

积分
718
nipos 发表于 2017-6-20 15:00:07 | 显示全部楼层
@duanyao I thinked the same but he had the same problem with other DNS servers.
There must be an other problem.
@issam Please post the content of your /etc/apt/sources.list
Probably it contains 127.0.0.1 as a mirror server but thats unlikely and I don't know how that should get into the file.
I don't have another idea what could cause the error so let's try that out anyway.

4

主题

17

帖子

89

积分

-r--------

Rank: 1

积分
89
issam 发表于 2017-6-20 17:43:08 | 显示全部楼层
@duanyao I think the result is as it should be, Thank you.

DeepinScreenshot20170620123708.png

4

主题

17

帖子

89

积分

-r--------

Rank: 1

积分
89
issam 发表于 2017-6-20 17:44:29 | 显示全部楼层
nipos replied at 2017-6-20 15:00
@duanyao I thinked the same but he had the same problem with other DNS servers.
There must be an oth ...

@niposHere it is, Thank you.


DeepinScreenshot20170620123848.png

11

主题

623

帖子

1610

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1610
duanyao 发表于 2017-6-20 18:09:01 | 显示全部楼层
本帖最后由 duanyao 于 2017-6-20 18:17 编辑
issam 发表于 2017-6-20 17:43
@duanyao I think the result is as it should be, Thank you.

Your Internet access and DNS looks fine. Do you still have problem with apt-get?
Can you open http://packages.deepin.com/deepin/ by a browser? It should show "Index of /deepin/ ...".

Are you using a proxy? If you have changed /etc/apt/apt.conf or any thing under /etc/apt/apt.conf.d/, please show it.

4

主题

17

帖子

89

积分

-r--------

Rank: 1

积分
89
issam 发表于 2017-6-20 18:35:49 | 显示全部楼层
Edited by issam at 2017-6-20 18:38
duanyao replied at 2017-6-20 18:09
本帖最后由 duanyao 于 2017-6-20 18:17 编辑

@duanyao I can access to this address and install the files required to complete the installation, And I have not changed any file in this folder  /etc/apt/apt.conf.d/
where is the terminal putting those files?
so I can put those two files there.
BTW what does this error mean :400  Bad URI [IP: 202.141.160.114 80]
it is the same problem when I tried to download update, it has stopped on the last Kilo bytes of the update files.
maybe for the same reason.
Thank you.


apt.conf.d.tar.gz

1.56 KB, 下载次数: 30

11

主题

623

帖子

1610

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1610
duanyao 发表于 2017-6-20 18:53:39 | 显示全部楼层
本帖最后由 duanyao 于 2017-6-20 19:00 编辑
issam 发表于 2017-6-20 18:35
Edited by issam at 2017-6-20 18:38

It seems OK. Try `apt update`, does it fail?

What is the output of `echo $http_proxy`?

4

主题

17

帖子

89

积分

-r--------

Rank: 1

积分
89
issam 发表于 2017-6-20 19:04:09 | 显示全部楼层
duanyao replied at 2017-6-20 18:53
本帖最后由 duanyao 于 2017-6-20 19:00 编辑

here is the output:
root@Home:/home/issam/Desktop# apt update
Hit:1 http://packages.deepin.com/deepin unstable InRelease
Hit:2 https://deb.opera.com/opera-stable stable InRelease
Hit:3 http://repository.spotify.com stable InRelease
Reading package lists... Done
Building dependency tree      
Reading state information... Done
990 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@Home:/home/issam/Desktop#

11

主题

623

帖子

1610

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1610
duanyao 发表于 2017-6-20 19:13:44 | 显示全部楼层
issam 发表于 2017-6-20 19:04
here is the output:
root@Home:/home/issam/Desktop# apt update
Hit:1 http://packages.deepin.com/dee ...

Looks fine. Now what's the output of `apt install vlc`?

4

主题

17

帖子

89

积分

-r--------

Rank: 1

积分
89
issam 发表于 2017-6-20 19:27:14 | 显示全部楼层
duanyao replied at 2017-6-20 19:13
Looks fine. Now what's the output of `apt install vlc`?

issam@Home:~/Desktop$ apt install vlc
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
issam@Home:~/Desktop$ sudu su
bash: sudu: command not found
issam@Home:~/Desktop$ sudo su
[sudo] password for issam:
root@Home:/home/issam/Desktop# apt install vlc
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following additional packages will be installed:
  fonts-freefont-ttf libbasicusageenvironment1 libcddb2 libdirectfb-1.2-9 libdvbpsi10
  libebml4v5 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386
  libgles1-mesa libgles2-mesa libgroupsock8 libiso9660-8 liblirc-client0
  liblircclient0 liblivemedia57 libmatroska6v5 libproxy-tools libproxy1v5
  libresid-builder0c2a libschroedinger-1.0-0 libsdl-image1.2 libsdl1.2debian
  libsidplay2 libupnp6 libusageenvironment3 libvcdinfo0 libvlc-bin libvlc5
  libvlccore8 libxcb-xv0 vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify
  vlc-plugin-qt vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization
Suggested packages:
  lirc libdvdcss2
The following NEW packages will be installed:
  fonts-freefont-ttf libbasicusageenvironment1 libcddb2 libdirectfb-1.2-9 libdvbpsi10
  libebml4v5 libgles1-mesa libgroupsock8 libiso9660-8 liblirc-client0 liblircclient0
  liblivemedia57 libmatroska6v5 libproxy-tools libresid-builder0c2a
  libschroedinger-1.0-0 libsdl-image1.2 libsdl1.2debian libsidplay2 libupnp6
  libusageenvironment3 libvcdinfo0 libvlc-bin libvlc5 libvlccore8 libxcb-xv0 vlc
  vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt
  vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization
The following packages will be upgraded:
  libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libglapi-mesa:i386 libgles2-mesa
  libproxy1v5
6 upgraded, 38 newly installed, 0 to remove and 984 not upgraded.
Need to get 70.9 kB/23.7 MB of archives.
After this operation, 93.3 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Err:1 http://packages.deepin.com/deepin unstable/main amd64 libproxy1v5 amd64 0.4.14-2
  400  Bad URI [IP: 202.141.160.114 80]
Err:2 http://packages.deepin.com/deepin unstable/main amd64 libproxy-tools amd64 0.4.14-2
  400  Bad URI [IP: 202.141.160.114 80]
E: Failed to fetch http://packages.deepin.com/deepin/pool/main/libp/libproxy/libproxy1v5_0.4.14-2_amd64.deb  400  Bad URI [IP: 202.141.160.114 80]
E: Failed to fetch http://packages.deepin.com/deepin/pool/main/libp/libproxy/libproxy-tools_0.4.14-2_amd64.deb  400  Bad URI [IP: 202.141.160.114 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
root@Home:/home/issam/Desktop#

11

主题

623

帖子

1610

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1610
duanyao 发表于 2017-6-20 19:45:38 | 显示全部楼层
issam 发表于 2017-6-20 19:27
issam@Home:~/Desktop$ apt install vlc
E: Could not open lock file /var/lib/dpkg/lock - open (13: P ...

Interesting, I would guess some node between you and packages.deepin.com is blocking the traffic. Try download http://packages.deepin.com/deepin/pool/main/libp/libproxy/libproxy-tools_0.4.14-2_amd64.deb with your browser?
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部