发新帖

[Deepin 15.5] Deepin splash lost after installing nvidia drivers

danygee / 2017-8-1 14:12
浏览: 1373 / 回复: 35
楼主: danygee

[Deepin 15.5] Deepin splash lost after installing nvidia drivers

[复制链接]

5

主题

57

帖子

233

积分

-r--r-----

Rank: 2

积分
233
danygee 发表于 2017-12-1 19:47:14 | 显示全部楼层
Edited by danygee at 2017-12-1 12:49

OK, things are getting even weirder...
Although my boot config is clearly set to 1024x768x24 bits as you can see below...

/etc/default/grub
# Written by com.deepin.daemon.Grub2
GRUB_BACKGROUND="/boot/grub/themes/deepin/background.png"
GRUB_CMDLINE_LINUX=""
# GRUB_CMDLINE_LINUX_DEFAULT="splash quiet"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1024x768-24,mtrr=3,scroll=ywrap"
GRUB_DEFAULT="0"
GRUB_DISTRIBUTOR="`/usr/bin/lsb_release -d -s 2>/dev/null || echo Deepin`"
GRUB_GFXMODE="1024x768x24"
GRUB_THEME="/boot/grub/themes/deepin/theme.txt"
GRUB_TIMEOUT="5"

/etc/initramfs-tools/modules

# List of modules that you want to include in your initramfs.
# They will be loaded at boot time in the order below.
#
# Syntax:  module_name [args ...]
#
# You must run update-initramfs(8) to effect this change.
#
# Examples:
#
# raid1
# sd_mod
uvesafb mode_option=1024x768-24 mtrr=3 scroll=ywrap

...and of course grub and initramfs get updated with...
sudo update-grub2 && sudo update-initramfs -u

...WHY is my shutdown animation still displayed in 1920x1080?
What am I still missing here?




| OS: Deepin 15.5 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 375.26) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 |

0

主题

44

帖子

147

积分

-r--------

Rank: 1

积分
147
o4is 发表于 2017-12-1 19:51:53 | 显示全部楼层
danygee replied at 2017-12-1 19:24
Strange...adding this hashtag brings back 3 dots on grey screen before login.
Testing other resoluti ...

I agree, that's strange.
I'can't test it right now(not at home) to give you a definite answer, but i'm 95% sure thats the way.

0

主题

44

帖子

147

积分

-r--------

Rank: 1

积分
147
o4is 发表于 2017-12-1 20:01:27 | 显示全部楼层
danygee replied at 2017-12-1 19:47
OK, things are getting even weirder...
Although my boot config is clearly set to 1024x768x24 bits as ...

First of all, did the start up logo worked?
Secondly, GRUB_GFXMODE="1024x768x24" should be GRUB_GFXMODE="1024x768"
and put a hashtag infront of the line you added in modules.

5

主题

57

帖子

233

积分

-r--r-----

Rank: 2

积分
233
danygee 发表于 2017-12-1 20:06:38 | 显示全部楼层
o4is replied at 2017-12-1 13:01
First of all, did the start up logo worked?
Secondly, GRUB_GFXMODE="1024x768x24" should be GRUB_GF ...

1. Startup logo not showing - black screen.
2. Tried GRUB_GFXMODE="1024x768" already, same deal, no startup logo.
3. Hashtaging modules disables them, so what is the point of adding a hashtagged entry?
| OS: Deepin 15.5 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 375.26) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 |

0

主题

44

帖子

147

积分

-r--------

Rank: 1

积分
147
o4is 发表于 2017-12-1 20:18:26 | 显示全部楼层
danygee replied at 2017-12-1 20:06
1. Startup logo not showing - black screen.
2. Tried GRUB_GFXMODE="1024x768" already, same deal, n ...

3. I definetely agree. The first few times a used it without the hashtag and it didn't work.
So i decided to do exactly the steps described. And it worked. I've tested it. For some resolutions it worked.
I don't use it anymore because i have a big screen and resolutions like 1280x1024 or 1600x900 don't make this logo look pretty, like 1920x1080.
2. Its definetely GRUB_GFXMODE="1024x768"

0

主题

44

帖子

147

积分

-r--------

Rank: 1

积分
147
o4is 发表于 2017-12-1 20:23:16 | 显示全部楼层
danygee replied at 2017-12-1 20:06
1. Startup logo not showing - black screen.
2. Tried GRUB_GFXMODE="1024x768" already, same deal, n ...

When i get to my deepin system, i will test it and post exactly the steps and the contents of the files that made the logo worked.

点评

Thx, looking forward to it!  发表于 2017-12-1 20:32

3

主题

117

帖子

535

积分

-r--r--r--

Rank: 3Rank: 3

积分
535
oscararg 发表于 2017-12-2 09:11:54 | 显示全部楼层
I must say, for me it worked as I wrote it and with the steps one by one, and it worked for my native resolution (at 24). I got the splash, try the steps one by one, or separalely, what I did solved the problem for me but really I can't say which one exactly did the job for me. As Nvidia devs say
It's not a bug, it's a feature.
That nice animation needs a KMS framebuffer, which Nvidia does not provide.
and no one seems to care about making them compatible at least. Its said that last Nvidia drivers (380s) solve the problem but didn't tried them on Deepin yet.
Back to the solutions, most guys used gfx resolution change + gfx payload "keep" change and it was sufficient, but most guys did it on Ubuntu, Linux Mint... As always a solution that works on one distro and on their based ones can not fully work or simply doesn't work on another one. As I said, Arch Linux guys simply deleted Plymouth from their distros, Nvidia has it own splash option, and its logo can be changed by any photo or animation you want too.

1

主题

21

帖子

99

积分

-r--------

Rank: 1

积分
99
realact 发表于 2017-12-2 11:58:48 | 显示全部楼层
I also have this issue, has anyone found a solution yet? is recommended to download the latest Linux NVidia drivers and install them in Deepin? I hate the 3 ugly dots animation as well while I love the Deepin boot up animation.

5

主题

57

帖子

233

积分

-r--r-----

Rank: 2

积分
233
danygee 发表于 2017-12-2 21:57:46 | 显示全部楼层
Guys, if my splash screen config is set to 1024x768 then why is the shutdown animation in 1920x1080?
Does it have some different config file?
| OS: Deepin 15.5 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 375.26) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 |

0

主题

44

帖子

147

积分

-r--------

Rank: 1

积分
147
o4is 发表于 6 天前 | 显示全部楼层
danygee replied at 2017-12-2 21:57
Guys, if my splash screen config is set to 1024x768 then why is the shutdown animation in 1920x1080? ...

Back at home, at last, and as i promised, i'm going to post exactly the steps to bring back the splash.
So, i started to execute the steps from that thread https://bbs.deepin.org/forum.php?mod=viewthread&tid=145021&extra= and a few other solutions found on the internet.
Some of them(with some specific resolutions) did bring my splash screen back.
What is working best(the same or even better result with less effort) for me is this kernel parameter: vga=792, which brings back my splash screen in 1024x768. No modifying many files, no loading extra modules, no force of the framebuffer(i.e echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash), nothing else.
My grub file looks like this:

# Written by com.deepin.daemon.Grub2
GRUB_CMDLINE_LINUX=“”
GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0 splash vga=792 ipv6.disable=1"
GRUB_DEFAULT="0"
GRUB_DISTRIBUTOR="`/usr/bin/lsb_release -d -s 2>/dev/null || echo Deepin`"
GRUB_GFXMODE="1920x1080"
GRUB_TIMEOUT="1"

The other kernel parameters are to supress some warnings(some external disks that are always mounted in my system) and the disappearance of the cursor blinking during boot(+disable ipv6).
That is the only change you need to make.
I hope this works for you...

ps1: only vga=792 works for me. Other resolutions show the ugly gray splash with the three dots.
ps2: vga= is deprecated, but should still work.

5

主题

57

帖子

233

积分

-r--r-----

Rank: 2

积分
233
danygee 发表于 5 天前 | 显示全部楼层
o4is replied at 2017-12-6 14:37
Back at home, at last, and as i promised, i'm going to post exactly the steps to bring back the sp ...

Strange, your suggestions simply don't work for me.
Blinking cursor is also not hidden.
I give up for now.
The stupid animation should work out of the box even after installing proprietary drivers.
Its a closed loop of stupidity and human ego.
Open source allows to create multiple, different instances basically of the same thing.
That generates multiple distros with multiple desktop environments and multiple standarts, which can be gone by tomorrow (like Unity for example).
That generates too much work and risk for leading companies to put efford on something so unstable, like Linux Desktop is.
And that generates hundreds of workarounds, low quality apps and strange issues like this one.




| OS: Deepin 15.5 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 375.26) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 |

0

主题

44

帖子

147

积分

-r--------

Rank: 1

积分
147
o4is 发表于 5 天前 | 显示全部楼层
danygee replied at 2017-12-7 06:21
Strange, your suggestions simply don't work for me.
Blinking cursor is also not hidden.
I give up  ...

Intresting...
Is the grub file working properly?
Are the changes to grub(any change) reflected to boot?
Have you tried to apply the changes directly to the grub.cfg file or from the grub command line during boot?

3

主题

117

帖子

535

积分

-r--r--r--

Rank: 3Rank: 3

积分
535
oscararg 发表于 5 天前 | 显示全部楼层
Ok, in Manjaro or Arch Deepin you simply delete Plymouth and get rid of those problems, and as I said, Arch distros don't come with Plymouth because of that problem. Tried to do it on Deepin, it adviced me that if would delete the complete environtment base (DDE, LightDM, etc) from simply deleting Plymouth, weird. As I said, Nvidia drivers has it own splash, which can be changed by any picture or animation. Personally I think that Plymouth is an "old epoch" app which simply is unuseful.
@o4is so you changed the boot resolution from the probably HD screen you have to a low res vga screen?... I was reading about that silent boot, and wartched some videos, thanks, to my solution I can add the solution which make dissapear the texts.
Anyways, I want to get rid of Plymouth someday...

5

主题

57

帖子

233

积分

-r--r-----

Rank: 2

积分
233
danygee 发表于 5 天前 | 显示全部楼层
oscararg replied at 2017-12-7 13:54
Ok, in Manjaro or Arch Deepin you simply delete Plymouth and get rid of those problems, and as I sai ...

Do you know how to change the nvidia bootsplash image?
I could at least replace it with static deepin splash image.
| OS: Deepin 15.5 | MB: ASUS Z170 DELUXE | CPU: i7-6700K | GPU: nVidia GTX 1080 (Driver 375.26) | RAM: 32GB G-SKILL Ripjaws 4 | NET: I219-V Ethernet | AUDIO: NVIDIA GP104 HD Audio Controller | SSD: KINGSTON_SH100S3 |

3

主题

117

帖子

535

积分

-r--r--r--

Rank: 3Rank: 3

积分
535
oscararg 发表于 4 天前 | 显示全部楼层
danygee replied at 2017-12-7 12:07
Do you know how to change the nvidia bootsplash image?
I could at least replace it with static dee ...

You can, search for the Nvidia config file at /etc/X11/, you'll see a "NoLogo" option, change "true" with "false", and add another line with Option "LogoPath" "/etc/<some file name>.png"
Remember, the file needs to be in .png format, animated or not it doesn't matters, but in .png, and with root privileges. I've published a post with some useful tweaks for Nvidia some months ago, all changes can be done in that config file https://bbs.deepin.org/forum.php?mod=viewthread&tid=144008&extra=

3

主题

117

帖子

535

积分

-r--r--r--

Rank: 3Rank: 3

积分
535
oscararg 发表于 4 天前 | 显示全部楼层
Found that adding to sudo gedit /etc/default/grub the line GRUB_GFXPAYLOAD_LINUX="keep" solves the problem as good as all the steps I described haha, sudo update-initramfs -u and sudo update-grub2 after doing the change of course are needed too.
返回列表
12
发新帖
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部