发新帖

sudo apt-get update is giving GPG error

bions / 2017-11-15 00:13
浏览: 179 / 回复: 7
查看: 179|回复: 8

sudo apt-get update is giving GPG error

[复制链接]
收藏
跳转到指定楼层
Edited by bions at 2017-11-15 00:13

Sudo apt-get update is giving error. I´m running 15.4.1. Same error occurs in 15.5. (beta). I already tried different mirrors with same result. Do you know what`s wrong? Thanks!

sudo apt-get update
[sudo] password for ********
Get:1 http://repository.spotify.com stable InRelease [3,302 B]
Hit:2 http://ftp.acc.umu.se/mirror/linuxdeepin/packages panda InRelease
Ign:1 http://repository.spotify.com stable InRelease
Fetched 3,302 B in 0s (4,919 B/s)
Reading package lists... Done
W: GPG error: http://repository.spotify.com stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EFDC8610341D9410
W: The repository 'http://repository.spotify.com stable InRelease' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.



1

主题

21

帖子

72

积分

-r--------

Rank: 1

积分
72
ginnerpeace 发表于 5 天前 | 显示全部楼层
google it.

点评

That doesn't help in any way.  发表于 5 天前

3

主题

11

帖子

70

积分

-r--------

Rank: 1

积分
70
bions 发表于 5 天前 来自移动端 | 显示全部楼层
ginnerpeace replied at 2017-11-15 00:40
google it.

Thanks for an advice. Tried 5 different solutions BEFORE asking here.

4

主题

200

帖子

863

积分

-rw-r--r--

Rank: 4

积分
863
nipos 发表于 5 天前 | 显示全部楼层
Run this command:
sudo gedit /etc/apt/sources.list
Remove the repository.spotify.com line from the file.
Save it and try apt-get again.
The Spotify repository seams to have some bugs,removing it will fix it.

3

主题

11

帖子

70

积分

-r--------

Rank: 1

积分
70
bions 发表于 5 天前 | 显示全部楼层
nipos replied at 2017-11-15 22:37
Run this command:
sudo gedit /etc/apt/sources.list
Remove the repository.spotify.com line from the f ...

I do not have repository.spotify.com in /etc/apt/sources.list...

Only this/these:

# Generated by deepin-installer
# deb [by-hash=force] http://packages.deepin.com/deepin panda main contrib non-free
# deb-src http://packages.deepin.com/deepin panda main contrib non-free
##########################################################################################
deb [by-hash=force] http://ftp.acc.umu.se/mirror/linuxdeepin/packages/ panda main contrib non-free

I asked my friend and he said that he is having same gbg error in terminal...

4

主题

200

帖子

863

积分

-rw-r--r--

Rank: 4

积分
863
nipos 发表于 5 天前 | 显示全部楼层
If it's an repository problem,everyone has it...
In the /etc/apt folder,there should be any other folder which contains additional repositories.
Unfortunately I can't remember its name.
Try to find the Spotify repository file and delete it.
You will need the following command because Deepin Filemanager doesn't have root rights:
sudo rm /etc/apt/FOLDER/SPOTIFY-FILE.list
If the file contains more repository,use the Gedit command from my last post and remove only the spotify line.
Now apt-get should work.

评分

参与人数 1贡献 +3 收起 理由
melodyzou + 3 Thanks for the answer.

查看全部评分

3

主题

11

帖子

70

积分

-r--------

Rank: 1

积分
70
bions 发表于 4 天前 | 显示全部楼层
Thank you nipos! it helped! The correct location was /etc/apt/sources.list.d/spotify.list

27

主题

352

帖子

1891

积分

drw-r--r--

Rank: 7Rank: 7Rank: 7

积分
1891
melodyzou 超级版主 发表于 4 天前 | 显示全部楼层
bions replied at 2017-11-16 00:07
Thank you nipos! it helped! The correct location was /etc/apt/sources.list.d/spotify.list

Glad it solved.
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部