发新帖

关于深度软件包管理器安装deb(非商店)卸载DDE的收集

jingle 官方管理员 / 2017-11-28 17:30
浏览: 15604 / 回复: 21
查看: 15604|回复: 22

关于深度软件包管理器安装deb(非商店)卸载DDE的收集

[复制链接]
收藏
跳转到指定楼层
关于社区反馈安装非商店的deb文件时,会卸载dde桌面无任何提示(或规避警告等),现在收集大家遇到的deb包名或者包地址,谢谢大家。

例如:

https://download1.rstudio.org/rstudio-xenial-1.1.383-amd64.deb

http://download.teamviewer.com/d ... teamviewer_i386.deb

https://developer.android.com/studio/index.html


官方指定爆料员

81

主题

2136

帖子

8127

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
8127
licardo 发表于 2017-11-28 17:36:36 | 显示全部楼层
我以为正式版发布了呢.. @全部

68

主题

746

帖子

3786

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
3786
Feelup 发表于 2017-11-28 17:40:44 | 显示全部楼层
我还以为正式版发布了

13

主题

239

帖子

1557

积分

-rw-r--r--

Rank: 4

积分
1557
superbing 志愿者 发表于 2017-11-28 17:54:02 | 显示全部楼层
我还以为正式版发布了.gif
https://www.deepin.org/product/
小白很白

253

主题

1万

帖子

5万

积分

d-rw-rw-r--

Rank: 8Rank: 8

积分
53460
jingle 官方管理员 发表于 2017-11-30 16:13:45 | 显示全部楼层
。。。。。。。。。反馈几个能卸载的包不
官方指定爆料员

3

主题

294

帖子

2529

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2529
snyh1010 发表于 2017-11-30 16:55:18 | 显示全部楼层
官方仓库里面的 是可以直接分析出所有的和dde有冲突的包.

第三方deb就只能靠收集了.

5

主题

39

帖子

214

积分

-r--r-----

Rank: 2

积分
214
iYong 发表于 2017-11-30 21:55:15 | 显示全部楼层
https://download.teamviewer.com/download/teamviewer_i386.deb

0

主题

5

帖子

15

积分

-r--------

Rank: 1

积分
15
love_deepin 发表于 2018-3-19 12:38:00 来自移动端 | 显示全部楼层
。。。。。。。。。。。

40

主题

118

帖子

979

积分

-rw-r--r--

Rank: 4

积分
979
yyws2012 发表于 2018-5-9 08:03:32 来自移动端 | 显示全部楼层
Teamviewer用不了了吗

48

主题

4850

帖子

1万

积分

drw-r-----

Rank: 7Rank: 7Rank: 7

积分
15099

活跃会员热心会员论坛元老

sored520 发表于 2018-5-9 15:46:42 | 显示全部楼层
yyws2012 发表于 2018-5-9 08:03
Teamviewer用不了了吗

貌似后来说修复了

83

主题

5197

帖子

1万

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
13316
QQ
jianguo922 志愿者 发表于 2018-5-15 12:32:04 | 显示全部楼层
火狐提示无法卸载
深度值得深入!深度有你更精彩
https://www.52pojie.cn/home.php?mod=space&uid=275571
电脑型号三星370r5v-s01  CPU:Intel酷睿i53210M         
内存:4GB+2GB×1    显卡芯片:AMD Radeon HD 8750M(2G)

2

主题

10

帖子

151

积分

-r--------

Rank: 1

积分
151
anysoft 发表于 2018-5-31 09:41:16 | 显示全部楼层
本帖最后由 anysoft 于 2018-5-31 09:42 编辑

我昨天安装 sudo apt install GTK+-
【警告】以上命令在dde下不要运行...

然后 知道鞋子所有桌面环境......然后ctrl+c无效...最后我等卸载完毕后把终端提示信息copy,被卸载的软件重新安装一遍...
控制台输出如下:
deepin@deppin-PC:~/Downloads/remmina-plugin-teamviewer-1.2.3.0/remmina-plugin-builder-1.2.3.0$ sudo apt install GTK+-
正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
注意,根据正则表达式 'GTK+' 选中了 'libghc-gtk-dev'
注意,根据正则表达式 'GTK+' 选中了 'libcaribou-gtk-module'
注意,根据正则表达式 'GTK+' 选中了 'libocamlnet-gtk2-ocaml-dev-yfye6:i386'
注意,根据正则表达式 'GTK+' 选中了 'libaiksaurusgtk-1.2-0c2a'
...
....
注意,根据正则表达式 'GTK+' 选中了 'libtopmenu-server-gtk2-0'
注意,根据正则表达式 'GTK+' 选中了 'imhangul-gtk3'
软件包 python-aptdaemon-gtk 未安装,所以不会被卸载
软件包 libgtk-perl 未安装,所以不会被卸载
软件包 orion-gtk-theme 未安装,所以不会被卸载
软件包 crossfire-client-gtk2 未安装,所以不会被卸载
软件包 easymp3gain-gtk-dbg 未安装,所以不会被卸载
注意,选中 'empathy-common' 而非 'libempathy-gtk-common'
软件包 ettercap-gtk 未安装,所以不会被卸载
软件包 gtkwhiteboard 未安装,所以不会被卸载
软件包 fbreader-gtk 未安装,所以不会被卸载
...
....
使用'sudo apt autoremove'来卸载它(它们)。
将会同时安装下列软件:
  fonts-wqy-zenhei libjs-xmlextras libutempter0 lynx lynx-common mono-xsp4 mono-xsp4-base monodoc-http xbitmaps xterm
建议安装:
  xfonts-cyrillic
下列软件包将被【卸载】:
  adwaita-icon-theme android-studio apps.com.youdao.note atom bamfdaemon chmsee chrome-dde dde dde-api
  dde-control-center dde-daemon dde-desktop dde-disk-mount-plugin dde-file-manager dde-launcher dde-qt5integration
  dde-session-ui dde-trash-plugin deepin-appstore deepin-artwork deepin-crosswalk deepin-default-settings
  deepin-font-installer deepin-gtk-theme deepin-manual deepin-metacity deepin-qml-widgets deepin-terminal
  deepin-wine-helper:i386 deepin-wine-plugin deepin-wine-plugin-virtual deepin-wm deepin.com.qq.im:i386
  deepin.com.qq.office:i386 deepin.com.thunderspeed:i386 deepin.com.wechat:i386 eclipse-jee fcitx-config-common
  fcitx-config-gtk fcitx-frontend-gtk2 fcitx-frontend-gtk3 fcitx-sogoupinyin-uk file-roller filezilla firefox
  firefox-dde firefox-l10n-zh-cn gcr gedit gimp gir1.2-gtk-3.0 gir1.2-gtksource-3.0 gir1.2-peas-1.0 gir1.2-vte-2.91
  gksu gnome-calculator gnome-font-viewer gnome-icon-theme gnome-keyring gnome-themes-standard google-android-sdk
  google-chrome-stable gparted gstreamer1.0-plugins-bad gtk-update-icon-cache gtk2-engines gtk2-engines-murrine
  gtk2-engines-pixbuf gvfs-backends haguichi idea-community lastore-daemon libappindicator1 libappindicator3-1
  libatk-wrapper-java-jni libavahi-ui-gtk3-0 libbonoboui2-0 libcanberra-gtk3-0 libclutter-1.0-0 libclutter-gtk-1.0-0
  libdbusmenu-gtk3-4 libdbusmenu-gtk4 libdde-file-manager libdeepin-metacity-private3 libdeepin-mutter0g libdeepin-wm0
  libevdocument3-4 libevview3-3 libflashplugin-pepper libgail-common libgail18 libgcr-ui-3-1 libgimp2.0 libgksu2-0
  libglade2-0 libglade2.0-cil libgnome-desktop-3-12 libgnomecanvas2-0 libgnomeui-0 libgranite3 libgspell-1-1
  libgtk-3-0 libgtk-3-common libgtk2-perl libgtk2.0-0 libgtk2.0-cil libgtk2.0-common libgtkmm-2.4-1v5
  libgtksourceview-3.0-1 libgtksourceview-3.0-common libgtkspell0 libindicator3-7 libindicator7
  libjavascriptcoregtk-1.0-0 libjavascriptcoregtk-4.0-18 libmetacity1 libnautilus-extension1a libnm-gtk0 libnma0
  libopencv-calib3d2.4v5 libopencv-features2d2.4v5 libopencv-highgui2.4-deb0 libopencv-objdetect2.4v5 libpeas-1.0-0
  libqcef1 libqt5libqgtk2 libvte-2.91-0 libwebkit1.1-cil libwebkit2gtk-4.0-37 libwebkitgtk-1.0-0 libwnck-3-0 libwnck22
  libwxgtk3.0-0v5 libyelp0 metacity mintdrivers miraclecast monodoc-browser mysql-workbench netease-cloud-music
  network-manager-integration-plugins network-manager-l2tp-gnome network-manager-openconnect-gnome
  network-manager-openvpn-gnome network-manager-pptp-gnome network-manager-strongswan network-manager-vpnc-gnome
  open-vm-tools-desktop openjdk-8-jdk openjdk-8-jre pinentry-gnome3 playonlinux poedit postman python-glade2
  python-gnome2 python-gnomekeyring python-gtk2 python-rsvg python-ubuntu-kylin-sso-client python-wnck python-wxgtk3.0
  python3-aptdaemon.gtk3widgets rapidsvn remmina remmina-plugin-rdp remmina-plugin-vnc screenlets simple-scan
  skypeforlinux sogoupinyin startdde svn-workbench switchhosts synaptic system-config-printer
  system-config-printer-common thunderbird thunderbird-locale-zh-hans ubuntu-kylin-sso-client
  ubuntu-kylin-sso-client-qt ucx uex xdg-desktop-portal-gtk yandex-browser-beta yelp zenity
下列【新】软件包将被安装:
  fonts-wqy-zenhei libjs-xmlextras libutempter0 lynx lynx-common mono-xsp4 mono-xsp4-base monodoc-http xbitmaps xterm
升级了 0 个软件包,新安装了 10 个软件包,要卸载 187 个软件包,有 1 个软件包未被升级。
有 2 个软件包没有被完全安装或卸载。
需要下载 10.2 MB 的归档。
解压缩后将会空出 7,977 MB 的空间。
您希望继续执行吗? [Y/n] Y
获取:1 http://packages.deepin.com/deepin panda/main amd64 xterm amd64 330-1 [681 kB]
获取:2 http://packages.deepin.com/deepin panda/main amd64 monodoc-http all 4.2-2 [75.6 kB]
获取:3 http://packages.deepin.com/deepin panda/main amd64 mono-xsp4-base all 4.2-2.1 [80.0 kB]
获取:4 http://packages.deepin.com/deepin panda/main amd64 mono-xsp4 all 4.2-2.1 [92.9 kB]

已下载 10.2 MB,耗时 2秒 (3,921 kB/s)
正在预设定软件包 ...
正在设置 libgcrypt20:amd64 (1.8.1-4ubuntu1) ...
(正在读取数据库 ... 系统当前共安装有 390188 个文件和目录。)
正在卸载 poedit (2.0.4-1) ...
正在卸载 uex (16.1.0.22) ...
正在卸载 fcitx-config-gtk (0.4.10-1) ...
正在卸载 fcitx-config-common (0.4.10-1) ...
正在卸载 yelp (3.22.0-1) ...
正在卸载 libyelp0:amd64 (3.22.0-1) ...
正在卸载 android-studio (3.0.1.0) ...
正在卸载 apps.com.youdao.note (0.8.12) ...
正在卸载 atom (1.22.0-1) ...
正在卸载 dde (15.5+3) ...
正在卸载 startdde (3.1.23-5) ...
正在卸载 dde-session-ui (4.2.0.1-2) ...
正在卸载 chmsee (1.3.0-3) ...
正在卸载 chrome-dde (63.0.3239.132) ...
正在卸载 dde-control-center (4.3.7-1) ...
正在卸载 dde-api (3.1.18.1-2) ...
正在卸载 dde-desktop (4.5.4-1) ...
正在卸载 dde-disk-mount-plugin (4.5.4-1) ...
正在卸载 dde-file-manager (4.5.4-1) ...
正在卸载 dde-launcher (4.3.0-2) ...
正在卸载 deepin-appstore (4.0.12-1) ...
正在卸载 dde-qt5integration (0.2.8.3-1) ...
正在卸载 dde-trash-plugin (4.5.4-1) ...
正在卸载 deepin-default-settings (2018.1.22-1) ...
正在卸载 deepin-artwork (2015.3) ...
正在卸载 deepin-crosswalk (18.46.461.0-2) ...
dpkg: 警告: 卸载 deepin-crosswalk 时,目录 /lastore 非空,因而不会删除该目录
正在卸载 deepin-font-installer (1.0.4-1) ...
正在卸载 deepin-gtk-theme (17.10.5-6) ...
正在卸载 deepin-manual (2.0.8-3) ...
正在卸载 deepin-qml-widgets (2.3.6-5) ...
正在卸载 playonlinux (4.2.12-1) ...
正在卸载 dde-daemon (3.2.8.1-2) ...
正在卸载 bamfdaemon (0.5.3-2) ...
正在卸载 deepin-metacity (3.22.13-3) ...
update-alternatives: 使用 /usr/bin/metacity 来在自动模式中提供 /usr/bin/x-window-manager (x-window-manager)
dpkg: adwaita-icon-theme:有依赖问题,但是如您所愿,将继续卸载:
libgtk-3-0:amd64 依赖于 adwaita-icon-theme.
.....

正在卸载 deepin-terminal (2.8-1) ...
在处理时有错误发生:
haguichi
sh: 1: /var/lib/lastore/scripts/build_system_info: not found
E: Sub-process /usr/bin/dpkg returned an error code (1)
W: 操作在完成之前被打断
deepin@deppin-PC:~/Downloads/remmina-plugin-teamviewer-1.2.3.0/remmina-plugin-builder-1.2.3.0$ gedit
bash: gedit: 未找到命令


省略了一部分..总之怪自己执行命令后没看提示.....东西全卸载完了.幸亏终端没关闭,不然都无法安装东西了.
我把卸载的全部重新安装一遍后重启电脑,一切恢复原状
log附件:
https://bbs.deepin.org/forum.php?mod=attachment&aid=NTU2NjB8OWMzOTlmODIwNGFlOTZkYTQ0NmE0YzFkNWYyNDM0ZjJ8MTU5NzAzNTg5MQ%3D%3D&request=yes&_f=.zip


49

主题

311

帖子

1616

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1616
machine 志愿者 发表于 2018-7-21 11:46:29 来自移动端 | 显示全部楼层
关闭了终端也可以进tty啊

10

主题

74

帖子

497

积分

-r--r--r--

Rank: 3Rank: 3

积分
497
phenix828 发表于 2018-10-13 22:47:40 | 显示全部楼层
Anbox?或者snap?
反正让我无法进入桌面,重装了。

167

主题

3793

帖子

1万

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
12974
QQ
superendermansm 发表于 2019-1-10 09:06:45 来自移动端 | 显示全部楼层
使用deepin 15.6安装playonlinux会卸载dde!!!!!!!!

167

主题

3793

帖子

1万

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
12974
QQ
superendermansm 发表于 2019-1-10 09:07:36 来自移动端 | 显示全部楼层
求助如何重新安装?playonlinux可以不要可是dde需要啊!如何全新安装dde?

167

主题

3793

帖子

1万

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
12974
QQ
superendermansm 发表于 2019-1-10 09:08:44 来自移动端 | 显示全部楼层
最棘手的可能是没卸干净。。。dde-desktop和dde-dock都在,但是dde-file-manager和一堆轮子都没了

167

主题

3793

帖子

1万

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
12974
QQ
superendermansm 发表于 2019-1-10 09:10:53 来自移动端 | 显示全部楼层
显示无法将LC_ALL设置为缺省的语区:没有那个文件或目录。怎么办,现在终端里都是英文。。。

167

主题

3793

帖子

1万

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
12974
QQ
superendermansm 发表于 2019-1-10 09:27:23 来自移动端 | 显示全部楼层
幸好图形界面还在。。。正在救活deepin-appstore尝试

167

主题

3793

帖子

1万

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
12974
QQ
superendermansm 发表于 2019-5-18 09:37:11 来自移动端 | 显示全部楼层
这个帖子还要置顶么?debinstaller早就修复这个bug了
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部