发新帖

请教下deepin15.4.1龙芯版怎么装eclipse啊

captainjack / 2018-1-13 19:33
浏览: 585 / 回复: 59
楼主: captainjack

请教下deepin15.4.1龙芯版怎么装eclipse啊

[复制链接]

5

主题

37

帖子

156

积分

-r--------

Rank: 1

积分
156
captainjack 发表于 2018-1-13 22:38:27 | 显示全部楼层
windcz91 发表于 2018-1-13 22:11
是不是软件包没有mips64版本的缘故?

可能是吧,感觉生态差很多的说
I5-3470                         3A3000
B75                                8G DDR3
GTX950                         120G SSD
12G DDR3
128G SSD + 1T HDD

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-13 23:07:50 | 显示全部楼层
全部找不到不太可能,你試試裝個常用的軟件,例如
sudo apt-get update
sudo apt-get install planner
這個軟件在3B1500上都能裝
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-13 23:10:06 | 显示全部楼层
我已經裝了很多軟件,wps,librecad,freecad,mutt,remmina
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-13 23:14:28 | 显示全部楼层
captainjack 发表于 2018-1-13 21:24
请问能给个联系方式么,方便请教您问题

發email吧wangjy
在hpstar.ac.cn
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-13 23:27:10 | 显示全部楼层
windcz91 发表于 2018-1-13 22:11
是不是软件包没有mips64版本的缘故?

常見的軟件還是有mips64el的, 龍芯版會自動找deepin倉庫裏的mips64el
如果缺包,自己可以去debian網站下載deb包,但是一定要找mips64el的,一般包都有十幾種架構的
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

17

主题

645

帖子

2345

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2345
windcz91 发表于 2018-1-13 23:43:50 | 显示全部楼层
cyberhero 发表于 2018-1-13 23:27
常見的軟件還是有mips64el的, 龍芯版會自動找deepin倉庫裏的mips64el
如果缺包,自己可以去debian網站下載 ...

学习了~感谢
我在使用deepin过程中遇到的问题及解决方法,欢迎参考
https://bbs.deepin.org/forum.php?mod=viewthread&tid=141477&extra=

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-14 03:21:34 | 显示全部楼层
商店裏編程類就這些,沒有eclipse。
eclipse可能用的java,所以在debian倉庫會看到架構是all,也就是mips64el和x86下載的是同一個deb包。
但是需要配置好java,好像oracle java收費,現在都是openjdk,它確定可以裝在龍芯上,如何配置不太懂
深度截图_20180113123022.png
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-14 03:24:00 | 显示全部楼层
我裝了這些就不想繼續下去了
sudo dpkg -i eclipse_3.8.1-7_all.deb
[sudo] junyue 的密码:
正在选中未选择的软件包 eclipse。
(正在读取数据库 ... 系统当前共安装有 141176 个文件和目录。)
正准备解包 eclipse_3.8.1-7_all.deb  ...
正在解包 eclipse (3.8.1-7) ...
dpkg: 依赖关系问题使得 eclipse 的配置工作不能继续:
eclipse 依赖于 eclipse-jdt (>= 3.8.1-7);然而:
  未安装软件包 eclipse-jdt。
eclipse 依赖于 eclipse-pde (>= 3.8.1-7);然而:
  未安装软件包 eclipse-pde。

dpkg: 处理软件包 eclipse (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
eclipse
sudo dpkg -i eclipse-jdt_3.8.1-7_all.deb
正在选中未选择的软件包 eclipse-jdt。
(正在读取数据库 ... 系统当前共安装有 141182 个文件和目录。)
正准备解包 eclipse-jdt_3.8.1-7_all.deb  ...
正在解包 eclipse-jdt (3.8.1-7) ...
dpkg: 依赖关系问题使得 eclipse-jdt 的配置工作不能继续:
eclipse-jdt 依赖于 default-jre | java5-runtime | java6-runtime;然而:
  未安装软件包 default-jre。
  未安装软件包 java5-runtime。
  未安装软件包 java6-runtime。
eclipse-jdt 依赖于 eclipse-platform (>= 3.8.1-7);然而:
  未安装软件包 eclipse-platform。
eclipse-jdt 依赖于 junit (>= 3.8.2-4);然而:
  未安装软件包 junit。
eclipse-jdt 依赖于 junit4 (>= 4.10-2);然而:
  未安装软件包 junit4。
eclipse-jdt 依赖于 libhamcrest-java (>= 1.1-8~);然而:
  未安装软件包 libhamcrest-java。

dpkg: 处理软件包 eclipse-jdt (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
eclipse-jdt

LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-14 03:26:24 | 显示全部楼层
然後按照下面的可以裝java,以前在3A2000 deepin下裝過,基本能用
http://www.loongnix.org/index.ph ... 5%E8%AF%B4%E6%98%8E
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

2

主题

650

帖子

1875

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1875
wtz 发表于 2018-1-14 06:17:38 | 显示全部楼层
Eclipse这样的项目太大,不适合拿来学习编译。建议直接使用编译好的软件包。
可以把软件源换乘debian的仓库,这样就能使用 misp64el 这个架构了:
  1. deb http://ftp.cn.debian.org/debian unstable  main contrib non-free
复制代码

5

主题

37

帖子

156

积分

-r--------

Rank: 1

积分
156
captainjack 发表于 2018-1-14 07:33:03 | 显示全部楼层
cyberhero 发表于 2018-1-14 03:24
我裝了這些就不想繼續下去了
sudo dpkg -i eclipse_3.8.1-7_all.deb
[sudo] junyue 的密码:

额,我找到了这个包,也是这个问题,这是安装不上是么?JDK我已经装好了
I5-3470                         3A3000
B75                                8G DDR3
GTX950                         120G SSD
12G DDR3
128G SSD + 1T HDD

5

主题

37

帖子

156

积分

-r--------

Rank: 1

积分
156
captainjack 发表于 2018-1-14 07:33:59 | 显示全部楼层
wtz 发表于 2018-1-14 06:17
Eclipse这样的项目太大,不适合拿来学习编译。建议直接使用编译好的软件包。
可以把软件源换乘debian的仓库 ...

deb找不到命令,是还要加什么吗
I5-3470                         3A3000
B75                                8G DDR3
GTX950                         120G SSD
12G DDR3
128G SSD + 1T HDD

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-14 07:56:08 | 显示全部楼层
本帖最后由 cyberhero 于 2018-1-14 07:57 编辑
captainjack 发表于 2018-1-14 07:33
deb找不到命令,是还要加什么吗

sudo gedit /etc/apt/sources.list
如果可以,豈不是什麼都能裝了
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

5

主题

37

帖子

156

积分

-r--------

Rank: 1

积分
156
captainjack 发表于 2018-1-14 08:17:48 | 显示全部楼层
cyberhero 发表于 2018-1-14 07:56
sudo gedit /etc/apt/sources.list
如果可以,豈不是什麼都能裝了

这样改了之后eclipse还是无法安装啊
I5-3470                         3A3000
B75                                8G DDR3
GTX950                         120G SSD
12G DDR3
128G SSD + 1T HDD

5

主题

37

帖子

156

积分

-r--------

Rank: 1

积分
156
captainjack 发表于 2018-1-14 08:23:03 | 显示全部楼层
captainjack 发表于 2018-1-14 08:17
这样改了之后eclipse还是无法安装啊

下载 eclipse-pde
硬件架构         软件包大小         安装后大小         文件
amd64         65,003.7 kB        73,442.0 kB         [文件列表]
arm64         65,002.4 kB        73,442.0 kB         [文件列表]
armel         65,003.5 kB        73,441.0 kB         [文件列表]
armhf         65,002.2 kB        73,441.0 kB         [文件列表]
i386         65,001.8 kB        73,441.0 kB         [文件列表]
mips         65,002.7 kB        73,442.0 kB         [文件列表]
mipsel         65,002.6 kB        73,441.0 kB         [文件列表]
ppc64el         65,003.6 kB        73,442.0 kB         [文件列表]
s390x         65,004.7 kB        73,446.0 kB         [文件列表]

请问下这里的mipsel我下载了没用,是要下mips的这个吗
I5-3470                         3A3000
B75                                8G DDR3
GTX950                         120G SSD
12G DDR3
128G SSD + 1T HDD

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-14 08:29:21 | 显示全部楼层
captainjack 发表于 2018-1-14 08:23
下载 eclipse-pde
硬件架构         软件包大小         安装后大小         文件
amd64         65,003.7 kB        73,442.0 kB         [文件列表] ...

確實沒有mips64el
mips和mipsel是32位的應該不行
不知道了
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

5

主题

37

帖子

156

积分

-r--------

Rank: 1

积分
156
captainjack 发表于 2018-1-14 08:31:24 | 显示全部楼层
cyberhero 发表于 2018-1-14 08:29
確實沒有mips64el
mips和mipsel是32位的應該不行
不知道了

mips的也不行,不过还是谢谢了
I5-3470                         3A3000
B75                                8G DDR3
GTX950                         120G SSD
12G DDR3
128G SSD + 1T HDD

0

主题

5

帖子

14

积分

-r--------

Rank: 1

积分
14
monsterhu 发表于 2018-1-14 08:37:44 | 显示全部楼层
我有一个问题,eclipse不是用java语言写的吗?由于java的平台无关性,照理论讲,你只需安装一个java,配好jre环境就能运行eclipse了啊,不知道你说的龙芯有没有对应的jvm,但是linux操作系统都在龙芯上面跑了,java的跨平台性是相对与操作系统而言的,所以理论上很容易解决的

77

主题

538

帖子

2467

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2467
cyberhero 发表于 2018-1-14 08:37:51 | 显示全部楼层
captainjack 发表于 2018-1-14 08:31
mips的也不行,不过还是谢谢了

mipsel試過沒有
LOONGSON 3B1500 X1
LOONGSON 3A2000 X1
LOONGSON 3A3000 X5
DEEPIN LOONGSON PROFESSIONAL EDITION 15.4.1 X2
DEEPIN AMD64 PROFESSIONAL EDITION 15.4.1 X4

5

主题

37

帖子

156

积分

-r--------

Rank: 1

积分
156
captainjack 发表于 2018-1-14 08:57:06 | 显示全部楼层
monsterhu 发表于 2018-1-14 08:37
我有一个问题,eclipse不是用java语言写的吗?由于java的平台无关性,照理论讲,你只需安装一个java,配好j ...

jdk我是安装好了,龙芯官方的loongnix上自带了eclipse,但是deepin上没有,我在想是不是因为loongnix基于fedora,而deepin基于debian,所以要把loongnix里的包拿来编译一下?然而loongnix官网也找不到eclipse的包,现在也不知道怎么办了
I5-3470                         3A3000
B75                                8G DDR3
GTX950                         120G SSD
12G DDR3
128G SSD + 1T HDD
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部