发新帖

ACPI error无法安装,急疯了

Feacx / 2018-6-26 21:35
浏览: 14129 / 回复: 28
查看: 14129|回复: 28

ACPI error无法安装,急疯了

[复制链接]
收藏
跳转到指定楼层
每次安装都出这个提示,我刚买的新电脑,主板是华硕B360M - Plus,为什么不可以呢?
真的很想用deepin
我家里的amd用deepin,舒服的很,我已经爱上了这个系统。
我为此琢磨了三天了,仍然没研究出来为什么,我真的很抓狂。
我是一名程序员,i like it。
望大神 能帮帮我,帮我解决一下这个问题,可以有偿,我感激不尽(我感觉我有可能是以后的雷军或者马化腾)

上图:

微信图片_20180626213505.jpg
微信图片_20180626213505.jpg

0

主题

53

帖子

778

积分

-r--r--r--

Rank: 3Rank: 3

积分
778
limitos 发表于 2018-6-26 22:18:37 来自移动端 | 显示全部楼层
和我之前装上网本的时候有点像,但又好像不太一样,你看看是不是主板不支持64位引导的原因

2

主题

23

帖子

84

积分

-r--------

Rank: 1

积分
84
Feacx 发表于 2018-6-27 09:38:20 来自移动端 | 显示全部楼层
这个主板挺新的,应该都支持 但是我找不到acpi相关的东西

60

主题

3346

帖子

1万

积分

drw-r--r--

Rank: 7Rank: 7Rank: 7

积分
10978
QQ
kirigaya 超级版主 发表于 2018-6-27 11:06:49 | 显示全部楼层
开机,在列表那里按e,找到倒数第二行的linux那行,在splash后面加上nouveau.runpm=0参数试试。


https://blog.justforlxz.com | Deepin Developer | 永远不要放弃思考

1

主题

255

帖子

1236

积分

-rw-r--r--

Rank: 4

积分
1236
QQ
zarnest 发表于 2018-6-27 12:23:26 | 显示全部楼层
I+N双显卡的锅?
HuaWeiMateBookProX2019i58g512g

8

主题

39

帖子

280

积分

-r--r-----

Rank: 2

积分
280
albertchen 发表于 2018-6-28 09:34:46 来自移动端 | 显示全部楼层
刷新BIOS,在改启动参数,应该没问题

2

主题

23

帖子

84

积分

-r--------

Rank: 1

积分
84
Feacx 发表于 2018-6-28 11:45:40 | 显示全部楼层
albertchen 发表于 2018-6-28 09:34
刷新BIOS,在改启动参数,应该没问题

大哥,可以详细说一下不,我是华硕的板子,昨天试了集显也不行

2

主题

23

帖子

84

积分

-r--------

Rank: 1

积分
84
Feacx 发表于 2018-6-28 11:46:10 | 显示全部楼层
albertchen 发表于 2018-6-28 09:34
刷新BIOS,在改启动参数,应该没问题

具体板子型号是 华硕 b360m-plus

2

主题

23

帖子

84

积分

-r--------

Rank: 1

积分
84
Feacx 发表于 2018-6-28 17:30:28 | 显示全部楼层
我的这个问题好像解决了

具体解决办法是:编辑 /boot/grub/grub.cfg
把install deepin里面的命令里加了一行 acpi=off

具体如下:

menuentry "Install Deepin" {
        set gfxpayload=keep
        linux        /live/vmlinuz.efi boot=live acpi=off union=overlay livecd-installer locale=zh_CN quiet splash --
        initrd        /live/initrd.lz
}

但是又冒出了新问题

还是黑屏,文字是:
MODSIGN: Couldn't get UEFI db list


求解决方案

11

主题

352

帖子

1474

积分

-rw-r--r--

Rank: 4

积分
1474
alexander_1 发表于 2018-6-28 20:23:04 | 显示全部楼层
跟你一样,各种折腾

8

主题

39

帖子

280

积分

-r--r-----

Rank: 2

积分
280
albertchen 发表于 2018-6-28 20:37:01 | 显示全部楼层
我的意思是,华硕主板一般都有BIOS升级程序,去升级一下,and启动参数可以加 acpi_osi=! acpi_osi='Windows 2009'
vim /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi_osi=! acpi_osi='Windows 2009'"

8

主题

39

帖子

280

积分

-r--r-----

Rank: 2

积分
280
albertchen 发表于 2018-6-28 20:39:11 | 显示全部楼层
请善用google搜索
深度截图_选择区域_20180628203828.png

2

主题

23

帖子

84

积分

-r--------

Rank: 1

积分
84
Feacx 发表于 2018-6-28 21:30:05 | 显示全部楼层

我尝试了禁用安全模式,也在谷歌看到了这篇文章,可是由于这个主板好像太新,我设置不来。

错就错在不该买这么新的主板了。

我明天再尝试一下,看看禁用安全模式能否OK,谢谢兄台。

0

主题

4

帖子

23

积分

-r--------

Rank: 1

积分
23
mrwaiter 发表于 2018-11-22 15:07:16 | 显示全部楼层
Feacx 发表于 2018-6-28 17:30
我的这个问题好像解决了

具体解决办法是:编辑 /boot/grub/grub.cfg

加了之后真的能安装了,但是安装完成之后系统启动不了,grub选择之后就一只黑屏在那

0

主题

4

帖子

23

积分

-r--------

Rank: 1

积分
23
mrwaiter 发表于 2018-11-22 15:09:00 | 显示全部楼层
加了acpi=off之后真的能安装了,但是安装完成之后系统启动不了,grub选择之后就一只黑屏在那

1

主题

5

帖子

31

积分

-r--------

Rank: 1

积分
31
xfm_xfm 发表于 2018-12-19 13:28:03 | 显示全部楼层
mrwaiter 发表于 2018-11-22 15:09
加了acpi=off之后真的能安装了,但是安装完成之后系统启动不了,grub选择之后就一只黑屏在那 ...

再开机的时候在后面加上nomodeset

11

主题

352

帖子

1474

积分

-rw-r--r--

Rank: 4

积分
1474
alexander_1 发表于 2018-12-19 14:25:27 | 显示全部楼层
真的折腾啊

0

主题

6

帖子

30

积分

-r--------

Rank: 1

积分
30
fhehdwdnv 发表于 2018-12-19 14:53:01 | 显示全部楼层
我好像遇到过这个问题,你仔细看最后一行提示,有可能是U盘制作工具的问题,用rufus以DD的方式把iso文件写入U盘应该可以解决

1

主题

5

帖子

24

积分

-r--------

Rank: 1

积分
24
steven_tim 发表于 2018-12-19 17:18:30 | 显示全部楼层
u盘尽量插在2.0口上,而且把安全引导关闭,可能是板子不支持完整的uefi启动方式都会出现问题,

214

主题

4198

帖子

1万

积分

d-rw-rw-r--

Rank: 8Rank: 8

积分
15587
aida 官方管理员 志愿者 发表于 2019-2-26 09:18:15 | 显示全部楼层
Feacx 发表于 2018-6-28 17:30
我的这个问题好像解决了

具体解决办法是:编辑 /boot/grub/grub.cfg

DSDT(Differentiated System Description Table)是ACPI规格的一部分。它提供了关于一个给定系统中受支持的电源事件的信息。ACPI表是由制造商在固件里提供的。通常,Linux遇到的问题是某些ACPI功能的缺失,比如风扇不转,盖子合上时屏幕不熄灭等等。这些问题可以归咎于DSDT是为Windows所定制的。
在开机的时候,启动菜单(grub)按E键,按下面修改的话重启会失效
在quiet splash 前加入 acpi_osi=! acpi_osi="Windows 2009"                        
或者 acpi_osi="!Windows 2015"
还有其他的选项可以看一下这篇文章2009 对应Windows 7 and Server 2008 R2
2015 对应Widnows 10       

http://alexhungdmz.blogspot.com/ ... s-not-linux-in.html


保存配置的方法
编辑/etc/default/grub
找到GRUB_CMDLINE_LINUX_DEFAULT行
GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=! acpi_osi=\"Windows 2009\"  quiet splash "

然后更新grub配置文件
sudo update-grub


不建议直接修改 /boot/grub/grub.cfg,因为没有容错。





您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部