发新帖

求助,使用CrossOver安装windows下的VPN软件

liuchao / 2018-7-18 17:34
浏览: 1375 / 回复: 6
查看: 1375|回复: 6

求助,使用CrossOver安装windows下的VPN软件

[复制链接]
收藏
跳转到指定楼层
本帖最后由 liuchao 于 2018-7-18 17:37 编辑

       我现在工作中使用的是 window10,想要完全切换到 Deepin,其他都好说,就是公司有自己的VPN软件,只提供 windows 和 OSX 的。
我在虚拟机中安装了 Deepin,用 CrossOver 安装了公司的 VPN 软件,安装过程中出现错误:安装虚拟网卡驱动失败
不知道这是因为虚拟机的原因,还是这个软件就没法儿用,希望有类似经验的朋友帮帮忙。


QQ拼音截图未命名222.png

1

主题

255

帖子

1234

积分

-rw-r--r--

Rank: 4

积分
1234
QQ
zarnest 发表于 2018-7-18 18:34:34 | 显示全部楼层
windows下的vpn软件。。。这个涉及虚拟驱动真的没法模拟支持
HuaWeiMateBookProX2019i58g512g

11

主题

128

帖子

3001

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
3001
mokyle 志愿者 发表于 2018-7-18 19:05:40 | 显示全部楼层
本帖最后由 mokyle 于 2019-6-4 12:12 编辑

真是巧啊.我现在就是用的这个软件.
有linux版的.但是deepin好像不能用.https://pan.baidu.com/s/1t6T-9ekDE86J9C8ast2dCg,如果把deepin伪装成ubuntu14.04就能装上,但是每次连接上只有前大概5秒能联通,过一会就ping不通了.

变通的办法是用docker装ubuntu14.04里面装这个linux版的.然后对于需要连接vpn内网的软件,如果支持代理就在容器里面开代理供软件使用.如果不支持代理只能用vpn方式就将软件直接装在docker中. 所以我把idea装在容器中了,性能几乎没有影响.对于ssh工具就是使用的容器里面系统装的socks5代理.

docker run 部分参数: --shm-size="3g" -e DISPLAY=$DISPLAY -v /tmp/.X11-unix:/tmp/.X11-unix -v /home/docker:/home/docker -v /home/k:/k --privileged=true  -e PULSE_SERVER=tcp:k-pc:4713 -e PULSE_COOKIE=/run/pulse/cookie -v ~/.config/pulse/cookie:/run/pulse/cookie
(注意,必须加--privileged=true,必须不加--net=host)
运行docker中的scvpn前,在真机上先执行:xhost +

docker_scvpn.png



1

主题

3

帖子

18

积分

-r--------

Rank: 1

积分
18
liuchao 发表于 2018-7-18 19:06:51 | 显示全部楼层
zarnest 发表于 2018-7-18 18:34
windows下的vpn软件。。。这个涉及虚拟驱动真的没法模拟支持

多谢回答,我找到了这个VPN的官网,他们有一个Linux客户端,只支持下面几个固定版本的系统,而且好像软件安装前都要检测一下系统,不是那几个的话,就退出安装了

    64位的Ubuntu12.04桌面版(Gnome桌面环境)。
    64位的Ubuntu14.04桌面版(Gnome桌面环境)。
    64位的Ubuntu Kylin16.04桌面版(系统自带桌面)。
    64位的CentOS6.5桌面版(Gnome桌面环境)。

文档:http://docs.hillstonenet.com/cn/Content/7_VPN/SSL_VPN_Client_L.htm
VPN下载地址:https://www.hillstonenet.com.cn/product-and-service/border-security/ngfw/

有没有可能破解那个软件呢?哈哈,我是不是想多了

1

主题

3

帖子

18

积分

-r--------

Rank: 1

积分
18
liuchao 发表于 2018-7-18 19:13:03 | 显示全部楼层
mokyle 发表于 2018-7-18 19:05
真是巧啊.我现在就是用的这个软件.
有linux版的.但是deepin好像不能用.https://pan.baidu.com/s/1t6T-9ekDE ...

实在是太感谢了!我去试试

0

主题

2

帖子

8

积分

-r--------

Rank: 1

积分
8
sp910 发表于 6 天前 | 显示全部楼层
mokyle 发表于 2018-7-18 19:05
真是巧啊.我现在就是用的这个软件.
有linux版的.但是deepin好像不能用.https://pan.baidu.com/s/1t6T-9ekDE ...

你好,我现在也遇到类似问题,我机器是ubuntu18.04,把机器伪装成16.04成功安装上该软件,但是无法连接成功,如果按照您的方法,是否是需要安装一个桌面版的ubuntu14.04,然后通过vnc连接容器中的桌面吗?

11

主题

128

帖子

3001

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
3001
mokyle 志愿者 发表于 5 天前 | 显示全部楼层
sp910 发表于 2020-5-23 15:11
你好,我现在也遇到类似问题,我机器是ubuntu18.04,把机器伪装成16.04成功安装上该软件,但是无法连接成 ...

不需要vnc,全网搜索“docker运行GUI”了解下。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部