发新帖

升级wine4.0

deepinY / 2019-1-27 11:20
浏览: 7527 / 回复: 35
查看: 7527|回复: 35
打印 上一主题 下一主题

升级wine4.0

[复制链接]
收藏
跳转到指定楼层
本帖最后由 deepinY 于 2019-1-27 11:22 编辑

如题
本人电脑联想Y7000,deepin15.9
昨天成功升级wine4.0,过程如下
具体的可以参考wine官网教程:
https://wiki.winehq.org/Debian
1.添加仓库
/etc/apt/sources.list 添加
deb https://dl.winehq.org/wine-builds/debian/ stretch main

2.下载并安装存储库密钥
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key

3.检查更新
sudo apt update
4.安装稳定版wine4.0
sudo apt install --install-recommends winehq-stable
5.检查版本
wine --version
显示
wine-4.0
安装成功


评分

参与人数 1贡献 +3 收起 理由
lupodeepin + 3 加分鼓励 : )

查看全部评分

91

主题

525

帖子

2888

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2888
2#
dfqchina 发表于 2019-1-27 12:31:00 来自移动端 | 只看该作者
厉害,收藏了

67

主题

1364

帖子

6615

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
6615
QQ
3#
sonichy 志愿者 发表于 2019-1-27 20:33:57 来自移动端 | 只看该作者
不折腾,等官升

1

主题

10

帖子

91

积分

-r--------

Rank: 1

积分
91
4#
dashi 发表于 2019-1-27 22:01:32 | 只看该作者
自己动手的典范,赞赞赞

91

主题

525

帖子

2888

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2888
5#
dfqchina 发表于 2019-1-28 10:31:38 来自移动端 | 只看该作者
升成功了

27

主题

444

帖子

2042

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2042
6#
deepinY 发表于 2019-1-28 11:16:51 | 只看该作者
sonichy 发表于 2019-1-27 20:33
不折腾,等官升

确实不用折腾,不过就是升级着玩的,官方deepin-wine还在升级wine3.x

4

主题

19

帖子

215

积分

-r--r-----

Rank: 2

积分
215
7#
vker8588 志愿者 发表于 2019-1-28 14:59:30 | 只看该作者
OK,升级成功了。

6

主题

28

帖子

214

积分

-r--r-----

Rank: 2

积分
214
8#
em1874 发表于 2019-1-28 18:07:14 | 只看该作者
你好,请问,安装稳定版的时候出现所示错误怎么办?谢谢
  1. sudo apt install --install-recommends winehq-stable
  2. [sudo] mty 的密码:
  3. 正在读取软件包列表... 完成
  4. 正在分析软件包的依赖关系树      
  5. 正在读取状态信息... 完成      
  6. 将会同时安装下列软件:
  7.   gstreamer1.0-plugins-base:i386 libcapi20-3 libcapi20-3:i386
  8.   libcdparanoia0:i386 libexif12:i386 libgd3:i386 libgphoto2-6:i386
  9.   libgphoto2-l10n libgphoto2-port12:i386
  10.   libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
  11.   libieee1284-3:i386 libodbc1 liborc-0.4-0:i386 libosmesa6 libsane:i386
  12.   libsane-extras:i386 libsane-extras-common libsdl2-2.0-0:i386
  13.   libvisual-0.4-0:i386 libwayland-cursor0:i386 libwayland-egl1:i386
  14.   libwayland-egl1-mesa:i386 libxkbcommon0:i386 libxpm4:i386 libxss1:i386
  15.   ocl-icd-libopencl1 sane-utils update-inetd wine-stable
  16.   wine-stable-amd64 wine-stable-i386:i386
  17. 建议安装:
  18.   gvfs:i386 libgd-tools:i386 gphoto2:i386 libvisual-0.4-plugins:i386
  19.   gstreamer1.0-tools:i386 libmyodbc odbc-postgresql tdsodbc unixodbc-bin
  20.   avahi-daemon:i386 hplip:i386 opencl-icd avahi-daemon unpaper
  21. 下列【新】软件包将被安装:
  22.   gstreamer1.0-plugins-base:i386 libcapi20-3 libcapi20-3:i386
  23.   libcdparanoia0:i386 libexif12:i386 libgd3:i386 libgphoto2-6:i386
  24.   libgphoto2-l10n libgphoto2-port12:i386
  25.   libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
  26.   libieee1284-3:i386 libodbc1 liborc-0.4-0:i386 libosmesa6 libsane:i386
  27.   libsane-extras:i386 libsane-extras-common libsdl2-2.0-0:i386
  28.   libvisual-0.4-0:i386 libwayland-cursor0:i386 libwayland-egl1:i386
  29.   libwayland-egl1-mesa:i386 libxkbcommon0:i386 libxpm4:i386 libxss1:i386
  30.   ocl-icd-libopencl1 sane-utils update-inetd wine-stable
  31.   wine-stable-amd64 wine-stable-i386:i386 winehq-stable
  32. 升级了 0 个软件包,新安装了 33 个软件包,要卸载 0 个软件包,有 0 个软件包未被升级。
  33. 需要下载 27.3 MB/67.9 MB 的归档。
  34. 解压缩后会消耗 482 MB 的额外空间。
  35. 您希望继续执行吗? [Y/n] y
  36. 获取:1 https://dl.winehq.org/wine-builds/ubuntu xenial/main amd64 wine-stable-amd64 amd64 4.0~xenial [27.3 MB]
  37. 获取:1 https://dl.winehq.org/wine-builds/ubuntu xenial/main amd64 wine-stable-amd64 amd64 4.0~xenial [27.3 MB]
  38. 错误:1 https://dl.winehq.org/wine-builds/ubuntu xenial/main amd64 wine-stable-amd64 amd64 4.0~xenial
  39.   Could not wait for server fd - select (11: 资源暂时不可用) [IP: 151.101.110.217 443]
  40. E: 无法下载 https://dl.winehq.org/wine-builds/ubuntu/dists/xenial/main/binary-amd64/wine-stable-amd64_4.0~xenial_amd64.deb  Could not wait for server fd - select (11: 资源暂时不可用) [IP: 151.101.110.217 443]
  41. E: 有几个软件包无法下载,要不运行 apt-get update 或者加上 --fix-missing 的选项再试试?
复制代码

27

主题

444

帖子

2042

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2042
9#
deepinY 发表于 2019-1-28 18:13:14 | 只看该作者
em1874 发表于 2019-1-28 18:07
你好,请问,安装稳定版的时候出现所示错误怎么办?谢谢

按照提示运行sudo apt-get update
或者在后面加上--fix missing再运行

6

主题

28

帖子

214

积分

-r--r-----

Rank: 2

积分
214
10#
em1874 发表于 2019-1-28 18:18:07 | 只看该作者
deepinY 发表于 2019-1-28 18:13
按照提示运行sudo apt-get update
或者在后面加上--fix missing再运行

你好,提示的2个都已经试过了,还是不行

27

主题

444

帖子

2042

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2042
11#
deepinY 发表于 2019-1-28 18:21:44 | 只看该作者
em1874 发表于 2019-1-28 18:18
你好,提示的2个都已经试过了,还是不行

运行后的结果是怎么样的

6

主题

28

帖子

214

积分

-r--r-----

Rank: 2

积分
214
12#
em1874 发表于 2019-1-28 18:26:29 | 只看该作者
deepinY 发表于 2019-1-28 18:21
运行后的结果是怎么样的

你好可以了,谢谢你。之前我自己按着提示来了一遍不行,刚刚受你提醒我又搞了一遍可以了,好奇怪
  1. wine --version
  2. wine-4.0
复制代码

27

主题

444

帖子

2042

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2042
13#
deepinY 发表于 2019-1-28 18:30:14 | 只看该作者
em1874 发表于 2019-1-28 18:26
你好可以了,谢谢你。之前我自己按着提示来了一遍不行,刚刚受你提醒我又搞了一遍可以了,好奇怪
...

安装好就行了

6

主题

28

帖子

214

积分

-r--r-----

Rank: 2

积分
214
14#
em1874 发表于 2019-1-28 18:35:12 | 只看该作者

好的,谢谢

0

主题

8

帖子

423

积分

-r--r--r--

Rank: 3Rank: 3

积分
423
15#
myprecious 发表于 2019-5-20 22:24:34 来自移动端 | 只看该作者
一直是提示无法定位软件包 winehq-stable

27

主题

444

帖子

2042

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2042
16#
deepinY 发表于 2019-5-20 22:28:14 | 只看该作者
myprecious 发表于 2019-5-20 22:24
一直是提示无法定位软件包 winehq-stable

按照步骤检查一下在源里面添加的是不是正确

22

主题

416

帖子

1273

积分

-rw-r--r--

Rank: 4

积分
1273
17#
lbygljq 发表于 2019-6-19 19:44:22 | 只看该作者
学习了,今天试试在15.10版本上升级。

0

主题

3

帖子

12

积分

-r--------

Rank: 1

积分
12
18#
lf3921 发表于 2019-6-27 11:21:16 | 只看该作者
PC:~$ sudo apt install --install-recommends winehq-stable
正在读取软件包列表... 完成
正在分析软件包的依赖关系树      
正在读取状态信息... 完成      
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
libkf5coreaddons5 : 破坏: libkf5auth5 (< 5.46) 但是 5.28.0-2 正要被安装
                     破坏: libkf5globalaccel-bin (< 5.46) 但是 5.28.0.1-1+comsta 正要被安装
libkf5crash5 : 破坏: libkf5globalaccel-bin (< 5.46) 但是 5.28.0.1-1+comsta 正要被安装
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。



救救我

27

主题

444

帖子

2042

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2042
19#
deepinY 发表于 2019-6-27 12:43:50 | 只看该作者
lf3921 发表于 2019-6-27 11:21
PC:~$ sudo apt install --install-recommends winehq-stable
正在读取软件包列表... 完成
正在分析软件包 ...

依赖问题,我也解决不了,你可以试试安装开发版

0

主题

3

帖子

12

积分

-r--------

Rank: 1

积分
12
20#
lf3921 发表于 2019-6-27 14:05:20 | 只看该作者
deepinY 发表于 2019-6-27 12:43
依赖问题,我也解决不了,你可以试试安装开发版

好的,我试试哈
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部