发新帖

QQ音乐deepin-wine deb包

gorquan 志愿者 / 2019-8-1 12:38
浏览: 7220 / 回复: 77
楼主: gorquan

QQ音乐deepin-wine deb包

[复制链接]

47

主题

419

帖子

2250

积分

dr--r--r--

Rank: 7Rank: 7Rank: 7

积分
2250
QQ
mistylinux 志愿者 发表于 2019-9-3 17:25:20 | 显示全部楼层
真神奇,我封装了一个navcat的deb就给我屏蔽帖子了,QQ音乐就可以???
品牌:小米Ruby15.6集显版
CPU : (英特尔)Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz
显卡:Intel(R) HD Graphics 620
内存:32G
硬盘:256+512 SSD
声卡:  
网卡:RTL8821CE

4

主题

175

帖子

610

积分

-r--r--r--

Rank: 3Rank: 3

积分
610
jieyi 发表于 2019-9-4 17:51:44 | 显示全部楼层
zihaoxing 发表于 2019-9-1 12:55
国内的360软件商店for linux,优麒麟,新支点,deepin等公司和linux个人爱好者能不能合作一起搞一个wine软件 ...

要是能一起合作了,不如直接合作开发Linux原生应用

0

主题

3

帖子

25

积分

-r--------

Rank: 1

积分
25
zyhx1799 发表于 2019-9-7 06:48:55 | 显示全部楼层
本帖最后由 zyhx1799 于 2019-9-7 07:00 编辑

在wine-4.02-ubuntu环境下:
1.安装”QQMusic_YQQProductNew.exe”,QQ音乐界面无乱码问题;
2.用”gorquan”编译的QQ音乐deepin-wine.deb包,修改QQ音乐的启动脚本,但仍按”deepin-wine”的应用软件路径,编辑完成”wine-QQMusic_ubuntu.squashfs”(69.9M),软件使用效果不错.在此,特感谢"gorquan"的辛勤奉献!!!
3.单独编辑wine应用软件路径,自成一体,参考”deepin-wine”的思路,理论上是可行的,但修改启动脚本太费时,编译很费神.
4.使用须知:先安装wine-ubuntu 环境后,再使用QQ音乐;deepin系统已集成deepin-wine环境,只安装wine-ubuntu 环境即可,理论上讲在ubuntu系统上,安装wine-ubuntu 环境后,还应安装deepin-wine环境,原因是借用了”deepin-wine”的外壳和部分启动脚本.
5.在ubuntu18.04.3系统下,制作成各自的压缩包:wine-ubuntu 环境和deepin-wine环境,解压后按说明一键安装即可,在安装时,对不同的系统内核,会自动安装缺失的依赖(须联网).
分享地址:
1.wine-ubuntu 环境
https://pan.baidu.com/s/1_1HFtfncOr9eXIyamAhfeg 提取码: tycd
2.deepin-wine环境
https://pan.baidu.com/s/1S970xSaqOeM0o6bGpQZgdA 提取码: yw7x
3.QQ音乐(wine)
https://pan.baidu.com/s/1TPW7Qnqj7Oy6MM_dIIPipg 提取码: 6fb2

5

主题

49

帖子

284

积分

-r--r-----

Rank: 2

积分
284
liu2445342557 发表于 2019-9-7 09:41:55 | 显示全部楼层
zyhx1799 发表于 2019-9-7 06:48
在wine-4.02-ubuntu环境下:
1.安装”QQMusic_YQQProductNew.exe”,QQ音乐界面无乱码问题;
2.用”gorquan” ...

我下载并安装wine-ubuntu之后整个系统的依赖全被破坏了
Arch

0

主题

3

帖子

25

积分

-r--------

Rank: 1

积分
25
zyhx1799 发表于 2019-9-7 10:27:20 | 显示全部楼层
本帖最后由 zyhx1799 于 2019-9-7 11:12 编辑
liu2445342557 发表于 2019-9-7 09:41
我下载并安装wine-ubuntu之后整个系统的依赖全被破坏了

抱歉!不知你用的是什么系统,我系统是ubuntu-18.04.3,内核4.15.0-59,压缩包安装时,根据各自系统情况会有取舍(即有些deb包不会安装,系统缺失的依赖将会自动下载安装).哎,这都是折腾惹的错!

18

主题

303

帖子

877

积分

-rw-r--r--

Rank: 4

积分
877
byx8848320105 发表于 2019-9-7 10:37:02 | 显示全部楼层
网易云音乐也不错哦,而且是linux.

5

主题

49

帖子

284

积分

-r--r-----

Rank: 2

积分
284
liu2445342557 发表于 2019-9-7 13:15:23 | 显示全部楼层
zyhx1799 发表于 2019-9-7 10:27
抱歉!不知你用的是什么系统,我系统是ubuntu-18.04.3,内核4.15.0-59,压缩包安装时,根据各自系统情况会有取 ...

我是deepin15.11,用安装sh脚本安装会破坏系统依赖
Arch

2

主题

41

帖子

222

积分

-r--r-----

Rank: 2

积分
222
gorquan 志愿者 发表于 2019-9-9 15:57:57 | 显示全部楼层
byx8848320105 发表于 2019-9-7 10:37
网易云音乐也不错哦,而且是linux.

我比较喜欢QQ音乐,谢谢

2

主题

41

帖子

222

积分

-r--r-----

Rank: 2

积分
222
gorquan 志愿者 发表于 2019-9-9 15:59:39 | 显示全部楼层
liu2445342557 发表于 2019-9-7 13:15
我是deepin15.11,用安装sh脚本安装会破坏系统依赖

deepin直接安装deb包就行,如果报问题升级一下deepin-wine组件

2

主题

41

帖子

222

积分

-r--r-----

Rank: 2

积分
222
gorquan 志愿者 发表于 2019-9-9 16:01:15 | 显示全部楼层
zyhx1799 发表于 2019-9-7 06:48
在wine-4.02-ubuntu环境下:
1.安装”QQMusic_YQQProductNew.exe”,QQ音乐界面无乱码问题;
2.用”gorquan” ...

如果从头开始安装,一段时间后QQ音乐会报错退出,且退出后再无法打开软件。我封装的版本解决了这个问题,但是解决方式不优雅

2

主题

41

帖子

222

积分

-r--r-----

Rank: 2

积分
222
gorquan 志愿者 发表于 2019-9-9 16:02:32 | 显示全部楼层
mistylinux 发表于 2019-9-3 17:25
真神奇,我封装了一个navcat的deb就给我屏蔽帖子了,QQ音乐就可以???

右转出门找管理员解决,不要在这里挑事,谢谢

2

主题

41

帖子

222

积分

-r--r-----

Rank: 2

积分
222
gorquan 志愿者 发表于 2019-9-9 16:04:39 | 显示全部楼层
pplokijuhyg 发表于 2019-9-3 14:48
歌词的配置不能保存哦 重启之后大小显示还是默认的

因为暴力解决了QQ音乐报错的问题。。这个问题我有时间修复一下

4

主题

65

帖子

361

积分

-r--r-----

Rank: 2

积分
361
every6 发表于 2019-9-10 23:21:39 来自移动端 | 显示全部楼层
byx8848320105 发表于 2019-9-7 10:37
网易云音乐也不错哦,而且是linux.

我也喜欢用网易云音乐,但是Linux版的更新进度太慢了,好歹出个心动模式呀!

0

主题

2

帖子

70

积分

-r--------

Rank: 1

积分
70
bluesfu 发表于 2019-9-11 14:46:18 | 显示全部楼层
在linuxmint下直接用wine4.0装上了。除了右键点击状态栏图标显示不全外,基本上完美使用。。。字体显示勉强算是正常。

2

主题

41

帖子

222

积分

-r--r-----

Rank: 2

积分
222
gorquan 志愿者 发表于 2019-9-11 15:26:28 | 显示全部楼层
bluesfu 发表于 2019-9-11 14:46
在linuxmint下直接用wine4.0装上了。除了右键点击状态栏图标显示不全外,基本上完美使用。。。字体显示勉强 ...

更新了? mv和安装后第二次启动有没有报错?

5

主题

49

帖子

284

积分

-r--r-----

Rank: 2

积分
284
liu2445342557 发表于 2019-9-11 16:43:10 | 显示全部楼层
gorquan 发表于 2019-9-9 15:59
deepin直接安装deb包就行,如果报问题升级一下deepin-wine组件

已经换到manjaro了
Arch

2

主题

41

帖子

222

积分

-r--r-----

Rank: 2

积分
222
gorquan 志愿者 发表于 2019-9-11 18:56:35 | 显示全部楼层

我平板也装了manjaro,打算过两天研究下乱码打包出来

0

主题

2

帖子

70

积分

-r--------

Rank: 1

积分
70
bluesfu 发表于 2019-9-11 19:31:03 | 显示全部楼层
gorquan 发表于 2019-9-11 15:26
更新了? mv和安装后第二次启动有没有报错?

mv加了gdiplus函数库不会闪退了。。。已经打开了,二次启动不起来点了没反应,应该算是没问题

2

主题

41

帖子

222

积分

-r--r-----

Rank: 2

积分
222
gorquan 志愿者 发表于 2019-9-11 22:31:08 | 显示全部楼层
bluesfu 发表于 2019-9-11 19:31
mv加了gdiplus函数库不会闪退了。。。已经打开了,二次启动不起来点了没反应,应该算是没问题 ...

牛逼 我想不到mv怎么解决.启动那个反而搞定了

5

主题

49

帖子

284

积分

-r--r-----

Rank: 2

积分
284
liu2445342557 发表于 2019-9-12 16:44:38 | 显示全部楼层
gorquan 发表于 2019-9-11 18:56
我平板也装了manjaro,打算过两天研究下乱码打包出来

好的,谢谢大佬
Arch
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部