发新帖

求助,docker安装就是找不到对应镜像!

pds_lxymmm / 2019-11-8 22:00
浏览: 70 / 回复: 3
查看: 70|回复: 3

求助,docker安装就是找不到对应镜像!

[复制链接]
收藏
跳转到指定楼层
我是刚买的荣耀magicbook,预装的是deepin 15.5,然后今天按照https://wiki.deepin.org/wiki/Docker上的教程安装docker时,进行到第5步不成功了,但是我的报错信息是这样的。
  1. sudo add-apt-repository  "deb [arch=amd64] https://download.docker.com/linux/debian jessie stable"
  2. Traceback (most recent call last):
  3.   File "/usr/bin/add-apt-repository", line 95, in <module>
  4.     sp = SoftwareProperties(options=options)
  5.   File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
  6.     self.reload_sourceslist()
  7.   File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
  8.     self.distro.get_sources(self.sourceslist)   
  9.   File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 93, in get_sources
  10.     (self.id, self.codename))
  11. aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Deepin/camel
复制代码
然后我看论坛里面的在source.list.d下新建docker.list,并添加
  1. deb [arch=amd64] https://mirrors.tuna.tsinghua.edu.cn/docker-ce/linux/debian/ jessie stable

复制代码
但是这样还不行,还是一样找不到这个版本,这是怎么回事?请高手解答下

54

主题

1744

帖子

6704

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
6704
lidanger 志愿者 发表于 7 天前 | 显示全部楼层
直接安装 sudo apt install docker-ce 不好么。最新版本可以去 docker 官网,需要运行一个脚本。网上相关教程也很多。
士别三日当刮目相待

1

主题

2

帖子

11

积分

-r--------

Rank: 1

积分
11
pds_lxymmm 发表于 7 天前 | 显示全部楼层
lidanger 发表于 2019-11-8 22:15
直接安装 sudo apt install docker-ce 不好么。最新版本可以去 docker 官网,需要运行一个脚本。网上相关教 ...

醉了,原来这个版本可以不用这么麻烦,我还整了一堆。。。

11

主题

259

帖子

833

积分

-rw-r--r--

Rank: 4

积分
833
ruclinux 发表于 6 天前 | 显示全部楼层
一般apt安装不了的,就上官网找源码包configure
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部