发新帖

deepin下为什么没有openssl-devel这个包啊?

widon1104 / 2019-11-14 22:21
浏览: 92 / 回复: 4
查看: 92|回复: 5

deepin下为什么没有openssl-devel这个包啊?

[复制链接]
收藏
跳转到指定楼层
deepin下为什么没有openssl-devel这个包啊?
我编译提示
configure: error: *** OpenSSL headers missing - please install first or check config.log ***
不知道如何解决


28

主题

534

帖子

2817

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2817
inface 发表于 2019-11-14 22:31:25 来自移动端 | 显示全部楼层
devel是redhat系列的命名吧,dev一般是debian的

11

主题

301

帖子

955

积分

-rw-r--r--

Rank: 4

积分
955
ruclinux 发表于 2019-11-14 22:32:53 | 显示全部楼层
打开config.log里边看一看error提示。一般完整包编译的会自带这个包的

71

主题

296

帖子

1654

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1654
widon1104 发表于 2019-11-14 22:37:45 | 显示全部楼层
inface 发表于 2019-11-14 22:31
devel是redhat系列的命名吧,dev一般是debian的

widon@widon-deepin:~/soft/Psiphon3-for-Linux/openssh-5.9p1$ sudo apt install openss
openssh-client       openssh-server       openssn
openssh-client-ssh1  openssh-sftp-server  openssn-data
openssh-known-hosts  openssl              openssn-dbg
openss开头的包只有这几个,没有openssl-dev

57

主题

2206

帖子

8170

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
8170
lidanger 志愿者 发表于 2019-11-14 22:41:01 | 显示全部楼层
你需要的是 libssl-dev 这个包吧,里面应该有头文件。

点评

对的  发表于 2019-11-14 22:46
士别三日当刮目相待
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部