发新帖

如何手动安装NVIDIA驱动软件

deepinuser17 / 2019-11-21 14:04
浏览: 10892 / 回复: 136
楼主: deepinuser17

如何手动安装NVIDIA驱动软件

  [复制链接]

3

主题

42

帖子

281

积分

-r--r-----

Rank: 2

积分
281
zhouzhinian 发表于 2020-4-18 02:23:36 | 显示全部楼层
这个方法最好,两次成功了
操作系统:
Deepin 20 Beta Linux 5.3.0-3-amd64 (Debian 8.3.0-6) #1 SMP deepin 5.3.15-6apricot (2020-04-13)
处理器:
Intel(R) Core(TM) i5-8400 @ 2.80GHz x 6
主板:
ASUSTeK COMPUTER INC. TUF B360M-PLUS GAMING S (ASUSTeK Computer Inc. Device 8694)
内存:
15.6GB (Kingston DDR4 2666 MT/s)
存储设备:
Galaxy GX0128ML1 (119GB ) / Netac SSD 256GB (238GB )
显示适配器:
NVIDIA GP106 [GeForce GTX 1060 6GB] (NVIDIA C

3

主题

87

帖子

460

积分

-r--r--r--

Rank: 3Rank: 3

积分
460
chenjunan0724 发表于 2020-4-18 09:53:07 | 显示全部楼层
眼。。。

18

主题

215

帖子

1060

积分

-rw-r--r--

Rank: 4

积分
1060
mahuan 发表于 2020-4-18 12:00:02 来自移动端 | 显示全部楼层
trader_r 发表于 2019-11-28 21:07
谢谢,终于安装成功了!

你用的显卡感觉画面怎样?我怎么感觉你的显卡驱动没有加载呢?没有进程?

18

主题

215

帖子

1060

积分

-rw-r--r--

Rank: 4

积分
1060
mahuan 发表于 2020-4-18 12:08:04 来自移动端 | 显示全部楼层
ghs19812004 发表于 2020-4-7 14:20
应该是同样明白你说的意思了!完成后驱动的序号好却又不对,我安装的是340.08的。不知道它为什么会显示39 ...

楼主下面有个几十kb的附件你下载了吗?从你的截图终端返回来看,你的好像第二步就错了!我的2060都装好了!还有不换你装的哪个版本的闭源驱动,系统显卡管理器里的版本号都是不变的,不是跟随你安装的版本号来变化的

18

主题

215

帖子

1060

积分

-rw-r--r--

Rank: 4

积分
1060
mahuan 发表于 2020-4-18 12:10:47 来自移动端 | 显示全部楼层
yingshuang 发表于 2020-4-16 19:43
确定是安装完成了吗? 进入桌面后显卡还是没有任何进程使用??
是不是少了关键的设置,这个安装包谁都能装 ...

确实,有很多人只是安装上了驱动,但是系统把驱动却没有加载!太小白的容易被忽略

17

主题

601

帖子

2666

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2666
deepinuser17 发表于 2020-4-18 12:27:22 | 显示全部楼层
yingshuang 发表于 2020-4-16 19:43
确定是安装完成了吗? 进入桌面后显卡还是没有任何进程使用??
是不是少了关键的设置,这个安装包谁都能装 ...

如果你的机器有Intel内置显卡,加NVIDIA独立显卡,你需要手动调节到使用NVIDIA独立显卡。 本贴的开头,有如何切换到NVIDIA独立显卡的链接。

4

主题

138

帖子

535

积分

-r--r--r--

Rank: 3Rank: 3

积分
535
ghs19812004 发表于 2020-4-18 13:11:17 | 显示全部楼层
mahuan 发表于 2020-4-18 12:08
楼主下面有个几十kb的附件你下载了吗?从你的截图终端返回来看,你的好像第二步就错了!我的2060都装好了 ...

谢谢,不能正常使用,后来就把它干掉了。现在换成V20,好像不用再单独去显卡驱动了!
曾经沧海难为水,除却巫山不是云!

24

主题

397

帖子

1859

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1859
QQ
houyawei 发表于 2020-4-18 13:13:21 | 显示全部楼层
v20好像直接sudo apt install nvidia-driver就安装了
OS: Deepin 20 Beta n/a
Kernel: x86_64 Linux 5.3.0-3-amd64
Resolution: 1920x1080
DE: Deepin Beta
WM: KWin
Icon Theme: smartisan_bloom
CPU: Intel Core i5-6300HQ @ 4x 3.2GHz
GPU: GeForce GTX 960M
RAM: 11917MiB

18

主题

215

帖子

1060

积分

-rw-r--r--

Rank: 4

积分
1060
mahuan 发表于 2020-4-18 13:38:50 来自移动端 | 显示全部楼层
houyawei 发表于 2020-4-18 13:13
v20好像直接sudo apt install nvidia-driver就安装了

没有测试过,按版主方法装的,如果像你的这么简单就能安装那真是太棒了

4

主题

138

帖子

535

积分

-r--r--r--

Rank: 3Rank: 3

积分
535
ghs19812004 发表于 2020-4-18 15:39:50 | 显示全部楼层
本帖最后由 ghs19812004 于 2020-4-18 15:45 编辑
houyawei 发表于 2020-4-18 13:13
v20好像直接sudo apt install nvidia-driver就安装了

确实可以行,一下子安装了59个安装包。

不知道为什么在这个界面长久停留

不知道为什么在这个界面长久停留
曾经沧海难为水,除却巫山不是云!

4

主题

138

帖子

535

积分

-r--r--r--

Rank: 3Rank: 3

积分
535
ghs19812004 发表于 2020-4-18 16:16:17 | 显示全部楼层
测试完了,不兼容,只能卸载了。安装的时候提示是安装了59个包,卸载时提示只卸掉了44个。
曾经沧海难为水,除却巫山不是云!

0

主题

6

帖子

150

积分

-r--------

Rank: 1

积分
150
renghaoa 发表于 2020-4-21 22:52:18 来自移动端 | 显示全部楼层
安装完成后重启卡在这个界面进不了桌面。之前15.11也是手动安装成功的的,这次方法没变。
IMG_20200417_024043.jpg

17

主题

601

帖子

2666

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2666
deepinuser17 发表于 2020-4-21 23:13:58 | 显示全部楼层
renghaoa 发表于 2020-4-21 22:52
安装完成后重启卡在这个界面进不了桌面。之前15.11也是手动安装成功的的,这次方法没变。 ...

按Ctrl + Alt + F3键组合,转换到文本终端。 登录。 然后查看/var/log/Xorg.0.log文件。 这个文件里有出错信息。 你的机器有几个显卡?发一下"lspci | egrep "VGA|3D""的结果上来

0

主题

4

帖子

35

积分

-r--------

Rank: 1

积分
35
aj74aguk 发表于 2020-4-22 21:47:01 | 显示全部楼层
兄弟们,求救。
完全按照剧本安装的,nvidia-smi能用了,但是Nvidia X Server Settings就是打不开,点了没反映。GPU 使用率一直是0, nvidia-settings也如图所示,没法打开。我也不知道自己的电脑显示现在是用什么来驱动的,头疼,折腾了好久了。 Screen Capture_deepin-devicemanager_20200422154522.png Screen Capture_deepin-terminal_20200422154117.png



0

主题

4

帖子

35

积分

-r--------

Rank: 1

积分
35
aj74aguk 发表于 2020-4-22 22:54:12 | 显示全部楼层
houyawei 发表于 2020-4-18 13:13
v20好像直接sudo apt install nvidia-driver就安装了

即便是这样,安装完成了,重启计算机,还是没有nvidia-smi

17

主题

601

帖子

2666

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2666
deepinuser17 发表于 2020-4-23 00:11:39 | 显示全部楼层
本帖最后由 deepinuser17 于 2020-4-23 00:15 编辑
aj74aguk 发表于 2020-4-22 21:47
兄弟们,求救。
完全按照剧本安装的,nvidia-smi能用了,但是Nvidia X Server Settings就是打不开,点了没 ...

你的机器有双显卡。内置显卡Intel 520目前为系统初始设置。参见本帖开头提供的链接手动转换到NVIDIA独立显卡.

每个显卡都有对应的PCI bus ID. 系统使用的显卡的PCI bus ID会在/var/log/Xorg.0.log里记录.

运行以下命令可以确认:
  1. lspci | egrep "VGA|3D"

  2. grep PCI /var/log/Xorg.0.log
复制代码



0

主题

6

帖子

150

积分

-r--------

Rank: 1

积分
150
renghaoa 发表于 2020-4-23 01:23:03 | 显示全部楼层
deepinuser17 发表于 2020-4-21 23:13
按Ctrl + Alt + F3键组合,转换到文本终端。 登录。 然后查看/var/log/Xorg.0.log文件。 这个文件里有出 ...

[    26.635]
X.Org X Server 1.20.4
X Protocol Version 11, Revision 0
[    26.635] Build Operating System: Linux 4.19.0-6-amd64 x86_64 Uos
[    26.635] Current Operating System: Linux reng-PC 5.3.0-3-amd64 #1 SMP deepin 5.3.15-6apricot (2020-04-13) x86_64
[    26.635] Kernel command line: BOOT_IMAGE=/vmlinuz-5.3.0-3-amd64 root=UUID=51e31a6a-28e0-432b-8b9b-943573add4da ro splash quiet DEEPIN_GFXMODE=
[    26.635] Build Date: 12 January 2020  01:39:33PM
[    26.635] xorg-server 2:1.20.4.2-1+deepin (https://www.debian.org/support)
[    26.635] Current version of pixman: 0.36.0
[    26.635]         Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[    26.635] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    26.635] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 22 23:15:24 2020
[    26.748] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    26.748] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    26.830] (==) No Layout section.  Using the first Screen section.
[    26.830] (==) No screen section available. Using defaults.
[    26.830] (**) |-->Screen "Default Screen Section" (0)
[    26.830] (**) |   |-->Monitor "<default monitor>"
[    26.885] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    26.885] (==) Automatically adding devices
[    26.885] (==) Automatically enabling devices
[    26.885] (==) Automatically adding GPU devices
[    26.885] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    26.982] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    26.982]         Entry deleted from font path.
[    27.210] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/100dpi/:unscaled,
        /usr/share/fonts/X11/75dpi/:unscaled,
        /usr/share/fonts/X11/Type1,
        /usr/share/fonts/X11/100dpi,
        /usr/share/fonts/X11/75dpi,
        built-ins
[    27.210] (==) ModulePath set to "/usr/lib/xorg/modules"
[    27.210] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[    27.210] (II) Loader magic: 0x55e36bd83e20
[    27.210] (II) Module ABI versions:
[    27.210]         X.Org ANSI C Emulation: 0.4
[    27.211]         X.Org Video Driver: 24.0
[    27.211]         X.Org XInput driver : 24.1
[    27.211]         X.Org Server Extension : 10.0
[    27.212] (++) using VT number 1

[    27.212] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    27.212] (II) xfree86: Adding drm device (/dev/dri/card0)
[    27.216] (--) PCI:*(1@0:0:0) 10de:06ef:103c:7010 rev 161, Mem @ 0xd2000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00006000/128, BIOS @ 0x????????/131072
[    27.216] (II) LoadModule: "glx"
[    27.294] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    30.232] (II) Module glx: vendor="NVIDIA Corporation"
[    30.232]         compiled for 4.0.2, module version = 1.0.0
[    30.232]         Module class: X.Org Server Extension
[    30.239] (II) NVIDIA GLX Module  340.108  Wed Dec 11 14:26:50 PST 2019
[    30.574] (==) Matched nouveau as autoconfigured driver 0
[    30.574] (==) Matched nv as autoconfigured driver 1
[    30.574] (==) Matched modesetting as autoconfigured driver 2
[    30.574] (==) Matched fbdev as autoconfigured driver 3
[    30.574] (==) Matched vesa as autoconfigured driver 4
[    30.575] (==) Assigned the driver to the xf86ConfigLayout
[    30.575] (II) LoadModule: "nouveau"
[    30.575] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    30.597] (II) Module nouveau: vendor="X.Org Foundation"
[    30.597]         compiled for 1.20.4, module version = 1.0.16
[    30.597]         Module class: X.Org Video Driver
[    30.597]         ABI class: X.Org Video Driver, version 24.0
[    30.597] (II) LoadModule: "nv"
[    30.598] (WW) Warning, couldn't open module nv
[    30.598] (EE) Failed to load module "nv" (module does not exist, 0)
[    30.598] (II) LoadModule: "modesetting"
[    30.598] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    30.599] (II) Module modesetting: vendor="X.Org Foundation"
[    30.599]         compiled for 1.20.4, module version = 1.20.4
[    30.599]         Module class: X.Org Video Driver
[    30.599]         ABI class: X.Org Video Driver, version 24.0
[    30.599] (II) LoadModule: "fbdev"
[    30.599] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    30.610] (II) Module fbdev: vendor="X.Org Foundation"
[    30.610]         compiled for 1.20.4, module version = 0.5.0
[    30.610]         Module class: X.Org Video Driver
[    30.610]         ABI class: X.Org Video Driver, version 24.0
[    30.610] (II) LoadModule: "vesa"
[    30.611] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    30.611] (II) Module vesa: vendor="X.Org Foundation"
[    30.611]         compiled for 1.20.4, module version = 2.4.0
[    30.611]         Module class: X.Org Video Driver
[    30.611]         ABI class: X.Org Video Driver, version 24.0
[    30.611] (II) NOUVEAU driver Date:   Mon Jan 28 23:25:58 2019 -0500
[    30.611] (II) NOUVEAU driver for NVIDIA chipset families :
[    30.611]         RIVA TNT            (NV04)
[    30.611]         RIVA TNT2           (NV05)
[    30.611]         GeForce 256         (NV10)
[    30.611]         GeForce 2           (NV11, NV15)
[    30.612]         GeForce 4MX         (NV17, NV18)
[    30.612]         GeForce 3           (NV20)
[    30.612]         GeForce 4Ti         (NV25, NV28)
[    30.612]         GeForce FX          (NV3x)
[    30.612]         GeForce 6           (NV4x)
[    30.612]         GeForce 7           (G7x)
[    30.612]         GeForce 8           (G8x)
[    30.612]         GeForce 9           (G9x)
[    30.612]         GeForce GTX 2xx/3xx (GT2xx)
[    30.612]         GeForce GTX 4xx/5xx (GFxxx)
[    30.612]         GeForce GTX 6xx/7xx (GKxxx)
[    30.612]         GeForce GTX 9xx     (GMxxx)
[    30.612]         GeForce GTX 10xx    (GPxxx)
[    30.612] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    30.612] (II) FBDEV: driver for framebuffer: fbdev
[    30.612] (II) VESA: driver for VESA chipsets: vesa
[    30.614] (EE) [drm] Failed to open DRM device for (null): -22
[    30.614] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -22
[    30.614] (WW) Falling back to old probe method for modesetting
[    30.614] (II) Loading sub module "fbdevhw"
[    30.614] (II) LoadModule: "fbdevhw"
[    30.614] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    30.615] (II) Module fbdevhw: vendor="X.Org Foundation"
[    30.615]         compiled for 1.20.4, module version = 0.0.2
[    30.615]         ABI class: X.Org Video Driver, version 24.0
[    30.615] (EE) Unable to find a valid framebuffer device
[    30.615] (WW) Falling back to old probe method for fbdev
[    30.615] (II) Loading sub module "fbdevhw"
[    30.615] (II) LoadModule: "fbdevhw"
[    30.615] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    30.615] (II) Module fbdevhw: vendor="X.Org Foundation"
[    30.615]         compiled for 1.20.4, module version = 0.0.2
[    30.615]         ABI class: X.Org Video Driver, version 24.0
[    30.615] (EE) open /dev/fb0: No such file or directory
[    30.615] vesa: Ignoring device with a bound kernel driver
[    30.615] (EE) [drm] Failed to open DRM device for (null): -22
[    30.615] (EE) Screen 0 deleted because of no matching config section.
[    30.615] (II) UnloadModule: "modesetting"
[    30.615] (EE) Screen 0 deleted because of no matching config section.
[    30.615] (II) UnloadModule: "fbdev"
[    30.615] (II) UnloadSubModule: "fbdevhw"
[    30.615] (EE) Screen 0 deleted because of no matching config section.
[    30.615] (II) UnloadModule: "vesa"
[    30.615] (EE) Device(s) detected, but none match those in the config file.
[    30.615] (EE)
Fatal server error:
[    30.615] (EE) no screens found(EE)
[    30.616] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
for help.
[    30.616] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    30.616] (EE)
[    30.616] (EE) Server terminated with error (1). Closing log file.

0

主题

6

帖子

150

积分

-r--------

Rank: 1

积分
150
renghaoa 发表于 2020-4-23 01:24:33 | 显示全部楼层
deepinuser17 发表于 2020-4-21 23:13
按Ctrl + Alt + F3键组合,转换到文本终端。 登录。 然后查看/var/log/Xorg.0.log文件。 这个文件里有出 ...

显卡是英伟达G 103M,10年前的机器了,单显卡。

24

主题

397

帖子

1859

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1859
QQ
houyawei 发表于 2020-4-23 08:42:34 | 显示全部楼层
aj74aguk 发表于 2020-4-22 22:54
即便是这样,安装完成了,重启计算机,还是没有nvidia-smi

感觉beta显卡没啥大问题先别装显卡驱动,现在不自动安装显卡驱动管理器,说不定正式版有驱动管理中心之类的东西。
OS: Deepin 20 Beta n/a
Kernel: x86_64 Linux 5.3.0-3-amd64
Resolution: 1920x1080
DE: Deepin Beta
WM: KWin
Icon Theme: smartisan_bloom
CPU: Intel Core i5-6300HQ @ 4x 3.2GHz
GPU: GeForce GTX 960M
RAM: 11917MiB

2

主题

23

帖子

110

积分

-r--------

Rank: 1

积分
110
stlswm 发表于 2020-4-23 10:12:45 | 显示全部楼层
我就是看了你们的帖子已经装了几次系统了。
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部