发新帖

error while loading shared libraries: libnss3.so

jerry79 / 2019-12-2 11:52
浏览: 153 / 回复: 6
查看: 153|回复: 6

error while loading shared libraries: libnss3.so

[复制链接]
收藏
跳转到指定楼层
安装一个软件pencil (http://pencil.evolus.vn/),遇到了问题:error while loading shared libraries: libnss3.so
如下图,我可以找到这个文件,也安装了libnss3,但是还是不行,请问应该怎样解决这个问题呢?
谢谢
  1. <font color="#ff0000">(base) jerry@jerry-PC:~/Downloads$ apt-file search libnss3.so</font>
  2. easyconnect: /usr/share/sangfor/EasyConnect/resources/lib64/libnss3.so
  3. firefox-esr: /usr/lib/firefox-esr/libnss3.so
  4. firefox-esr-dev: /usr/lib/firefox-esr-devel-52/sdk/lib/libnss3.so
  5. firefox-esr52.9-cn: /usr/lib/firefox-esr-52.9/libnss3.so
  6. firefox-zh: /usr/lib/firefox-zh/libnss3.so
  7. libnss3: /usr/lib/x86_64-linux-gnu/libnss3.so
  8. openoffice-core01: /opt/openoffice4/program/libnss3.so
  9. palemoon: /usr/lib/palemoon/libnss3.so
  10. thunderbird: /usr/lib/thunderbird/libnss3.so
  11. thunderbird-dev: /usr/lib/thunderbird-devel/sdk/lib/libnss3.so
  12. wps-office: /opt/kingsoft/wps-office/office6/libnss3.so
  13. <font color="#ff0000">(base) jerry@jerry-PC:~/Downloads$ pencil</font>
  14. pencil: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory
  15. <font color="#ff0000">(base) jerry@jerry-PC:~/Downloads$ sudo apt-get install libnss3</font>
  16. 正在读取软件包列表... 完成
  17. 正在分析软件包的依赖关系树      
  18. 正在读取状态信息... 完成      
  19. libnss3 已经是最新版 (2:3.26.2-1.1+deb9u1)。
  20. 升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 1 个软件包未被升级。
  21. <font color="#ff0000">(base) jerry@jerry-PC:~/Downloads$ pencil</font>
  22. pencil: error while loading shared libraries: libnss3.so: cannot open shared object file: No such file or directory

复制代码


62

主题

2413

帖子

9037

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
9037
lidanger 志愿者 发表于 2019-12-2 12:02:45 | 显示全部楼层
安装了一下,没什么问题啊。。
深度截图_20191202120212.png
士别三日当刮目相待

74

主题

430

帖子

2399

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2399
jerry79 发表于 2019-12-3 12:29:25 | 显示全部楼层
lidanger 发表于 2019-12-2 12:02
安装了一下,没什么问题啊。。

我的是stable版本,你的也是吗?

62

主题

2413

帖子

9037

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
9037
lidanger 志愿者 发表于 2019-12-3 12:38:10 | 显示全部楼层
jerry79 发表于 2019-12-3 12:29
我的是stable版本,你的也是吗?

不知道,我安装是这个 http://pencil.evolus.vn/dl/V3.1.0.ga/pencil_3.1.0.ga_amd64.deb 直接在你发的链接上找的。
士别三日当刮目相待

62

主题

2413

帖子

9037

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
9037
lidanger 志愿者 发表于 2019-12-3 13:12:25 | 显示全部楼层
jerry79 发表于 2019-12-3 12:29
我的是stable版本,你的也是吗?

我系统是 stable 版本。。
士别三日当刮目相待

13

主题

112

帖子

788

积分

-r--r--r--

Rank: 3Rank: 3

积分
788
supermew 志愿者 发表于 2019-12-4 08:58:49 来自移动端 | 显示全部楼层
怪怪额, apt-file 是查找哪个包安装了所查找文件, 而不是指你系统里面有无这个文件。 现在你应该安装 libnss3

74

主题

430

帖子

2399

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
2399
jerry79 发表于 2019-12-5 11:54:14 | 显示全部楼层
lidanger 发表于 2019-12-3 13:12
我系统是 stable 版本。。

谢谢,我的错,我装了32位的,傻了
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部