发新帖

优化deepinV20(UOS)的十大操作!!!!!

hyjokhyy / 2020-5-28 20:29
浏览: 24280 / 回复: 70
楼主: hyjokhyy

优化deepinV20(UOS)的十大操作!!!!!

  [复制链接]

2

主题

8

帖子

41

积分

-r--------

Rank: 1

积分
41
QQ
qxlyg 志愿者 发表于 2020-7-12 16:19:42 | 显示全部楼层
好帖子,顶上去

73

主题

1564

帖子

4860

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
4860
QQ
wcswcs4 志愿者 发表于 2020-7-12 19:24:20 | 显示全部楼层
好的分享,心拟的杰作。

0

主题

26

帖子

73

积分

-r--------

Rank: 1

积分
73
ldhotao 发表于 2020-7-13 11:45:59 来自移动端 | 显示全部楼层
支持,看看,谢谢楼主分享

15

主题

281

帖子

1744

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1744
superbing 志愿者 发表于 2020-7-14 20:10:16 | 显示全部楼层
好东西、支持
https://bbs.chinauos.com
小白很白

0

主题

2

帖子

9

积分

-r--------

Rank: 1

积分
9
woshiyuyang1 发表于 2020-7-15 16:10:20 | 显示全部楼层
deepin20beta你要不要试一下

8

主题

340

帖子

1763

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1763
jiao 志愿者 发表于 2020-7-15 16:36:48 | 显示全部楼层
留个脚印,备用。

11

主题

277

帖子

1182

积分

-rw-r--r--

Rank: 4

积分
1182
wcss2010 发表于 2020-7-17 13:59:51 | 显示全部楼层
chenyh 发表于 2020-7-11 11:18
我的acer4743G  安装了steam 刀塔2   但是玩不了。。。老机器了。

你的机子是什么显卡啊,我最近安装成功显卡,有些游戏已经可以玩了,我的是Nvidia GeFore GT 550M,驱动版本是390.132,如果你的显卡和我差不多,我有个笔记,你要不要试试,有勇气没?
   
这是我的安装笔记,供你参考:

Debian 发行版Nvidia驱动+Bumblebee控制显卡切换

参照Debian官网: https://wiki.debian.org/Bumblebee/
Nvidia驱动查询:https://www.nvidia.cn/Download/index.aspx?lang=cn

查看显卡 $ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 550M] [10de:0df6]  (rev al)

其中nvidia显卡rev al表示显卡已启用
我在Nvidia驱动查询那里查了一下,我的显卡是NVIDIA Corporation GF108M [GeForce GT 550M] [10de:0df6] (rev ff),对应的驱动是390.132,而deepin源里没有我的驱动,所以我需要添加Debian官方源:
Debian官方文档 :https://wiki.debian.org/SourcesList
$ sudo deepin-editor /etc/apt/sources.list
   在末尾加入:
    # Debian 10 "Buster"
    deb http://deb.debian.org/debian/ buster main contrib non-free

注:如果是从nvidia官网下载的.run驱动,安装到最后时会提示你是不是要覆盖X Configuration File,这个不要覆盖,会进不去系统(不知道为什么)

$ sudo apt install nvidia-legacy-390xx-driver


对于debian8(包含)以上的版本可以直接安装Bumblebee与nvidia驱动

如果需要使用 nouveau开源驱动
$ sudo apt-get install bumblebee primus

如果需要使用nvidia闭源官方驱动(需要在/etc/apt/sources.list添加非开源软件仓库, contrib non-free)
$ sudo apt-get install bumblebee-nvidia primus
将用户添加到bumblebee用户组

$ sudo adduser $USER bumblebee $USER代表用户名
重启 $ reboot 查看显卡

$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 550M] [10de:0df6]  (rev ff)

此时nvidia显卡已禁用
使用nvidia显卡运行程序

$ optirun [options] <application> [application-parameters]
例如
$ optirun glxgears -info 更多命令
$ optirun --help
打开nvidia配置界面

$ optirun nvidia-settings -c :8
tips: 如果使用optirun命令出现错误
$ optirun glxgears -info
[ 127.294118]

[ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.[ 127.294144]
[ERROR]Could not connect to bumblebee daemon - is it running?

可能是之前已经将nouveau添加到了黑名单,.导致与bumblebee冲突
需要将之前的配置取消
删除之前添加的/etc/modprobe.d/blacklist.conf文件
修改完成后重启服务
$ service bumblebeed restart


如果刚安装好Debian 10的时候启动会黑屏,无法进入系统,解决办法是在grub界面,按e修改启动参数,在启动参数那一行(一般会包含quiet)后面加上
nouveau.modeset=0

11

主题

277

帖子

1182

积分

-rw-r--r--

Rank: 4

积分
1182
wcss2010 发表于 2020-7-17 14:00:55 | 显示全部楼层
chenyh 发表于 2020-7-11 11:18
我的acer4743G  安装了steam 刀塔2   但是玩不了。。。老机器了。

你的机子是什么显卡啊,我最近安装成功显卡,有些游戏已经可以玩了,我的是Nvidia GeFore GT 550M,驱动版本是390.132,如果你的显卡和我差不多,我有个笔记,你要不要试试,有勇气没?
   
这是我的安装笔记,供你参考:

Debian 发行版Nvidia驱动+Bumblebee控制显卡切换

参照Debian官网: https://wiki.debian.org/Bumblebee/
Nvidia驱动查询:https://www.nvidia.cn/Download/index.aspx?lang=cn

查看显卡 $ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 550M] [10de:0df6]  (rev al)

其中nvidia显卡rev al表示显卡已启用
我在Nvidia驱动查询那里查了一下,我的显卡是NVIDIA Corporation GF108M [GeForce GT 550M] [10de:0df6] (rev ff),对应的驱动是390.132,而deepin源里没有我的驱动,所以我需要添加Debian官方源:
Debian官方文档 :https://wiki.debian.org/SourcesList
$ sudo deepin-editor /etc/apt/sources.list
   在末尾加入:
    # Debian 10 "Buster"
    deb http://deb.debian.org/debian/ buster main contrib non-free

注:如果是从nvidia官网下载的.run驱动,安装到最后时会提示你是不是要覆盖X Configuration File,这个不要覆盖,会进不去系统(不知道为什么)

$ sudo apt install nvidia-legacy-390xx-driver


对于debian8(包含)以上的版本可以直接安装Bumblebee与nvidia驱动

如果需要使用 nouveau开源驱动
$ sudo apt-get install bumblebee primus

如果需要使用nvidia闭源官方驱动(需要在/etc/apt/sources.list添加非开源软件仓库, contrib non-free)
$ sudo apt-get install bumblebee-nvidia primus
将用户添加到bumblebee用户组

$ sudo adduser $USER bumblebee $USER代表用户名
重启 $ reboot 查看显卡

$ lspci -nn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 550M] [10de:0df6]  (rev ff)

此时nvidia显卡已禁用
使用nvidia显卡运行程序

$ optirun [options] <application> [application-parameters]
例如
$ optirun glxgears -info 更多命令
$ optirun --help
打开nvidia配置界面

$ optirun nvidia-settings -c :8
tips: 如果使用optirun命令出现错误
$ optirun glxgears -info
[ 127.294118]

[ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.[ 127.294144]
[ERROR]Could not connect to bumblebee daemon - is it running?

可能是之前已经将nouveau添加到了黑名单,.导致与bumblebee冲突
需要将之前的配置取消
删除之前添加的/etc/modprobe.d/blacklist.conf文件
修改完成后重启服务
$ service bumblebeed restart


如果刚安装好Debian 10的时候启动会黑屏,无法进入系统,解决办法是在grub界面,按e修改启动参数,在启动参数那一行(一般会包含quiet)后面加上
nouveau.modeset=0

1

主题

24

帖子

177

积分

-r--------

Rank: 1

积分
177
shadowdumb 发表于 2020-7-17 14:41:33 | 显示全部楼层
哈哈,这第一个是我发的,可以看看我空间

0

主题

2

帖子

21

积分

-r--------

Rank: 1

积分
21
byownlau 发表于 2020-7-18 20:45:41 | 显示全部楼层
真心非常不错,收集了很多有用的干货。Mark一下

0

主题

4

帖子

20

积分

-r--------

Rank: 1

积分
20
charleyleo 发表于 2020-7-20 16:47:40 | 显示全部楼层
感谢分享

0

主题

4

帖子

20

积分

-r--------

Rank: 1

积分
20
charleyleo 发表于 2020-7-20 16:51:28 | 显示全部楼层
shadowdumb 发表于 2020-7-17 14:41
哈哈,这第一个是我发的,可以看看我空间

赞一个

40

主题

181

帖子

835

积分

-rw-r--r--

Rank: 4

积分
835
wzb_td 发表于 2020-8-11 14:38:58 | 显示全部楼层
这个就厉害了

24

主题

145

帖子

625

积分

-r--r--r--

Rank: 3Rank: 3

积分
625
yunchuandehaidao 志愿者 发表于 2020-8-14 15:35:48 来自移动端 | 显示全部楼层
先留一脚

3

主题

43

帖子

179

积分

-r--------

Rank: 1

积分
179
hww 志愿者 发表于 2020-8-15 18:25:16 | 显示全部楼层
我这cpu估计再优化,也飞不起来

1

主题

8

帖子

38

积分

-r--------

Rank: 1

积分
38
a134101010 发表于 2020-8-18 21:30:16 来自移动端 | 显示全部楼层
基本打印问题还未解决

7

主题

22

帖子

86

积分

-r--------

Rank: 1

积分
86
color_wolf 发表于 2020-8-28 00:41:00 | 显示全部楼层
这些问题存在,是deepin团队的耻辱,deepin团队要有高度的自觉性,把这些问题扼杀掉,而不是让广大用户去折腾,祝deepin越办越好。

2

主题

291

帖子

1675

积分

-rw-rw-r--

Rank: 5Rank: 5

积分
1675
abelwy 发表于 2020-9-3 15:50:45 | 显示全部楼层
hyjokhyy 发表于 2020-5-28 22:01
好的。具体看附件文件

死机安全关闭系统的方法 学到了







    神奇的 Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4173.0 Safari/537.36

    31

    主题

    97

    帖子

    588

    积分

    -r--r--r--

    Rank: 3Rank: 3

    积分
    588
    s18207611738 发表于 2020-9-3 18:31:51 | 显示全部楼层
    dpkg: 处理软件包 nvidia-driver (--configure)时出错:
    依赖关系问题 - 仍未被配置
    在处理时有错误发生:
    nvidia-kernel-dkms
    nvidia-driver
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@s-f-h-PC:/home/s-f-h#

    31

    主题

    97

    帖子

    588

    积分

    -r--r--r--

    Rank: 3Rank: 3

    积分
    588
    s18207611738 发表于 2020-9-3 18:55:12 | 显示全部楼层
    root@s-f-h-PC:/home/s-f-h# apt-get install -y nvidia-driver
    正在读取软件包列表... 完成
    正在分析软件包的依赖关系树      
    正在读取状态信息... 完成      
    nvidia-driver 已经是最新版 (440.100-1)。
    升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 1 个软件包未被升级。
    有 2 个软件包没有被完全安装或卸载。
    解压缩后会消耗 0 B 的额外空间。
    正在设置 nvidia-kernel-dkms (440.100-1) ...
    Removing old nvidia-current-440.100 DKMS files...

    ------------------------------
    Deleting module version: 440.100
    completely from the DKMS tree.
    ------------------------------
    Done.
    Loading new nvidia-current-440.100 DKMS files...
    Building for 5.8.5-050805-generic
    Building initial module for 5.8.5-050805-generic
    Error! Bad return status for module build on kernel: 5.8.5-050805-generic (x86_64)
    Consult /var/lib/dkms/nvidia-current/440.100/build/make.log for more information.
    dpkg: 处理软件包 nvidia-kernel-dkms (--configure)时出错:
    已安装 nvidia-kernel-dkms 软件包 post-installation 脚本 子进程返回错误状态 10
    dpkg: 依赖关系问题使得 nvidia-driver 的配置工作不能继续:
    nvidia-driver 依赖于 nvidia-kernel-dkms (= 440.100-1) | nvidia-kernel-440.100;然而:
      软件包 nvidia-kernel-dkms 尚未配置。
      未安装软件包 nvidia-kernel-440.100。
      软件包 nvidia-kernel-dkms 提供了 nvidia-kernel-440.100,但它尚未被配置。

    dpkg: 处理软件包 nvidia-driver (--configure)时出错:
    依赖关系问题 - 仍未被配置
    在处理时有错误发生:
    nvidia-kernel-dkms
    nvidia-driver
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@s-f-h-PC:/home/s-f-h#
    您需要登录后才可以回帖 登录 | 立即注册

    本版积分规则

    快速回复 返回列表 返回版块 返回顶部