发新帖

【求助】无法安装爱普生打印机驱动,提示缺少lsb

lxflhy / 2020-9-13 21:25
浏览: 192 / 回复: 8
查看: 192|回复: 8

【求助】无法安装爱普生打印机驱动,提示缺少lsb

[复制链接]
收藏
跳转到指定楼层
本帖最后由 lxflhy 于 2020-9-16 20:49 编辑

如题,安装驱动,提示缺少lsb,官方源中没有,安装不了,求个有lsb的可靠的源,谢谢

================

安装错误信息在3楼

电脑:联想笔记本Y40-70AT-IFI
CPU:INTEL i5 4210U 1.7GHZ 2.4GHZ
内存:8G
集显:INTEL Graphics HD 4400
独显:AMD Radeon R9 M275  2GB
操作系统:Windows 10 / Deepin 20 Beta
我在使用deepin遇到的问题和解决方法:http://blog.sina.com.cn/s/articlelist_6481008946_0_1.html

27

主题

878

帖子

3673

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
3673
deepinuser17 发表于 2020-9-13 23:26:20 | 显示全部楼层
最好上传出错信息。没有具体信息,别人无法帮助。

深度初始安装了两个lsb软件包。
  1. $ dpkg -l lsb-base lsb-release
  2. Desired=Unknown/Install/Remove/Purge/Hold
  3. | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
  4. |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
  5. ||/ Name           Version       Architecture Description
  6. +++-==============-=============-============-=============================================
  7. ii  lsb-base       10.2019051400 all          Linux Standard Base init script functionality
  8. ii  lsb-release    10.2019051400 all          Linux Standard Base version reporting utility
复制代码


查看一下这两个包是否已经安装了。

25

主题

701

帖子

3380

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
3380
lxflhy 发表于 2020-9-15 18:54:09 | 显示全部楼层
deepinuser17 发表于 2020-9-13 23:26
最好上传出错信息。没有具体信息,别人无法帮助。

深度初始安装了两个lsb软件包。

显示已经安装了这两个包:

=============
~$ dpkg -l lsb-base lsb-release
期望状态=未知(u)/安装(i)/删除(r)/清除(p)/保持(h)
| 状态=未安装(n)/已安装(i)/仅存配置(c)/仅解压缩(U)/配置失败(F)/不完全安装(H)/触发器等待(W)/触发器未决(T)
|/ 错误?=(无)/须重装(R) (状态,错误:大写=故障)
||/ 名称           版本          体系结构     描述
+++-==============-=============-============-=============================================
ii  lsb-base       10.2019051400 all          Linux Standard Base init script functionality
ii  lsb-release    10.2019051400 all          Linux Standard Base version reporting utility
============

我不管是用终端还是图形界面安装,都是显示没有lsb
=========
~$ sudo dpkg -i /home/htlxf116/Downloads/epson-inkjet-printer-l100l200_1.0.0-1lsb3.2_amd64.deb

正在选中未选择的软件包 epson-inkjet-printer-l100l200。
(正在读取数据库 ... 系统当前共安装有 248327 个文件和目录。)
准备解压 .../epson-inkjet-printer-l100l200_1.0.0-1lsb3.2_amd64.deb  ...
正在解压 epson-inkjet-printer-l100l200 (1.0.0-1lsb3.2) ...
dpkg: 依赖关系问题使得 epson-inkjet-printer-l100l200 的配置工作不能继续:
epson-inkjet-printer-l100l200 依赖于 lsb (>= 3.2);然而:
  未安装软件包 lsb。

dpkg: 处理软件包 epson-inkjet-printer-l100l200 (--install)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 libc-bin (2.28.8.1-1+dde) 的触发器 ...
在处理时有错误发生:
epson-inkjet-printer-l100l200
电脑:联想笔记本Y40-70AT-IFI
CPU:INTEL i5 4210U 1.7GHZ 2.4GHZ
内存:8G
集显:INTEL Graphics HD 4400
独显:AMD Radeon R9 M275  2GB
操作系统:Windows 10 / Deepin 20 Beta
我在使用deepin遇到的问题和解决方法:http://blog.sina.com.cn/s/articlelist_6481008946_0_1.html

25

主题

701

帖子

3380

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
3380
lxflhy 发表于 2020-9-16 20:32:23 | 显示全部楼层
自己顶起,期待大神
电脑:联想笔记本Y40-70AT-IFI
CPU:INTEL i5 4210U 1.7GHZ 2.4GHZ
内存:8G
集显:INTEL Graphics HD 4400
独显:AMD Radeon R9 M275  2GB
操作系统:Windows 10 / Deepin 20 Beta
我在使用deepin遇到的问题和解决方法:http://blog.sina.com.cn/s/articlelist_6481008946_0_1.html

255

主题

1万

帖子

5万

积分

d-rw-rw-r--

Rank: 8Rank: 8

积分
56374
jingle 官方管理员 发表于 2020-9-16 20:37:19 | 显示全部楼层
https://www.uniontech.com/adapter-list 试试这里有没有你的型号
官方指定爆料员

25

主题

701

帖子

3380

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
3380
lxflhy 发表于 2020-9-16 20:47:25 | 显示全部楼层
jingle 发表于 2020-9-16 20:37
https://www.uniontech.com/adapter-list 试试这里有没有你的型号

我的是L100或者L101,那里没有这款,15.11之前我都是从下面这个网址下载的驱动安装的,都没有问题,现在不行了,总是提示没有安装lsb,无法安装!
http://download.ebz.epson.net/ds ... b7fd08d3ff0ea9db896
电脑:联想笔记本Y40-70AT-IFI
CPU:INTEL i5 4210U 1.7GHZ 2.4GHZ
内存:8G
集显:INTEL Graphics HD 4400
独显:AMD Radeon R9 M275  2GB
操作系统:Windows 10 / Deepin 20 Beta
我在使用deepin遇到的问题和解决方法:http://blog.sina.com.cn/s/articlelist_6481008946_0_1.html

4

主题

61

帖子

319

积分

-r--r-----

Rank: 2

积分
319
xieqin74123 发表于 2020-9-16 21:28:59 | 显示全部楼层
lxflhy 发表于 2020-9-16 20:47
我的是L100或者L101,那里没有这款,15.11之前我都是从下面这个网址下载的驱动安装的,都没有问题,现在 ...

没记错的话,debian在五年前就放弃了lsb,deepin基于debian,估计也不支持lsb了。我用的是爱普生的3150系列,在打印机管理器那个地方可以安装驱动,如果你的型号没有驱动,那估计也够呛了

25

主题

701

帖子

3380

积分

-rw-rw-rw-

Rank: 6Rank: 6

积分
3380
lxflhy 发表于 2020-9-19 09:17:18 | 显示全部楼层
xieqin74123 发表于 2020-9-16 21:28
没记错的话,debian在五年前就放弃了lsb,deepin基于debian,估计也不支持lsb了。我用的是爱普生的3150系 ...

V20之前的15.11版还有lsb,还支持呢,一升级,反而不支持了,越升级兼容性越差?
电脑:联想笔记本Y40-70AT-IFI
CPU:INTEL i5 4210U 1.7GHZ 2.4GHZ
内存:8G
集显:INTEL Graphics HD 4400
独显:AMD Radeon R9 M275  2GB
操作系统:Windows 10 / Deepin 20 Beta
我在使用deepin遇到的问题和解决方法:http://blog.sina.com.cn/s/articlelist_6481008946_0_1.html

4

主题

61

帖子

319

积分

-r--r-----

Rank: 2

积分
319
xieqin74123 发表于 2020-9-19 15:23:29 | 显示全部楼层
本帖最后由 xieqin74123 于 2020-9-19 15:26 编辑
lxflhy 发表于 2020-9-19 09:17
V20之前的15.11版还有lsb,还支持呢,一升级,反而不支持了,越升级兼容性越差? ...

这个估计得问debian了,deepin15系基于debian8,而后者是第一个不默认兼容lsb的debian版本,但是我记得当时网上有方法兼容lsb,估计deepin15也是这么干的。现在V20是基于debian10,抛弃了lsb这么久,对lsb兼容变差也可以理解吧
---更新---
你或许可以参考debian官网有关LSB的wiki:https://wiki.debian.org/DebianLsb

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回列表 返回版块 返回顶部