• Homepage
  • Categories
libssl-dev libssl1.0-dev
deepin Talks2468 views ·10 replies
Tofloor
mysong
deepin^1
2017-09-13 13:52
Author
安装php7.1-dev需要以来libssl-dev,然后安装为知笔记wiznote 需要依赖libssl1.0-dev,导致php7.1-dev和wiznote不能共存.

请问这个怎么解决啊?
ReplyFavoriteView the author
All Replies
jingle
deepin^10
2017-09-14 00:45
#1
确实依赖的版本不一样

  1. deepin@deepin:~$ apt-cache depends php7.1-dev
  2. php7.1-dev
  3.   依赖: autoconf
  4.   依赖: automake
  5.   依赖: libpcre3-dev
  6.   依赖: libssl-dev
  7.   依赖: php7.1-cli
  8.   依赖: php7.1-common
  9.   依赖: shtool
  10.   依赖: libtool
  11.   推荐: dh-php
  12.   推荐: pkg-php-tools
  13. deepin@deepin:~$ apt-cache depends wiznote
  14. wiznote
  15.   依赖: libc6
  16.   依赖: libgcc1
  17.   依赖: libstdc++6
  18.   依赖: libx11-6
  19.   依赖: zlib1g
  20.   依赖: libssl1.0-dev
Copy the Code
ReplyView the author
jingle
deepin^10
2017-09-14 00:53
#2
可能需要重现打包wiznote 看看
ReplyView the author
mysong
deepin^1
2017-09-14 01:41
#3
拜托请尽快解决
ReplyView the author
ginnerpeace
deepin^2
2017-10-30 08:47
#4
已经好久了,每次要编译扩展就把为知笔记卸载一遍……
ReplyView the author
xielingyun
deepin^4
2017-10-30 10:37
#5
本帖最后由 xielingyun 于 2017-10-30 18:44 编辑
https://bbs.deepin.org/post/145483
已经好久了,每次要编译扩展就把为知笔记卸载一遍……

可以在官方给出新版本之前,手动修改本地的信息来避免这个问题
  1. sudo vim /var/lib/dpkg/status
Copy the Code
  1. Package: wiznote
  2. Status: install ok installed
  3. Priority: optional
  4. Section: graphics
  5. Installed-Size: 393512
  6. Maintainer: Deepin Packages Builder
  7. Architecture: amd64
  8. Version: 2.5.5-1
  9. Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libstdc++6 (>= 5.2), libx11-6, zlib1g (>= 1:1.1.4), libssl1.0-dev
  10. Description: Cross platform cloud based note-taking application
  11. Cross platform cloud based note-taking application.
  12. .
  13. Please refer to WizNote home for more detailed info: http://www.wiznote.com.
  14. Homepage: http://www.wiznote.com
Copy the Code
把这里的 libssl1.0-dev 直接删掉,变成
  1. Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libstdc++6 (>= 5.2), libx11-6, zlib1g (>= 1:1.1.4)
Copy the Code
然后保存文件退出就好了

上面的修改可能有一个问题,在使用 apt update 的时候会提示wiznote需要升级,可以更加直接的修改掉这个包的版本号,例如下面这样
  1. Version: 2.5.5-2
Copy the Code


ReplyView the author
ginnerpeace
deepin^2
2017-11-13 14:17
#6
https://bbs.deepin.org/post/145483
可以在官方给出新版本之前,手动修改本地的信息来避免这个问题
把这里的 libssl1.0-dev 直接删掉,变成然 ...

OK, 这样可以,蟹蟹
ReplyView the author
ginnerpeace
deepin^2
2017-12-05 14:25
#7
https://bbs.deepin.org/post/145483
可以在官方给出新版本之前,手动修改本地的信息来避免这个问题
把这里的 libssl1.0-dev 直接删掉,变成然 ...

这样之后再装php7.0-dev,仍然会提示卸载libssl1.0-dev,这样直接卸载之后wiznote不能上传了
ReplyView the author
ginnerpeace
deepin^2
2017-12-12 07:02
#8
社区里没有PHP开发者在用deepin吗?这个问题还是比较难受的,没有解决前暂时不能用apt来装php了
  1. ginnerpeace@jedi:~$ apt policy libssl-dev
  2. libssl-dev:
  3.   已安装:(无)
  4.   候选: 1.1.0f-3
  5.   版本列表:
  6.       1.1.0f-3 500
  7.           500 http://packages.deepin.com/deepin panda/main amd64 Packages
  8. ginnerpeace@jedi:~$ apt policy libssl1.0-dev
  9. libssl1.0-dev:
  10.   已安装:1.0.2l-2
  11.   候选: 1.0.2l-2
  12.   版本列表:
  13.       *** 1.0.2l-2 500
  14.           500 http://packages.deepin.com/deepin panda/main amd64 Packages
  15.           100 /var/lib/dpkg/status
Copy the Code


ReplyView the author
ginnerpeace
deepin^2
2017-12-14 07:56
#9
沉了……

我用6楼的方法改掉了 php7.0-dev 对 libssl-dev 的依赖,安装了 libssl1.0-dev,目前没有发现问题,暂且这样
ReplyView the author
ginnerpeace
deepin^2
2018-03-25 09:35
#10
挖坟,包仓库里的php7.1-dev已经将依赖更新成了 libssl1.0-dev ,完美
ReplyView the author

Rankings

  • Weekly
  • Monthly
  • Total