• Homepage
  • Categories
安装Canon LBP2900打印机64位驱动的正确方法
Experiences and Insight1342 views ·6 replies
Tofloor
yeahxin
deepin^1
2018-09-06 01:20
Author
Canon 64位CAPT驱动包含了闭源的32位captfilter,而32位的captfilter需要依赖32位的libc6和libpopt0库文件而工作。这些库在包依赖关系中没有被安装。所以需要打开终端输入以下命令查看:
1、sudo apt-get install cndrvcups-common cndrvcups-capt
2、sudo ldd /usr/bin/captfilter
如果出现如下信息,请继续步骤3
linux-gate.so.1 (0xf76eb000)
libpopt.so.0 => /usr/lib32/libpopt.so.0 (0xf76a6000)
libc.so.6 => /lib32/libc.so.6 (0xf7501000)
/lib/ld-linux.so.2 (0xf76ec000)
3、sudo ldd /usr/bin/capt* | sort | uniq | grep "not found"
4、sudo apt-get install zlib1g:i386 libxml2:i386 libstdc++6:i386
5、最后在图形界面”打印设置”添加Canon LBP 2900打印机
这样添加的Canon LBP2900打印机64位驱动就可以正常工作了
参考资料:https://help.ubuntu.com/community/CanonCaptDrv190?action=show&redirect=HardwareSupportComponentsPrinters%2FCanonPrinters%2FCanon_LBP_2900

ReplyFavoriteView the author
All Replies
shisir_deepin
deepin^1
2018-11-01 03:56
#1
感谢大神指导!
ReplyView the author
shisir_deepin
deepin^1
2018-11-01 04:27
#2
感谢大神的指导,打印机已经安装并成功打印测试页!非常感谢!
ReplyView the author
675165914
deepin^0
2018-11-01 05:12
#3
我还是搞不懂,谢谢指教
ReplyView the author
arlly
deepin^5
2018-11-01 07:32
#4
ReplyView the author
freezone0011
deepin^2
2020-05-24 10:36
#5
Canon LBP 2900+  上面介绍的都 不能安装 呀??在线等
ReplyView the author
bmw320
deepin^2
2020-05-24 14:48
#6
最好帮同学们打包好,我们负责下载就行。
ReplyView the author

Rankings

  • Weekly
  • Monthly
  • Total