• Homepage
  • Categories
pixelbook2017在deepin20下没声音,尝试论坛多种方法都无效
Experiences and Insight431 views ·13 replies
Tofloor
wzs721014
deepin^1
2020-10-01 08:01
Author
本帖最后由 wzs721014 于 2020-10-1 16:10 编辑

ixelbook2017在deepin20下没声音,尝试论坛多种方法都无效.外放没声音.3.5mm耳机孔没声音.但是C口的华为耳机有声音



ReplyFavoriteView the author
All Replies
wzs721014
deepin^1
2020-10-01 08:04
#1
设备管理器
ReplyView the author
wzs721014
deepin^1
2020-10-01 08:06
#2
  1. lspci | grep audio
  2. 00:1f.3 Multimedia audio controller: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
Copy the Code
  1. play -l
  2. **** List of PLAYBACK Hardware Devices ****
  3. card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  4.   Subdevices: 0/1
  5.   Subdevice #0: subdevice #0
  6. card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  7.   Subdevices: 1/1
  8.   Subdevice #0: subdevice #0
  9. card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  10.   Subdevices: 1/1
  11.   Subdevice #0: subdevice #0
  12. card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  13.   Subdevices: 1/1
  14.   Subdevice #0: subdevice #0
  15. card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  16.   Subdevices: 1/1
  17.   Subdevice #0: subdevice #0
Copy the Code


ReplyView the author
wzs721014
deepin^1
2020-10-01 08:20
#3
  1. 试试这个方法
  2. sudo vi /etc/default/grub
  3. 下面这个选项后面添加snd_hda_intel.dmic_detect=0
  4. GRUB_CMDLINE_LINUX_DEFAULT="${这里你的原有配置不要动} snd_hda_intel.dmic_detect=0"
  5. sudo update-grub
  6. reboot
Copy the Code

这个方法无效;升级内核到5.7和5.8都无效
ReplyView the author
iafs
deepin^2
2020-10-01 09:15
#4
https://bbs.deepin.org/post/203183
这个方法无效;升级内核到5.7和5.8都无效

这个方法可行,我都试成功了。主要是编辑后保存上就行了。
ReplyView the author
iafs
deepin^2
2020-10-01 09:23
#5
https://bbs.deepin.org/post/203183
这个方法无效;升级内核到5.7和5.8都无效

输入GRUB_CMDLINE_LINUX_DEFAULT=“splash quiet snd_hda_intel.dmic_detect=0" ,保存上,我的可能是是esc+w+q,也可能是esc+:+w+q,试了多变才保存上。保存上后,再输入sudo update-grub,reboot。重启就有声音了。
ReplyView the author
iafs
deepin^2
2020-10-01 09:27
#6
https://bbs.deepin.org/post/203183
这个方法无效;升级内核到5.7和5.8都无效

我的以前是声音输出就一个,输入没有一个。现在输出8个,输入2个。或者是不是我再升级内核的缘故,现在升级5.8.12,还没有升级好。
ReplyView the author
wzs721014
deepin^1
2020-10-01 09:37
#7
https://bbs.deepin.org/post/203183
输入GRUB_CMDLINE_LINUX_DEFAULT=“splash quiet snd_hda_intel.dmic_detect=0" ,保存上,我的可能是是e ...

不是这个问题,这个vim的基本操作我还是会的
ReplyView the author
lcw0268
deepin^6
2020-10-01 11:37
#8
把splash项去掉,重启看看显示什么?
数字通道我的一般都没有声音,楼主的有啊?
没有看到楼主选哪个输出呀?
ReplyView the author
wzs721014
deepin^1
2020-10-01 13:05
#9
https://bbs.deepin.org/post/203183
把splash项去掉,重启看看显示什么?
数字通道我的一般都没有声音,楼主的有啊?
没有看到楼主选哪个输出呀 ...

五个输出都尝试了,外放都不行.
插入C口耳机后,输出就多出来耳机选项了.
ReplyView the author
wzs721014
deepin^1
2020-10-01 13:26
#10
https://bbs.deepin.org/post/203183
把splash项去掉,重启看看显示什么?
数字通道我的一般都没有声音,楼主的有啊?
没有看到楼主选哪个输出呀 ...

注释掉splash项后,输入输出都是空白了
ReplyView the author
lcw0268
deepin^6
2020-10-02 04:00
#11
https://bbs.deepin.org/post/203183
注释掉splash项后,输入输出都是空白了

是看启动过程中,有没有什么错误显示?红色的。
ReplyView the author
wzs721014
deepin^1
2020-10-02 06:40
#12
速度太快,看不到
ReplyView the author
lhicq
deepin^1
2020-12-11 22:38
#13

我也遇到同样问题,今天系统升级后就没有声音了。

ReplyView the author
New Thread

Rankings

  • Weekly
  • Monthly
  • Total