• 社区首页
  • 版块
期待dde代码的国内镜像和构建dde的方法
社区测试883个浏览 ·4个评论
电梯直达到第
zhangn1985
deepin^4
发表于2020-10-23 13:31
楼主
尝试自己构建dde,但是github实在太慢,不知道有没有国内的镜像?
构建dde有哪些基本部件哪些可选部件?


回复收藏只看作者
所有回复
zhangn1985
deepin^4
发表于2020-10-24 12:57
沙发
编译顺序:
dktcore
dtkgui
deepin-gettext-tools
gio-qt
dde-qt-dbus-factory
zhangn1985
deepin^4
发表于2020-10-24 15:22
板凳
dtkwidget
dde-network-utils
dde-dock
deepin-movie-reborn
dde-file-manager
zhangn1985
deepin^4
发表于2020-10-30 08:50
地板

构建了几天,终于还是决定放弃,永远放弃。


不知道该说,辛苦deepin的集成人员,还是开发人员,总之能把这么乱的东西搞到能用真是不小的能力。


为什么乱呢?

它根本没有搞清楚软件的层次关系。

debian打包人员总结的依赖关系,

https://salsa.debian.org/pkg-deepin-team/progress-tracker/-/blob/master/depgraph/pkg-deepin-dep.svg

大蜘蛛网。

人家都还是有经验的,弱一点的根本处理不过来。


还有,软件之间也乱,比如

dde-api里面提供

/usr/lib/deepin-api/image-blur

但这个软件包又依赖:blur-effect

它提供:blur_image


看出来有意思了吧。这两个是啥呢。

dde-api里面的是一个go程序。名字和 blur_image 差不多,应该也是一样的功能。

为啥deepin要用go再画轮子呢?


再谈dde-api,这个看起来是api,但是呢是一堆helper和一堆systemd service定义。

本来可以用shell来实现,或者单独成包。

应该用shell重新实现helper,打包成dde-helper

service部分单独打包成dde-service.


还有的就是把可选的运行时依赖强制为必选依赖,这个就太多了。


compact level被设置成9,导致编译单线程,这个真是辛苦。


软件包间有同名文件。当然是开发包有同名文件,所以普通用户感觉不到。


最严重的就是deepin-authentication 这个软件包编译安装之后,PAM系统就不工作了。

只能ssh+key认证登录系统,而且sudo/su都失败。

为啥,因为它改了PAM module path. 导致它的PAM module不能找到。

你以为把PAM module手动改到对应位置就好了吗?

不,它会报找不到symbol。但是我是从源码编译链接的呀,可能找不到符号吧。

蒙逼。


只好全部删除。






zhangn1985
deepin^4
发表于2020-10-30 08:51
4楼


大蜘蛛网。

发布帖子

光荣榜

  • 周榜
  • 月榜
  • 总榜