• 社区首页
  • 版块
keyserver.ubuntu.com 从公钥服务器接收失败 异常
体验心得144个浏览 ·6个评论
电梯直达到第
berrydeepin
deepin^1
发表于2020-10-26 03:00
楼主
本帖最后由 berrydeepin 于 2020-10-26 11:34 编辑

V20 apt update ;apt install uprade 提示下面异常,请教如何处理?是不是keyserver.ubuntu.com被封了导致无法进行公钥交换?

Executing: /tmp/apt-key-gpghome.wLf0BK7j9H/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 50B027516CAEE58D
gpg: 从公钥服务器接收失败:Server indicated a failure
Warning: The postinst maintainerscript of the package app4deepin-kernel-repository-china
Warning: seems to use apt-key (provided by apt) without depending on gnupg or gnupg2.
Warning: This will BREAK in the future and should be fixed by the package maintainer(s).
Note: Check first if apt-key functionality is needed at all - it probably isn't!
Warning: apt-key should not be used in scripts (called from postinst maintainerscript of the package app4deepin-kernel-repository-china)
回复收藏只看作者
所有回复
berrydeepin
deepin^1
发表于2020-10-26 04:50
沙发
网上找了很多资料,大同小异,均无法解决,有大神知道如何处理么?多谢。
App4Deepin
deepin^5
发表于2020-10-26 09:08
板凳
Edited by lvtommy at 2020-10-26 17:09

i have corrected this error. You can install this new DEB file for repository.

Before do on terminal :
sudo apt purge app4deepin-kernel-repository-china

After install the new DEB

我已经纠正了这个错误。 您可以为存储库安装此新的DEB文件
Use this link to download the new DEB :  https://lvtommydeb.b-cdn.net/deepin-20/app4deepin-kernel-repository-china_1.0.2.deb

Or see attachmentapp4deepin-kernel-repository-china_1.0.2.deb



神末 沫版主
发表于2020-10-26 09:26
地板
https://bbs.deepin.org/post/204425
Edited by lvtommy at 2020-10-26 17:09

i have corrected this error. You can install this new DEB f ...

Hello
How about talking about Chinese mirror from Spark Server?We've ready for it
App4Deepin
deepin^5
发表于2020-10-26 10:30
4楼
https://bbs.deepin.org/post/204425
Hello
How about talking about Chinese mirror from Spark Server?We've ready for it

Hi, we can. If i can use your server, it will be very nice.

How i can do this ?
神末 沫版主
发表于2020-10-26 11:43
5楼
https://bbs.deepin.org/post/204425
Hi, we can. If i can use your server, it will be very nice.

How i can do this ?

You need to deploy an rsync server
berrydeepin
deepin^1
发表于2020-10-26 12:18
6楼
https://bbs.deepin.org/post/204425
Edited by lvtommy at 2020-10-26 17:09

i have corrected this error. You can install this new DEB f ...

thanks for your help,  fixed it
发布帖子

光荣榜

  • 周榜
  • 月榜
  • 总榜