• Homepage
  • Categories
深度操作系统 15 Alpha2升级至深度操作系统15 Beta的方法
15 RC专版(归档中)8727 views ·37 replies
Tofloor
cxbii
deepin^7
2015-12-16 08:29
Author
大家好,
为了让大家更为顺利的升级至深度操作系统15 Beta,请各位深度操作系统 15 Alpha2用户按照如下方法进行系统升级:
1. 在启动器中打开深度终端”,运行以下命令(如需输入密码,请直接盲打登录密码后回车):
  1. sudo gedit /etc/apt/sources.list
Copy the Code
2. 然后使用以下内容进行替换并保持文件:
deb [by-hash=force] http://packages.deepin.com/deepin unstable main contrib non-free

3. 然后在终端执行以下命令:
  1. sudo apt-get update && sudo apt-get install apt lastore-daemon libapt-pkg5.0 -y && sudo apt-get dist-upgrade -y
Copy the Code

4. 等待系统更新完毕后,重启电脑即可。


注意事项:
  • 深度操作系统 15 Alpha2以外任何版本,均不支持升级至深度操作系统15 Beta。



ReplyFavoriteView the author
All Replies
parsgo
deepin^5
2015-12-16 09:24
#1
升级后,字体不如从前,如何解决?
ReplyView the author
ming1007520388
deepin^5
2015-12-16 09:45
#2
https://bbs.deepin.org/post/34120
升级后,字体不如从前,如何解决?

深度商店可以用吗?!
ReplyView the author
parsgo
deepin^5
2015-12-16 09:49
#3
https://bbs.deepin.org/post/34120
深度商店可以用吗?!

deepin-appstore -c
之后,就可以了
ReplyView the author
parsgo
deepin^5
2015-12-16 09:52
#4
Deepin的第一次滚动升级,基本顺利。

工程师们辛苦了!
ReplyView the author
lieri
deepin^6
2015-12-16 10:01
#5
上午通过终端sudo apt-get update && sudo apt-get dist-upgrade -y升级到了你所说的不是正式版的beta,刚才用你本帖子中的步骤操作之后没有升级任何包,同时发现sudo apt-get update 时的源是http://packages.deepin.com/deepin unstable InRelease,是不是我这里出错了?
PS:之前由于cdn出问题,在终端下执行过这个命令sudo apt-get update; sudo apt-get dist-upgrade -o Acquire::SmartMirrors::Enable=false
ReplyView the author
jimmyxu
deepin^5
2015-12-16 10:05
#6
https://bbs.deepin.org/post/34120
deepin-appstore -c
之后,就可以了

还是-c清理后才管用!
ReplyView the author
vstec
deepin^4
2015-12-16 10:10
#7
正在升级中
ReplyView the author
方老四
deepin^6
2015-12-16 10:33
#8
本帖最后由 fangling 于 2015-12-16 18:48 编辑

按楼主的升级办法升级,升级失败,好像是傲游浏览器的问题,在启动器里又缷载不掉,请教高手指点该如何办。
ReplyView the author
huching
deepin^3
2015-12-16 12:07
#9
W: 无法下载 http://packages.deepin.com/deepin/dists/unstable/non-free/binary-amd64/Packages  Hash 校验和不符

W: 无法下载 http://packages.deepin.com/deepin/dists/unstable/contrib/binary-i386/Packages  Hash 校验和不符

W: 无法下载 http://packages.deepin.com/deepin/dists/unstable/non-free/binary-i386/Packages  Hash 校验和不符
ReplyView the author
macaiyun0629
deepin^6
2015-12-16 13:18
#10
按楼主的方法升级,搜狗输入法直接挂了,然后将deb [by-hash=force] http://packages.deepin.com/deepin unstable main contrib non-free注释掉,使用原来的源,更新之后搜狗输入法才能正常使用
ReplyView the author
honor
deepin^6
2015-12-16 15:33
#11
https://bbs.deepin.org/post/34120
deepin-appstore -c
之后,就可以了

厉害,果然不报错了。
ReplyView the author
honor
deepin^6
2015-12-16 15:34
#12
楼主,更新完成后,sources.list需要恢复成原来的设置吗?
ReplyView the author
chenzhiwei
deepin^4
2015-12-16 16:10
#13
我从 2015 a1 一路升级过来,一点问题都没有哦。明显流畅多了,只是整体颜色偏白让我很不舒服。
ReplyView the author
slg0739
deepin^5
2015-12-17 01:22
#14
我用sudo apt-get update

sudo apt full-upgrade

升级很顺利。。。。。。

ReplyView the author
gusl
deepin^3
2015-12-17 01:42
#15
直接
sudo apt-get update
sudo apt-get dist-upgrade
就升级到beta了
ReplyView the author
方老四
deepin^6
2015-12-17 01:55
#16
A2升级不成功,问题见9楼,重新安装了一遍。
ReplyView the author
cxbii
deepin^7
2015-12-17 05:23
#17
https://bbs.deepin.org/post/34120
按楼主的升级办法升级,升级失败,好像是傲游浏览器的问题,在启动器里又缷载不掉,请教高手指点该如何办。 ...

终端执行:
sudo nautilus  /etc/apt/sources.list.d

把遨游的源文件删除后再次更新。
ReplyView the author
方老四
deepin^6
2015-12-17 05:26
#18
本帖最后由 fangling 于 2015-12-17 13:31 编辑
https://bbs.deepin.org/post/34120
终端执行:

把遨游的源文件删除后再次更新。

已经重新安装一遍Beta,也不是很麻烦。谢谢。我是在官网上下载的deb包安装的,是不是这个原因。安装Beta后是从深度商店中安装,希望经后升级不会有问题。
ReplyView the author
cxbii
deepin^7
2015-12-17 05:35
#19
https://bbs.deepin.org/post/34120
已经重新安装一遍Beta,也不是很麻烦。谢谢。我是在官网上下载的deb包安装的,是不是这个原因。安装Beta后 ...

这个是遨游的安装包的问题,它安装遨游后会添加自己的源,但是现在那个源失效了。

商店中安装也是有问题的,这个问题我汇报下
ReplyView the author
方老四
deepin^6
2015-12-17 05:43
#20
本帖最后由 fangling 于 2015-12-17 13:45 编辑
https://bbs.deepin.org/post/34120
这个是遨游的安装包的问题,它安装遨游后会添加自己的源,但是现在那个源失效了。

商店中安装也是有问题 ...

使用傲游浏览器就是因为可以共享收藏夹,那我先按18楼的方法把傲游的源删除掉,今后就不会影响升级了吧?
ReplyView the author
1/2
To page

Rankings

  • Weekly
  • Monthly
  • Total