• Homepage
  • Categories
解决方法:在 Ubuntu 16.04 中安装有道词典
Apps Section1.2w views ·20 replies
Tofloor
geeytey
deepin^1
2016-07-02 09:47
Author
本帖最后由 geeytey 于 2016-7-2 23:43 编辑


我的环境是 Ubuntu Mate 16.04 x64,从 http://cidian.youdao.com/index-linux.html 下载得到 Ubuntu 的 64位包:youdao-dict_1.1.0-0-ubuntu_amd64.deb,使用 dpkg -i 命令安装后修复依赖,但是发现安装不成功。

Google了一番,找到了这个帖子http://www.time-track.cn/install-youdaodict-in-xenial.html  。

问题在于有道词典的软件包依赖于gstreamer0.10-plugins-ugly ,但是在 Ubuntu 16.04 中,已经去掉了 gstreamer0.10-plugins-ugly ,所以有道词典没法安装。

但是实测发现即使没有 gstreamer0.10-plugins-ugly  ,也不影响有道词典的使用。  

所以我们可以去掉deb包里面对于 gstreamer0.10-plugins-ugly  的依赖。具体操作如下:  

  1. dpkg -X ./youdao-dict_1.1.0-0-ubuntu_amd64.deb  youdao #将 deb 包解压到 youdao 目录
  2. dpkg -e ./youdao-dict_1.1.0-0-ubuntu_amd64.deb youdao/DEBIAN #解压 deb 包中的 control 信息
  3. vi youdao/DEBIAN/control #编辑 control 文件,去掉 Depends 里的 gstreamer0.10-plugins-ugly
  4. mkdir youdaobuild #创建 youdaobuild 目录
  5. dpkg-deb -b youdao youdaobuild/ #重新打包
Copy the Code


然后安装这个新的 deb 包,修复依赖即可。

为了懒人们,我分享一下我制作的 deb 包,需要的自取,Ps,论坛允许的附件大小实在是不够用啊,只能百度云了。

  1. 链接: http://pan.baidu.com/s/1sly3Xl7 密码: 1b5j
Copy the Code



BTW,求 deepin 团队继续更新 有道词 啊!





更新:不能忍,老弹出这个,跪求更新啊!



Ps,截图软件是 deepin-scrot_2.0-0deepin_all.deb —— 我只能安装成功这么古老的深度截图,找到了 deepin-screenshot_3.1.8-2_amd64.deb ,但是依赖没法解决,作罢。


ReplyFavoriteView the author
All Replies
geeytey
deepin^1
2016-07-02 09:50
#1
帖子里怎么没法插入超链接?
ReplyView the author
diyiliaoya
deepin^6
2016-07-02 10:40
#2
https://bbs.deepin.org/post/41112
帖子里怎么没法插入超链接?


ReplyView the author
geeytey
deepin^1
2016-07-02 14:35
#3

我知道这个,在写的时候,插了两个链接,但是点发表之后就没有超链接了。
ReplyView the author
diyiliaoya
deepin^6
2016-07-02 14:43
#4
https://bbs.deepin.org/post/41112
我知道这个,在写的时候,插了两个链接,但是点发表之后就没有超链接了。 ...

可能姿势不对
ReplyView the author
geeytey
deepin^1
2016-07-02 15:44
#5

刚刚更新了一下帖子,还是没法插入链接
ReplyView the author
diyiliaoya
deepin^6
2016-07-03 00:34
#6
本帖最后由 diyiliaoya 于 2016-7-3 09:48 编辑
https://bbs.deepin.org/post/41112
刚刚更新了一下帖子,还是没法插入链接

那就奇怪了,我帮你编辑一下看看,如何?
ReplyView the author
yjqcx89
deepin^5
2016-07-03 04:06
#7
https://bbs.deepin.org/post/41112
那就奇怪了,我帮你编辑一下看看,如何?

我也不能插链接,可能会是论坛BUG
ReplyView the author
diyiliaoya
deepin^6
2016-07-03 05:16
#8
本帖最后由 diyiliaoya 于 2016-7-3 13:17 编辑
https://bbs.deepin.org/post/41112
我也不能插链接,可能会是论坛BUG

我刚注册了号试了一下,确实不能发链接
估计是等级限制吧 ,为了防止广告号,但是你的等级也不低啊
这事只能https://bbs.deepin.org/user/48640
ReplyView the author
jingle
deepin^10
2016-07-04 00:57
#9
https://bbs.deepin.org/post/41112
我刚注册了号试了一下,确实不能发链接
估计是等级限制吧 ,为了防止广告号,但是你的等级也不低啊
这事 ...
OK  我反馈下。
ReplyView the author
yjqcx89
deepin^5
2016-07-04 13:55
#10
本帖最后由 yjqcx89 于 2016-7-4 21:57 编辑
https://bbs.deepin.org/post/41112
OK  我反馈下。

我可以加链接了,是已经FIX了吗?好快啊。

测试链接: https://bbs.deepin.org/post/41112
测试链接2: https://bbs.deepin.org/post/41112
ReplyView the author
yutent
deepin^6
2016-07-05 02:32
#11
严重支持
有道词典,确实很久没更新了……我现在也是16.04了,装不上。
深度截图,确实是linux下最好的截图,可惜依赖太多,非deepin安装起来,几乎要把整个深度桌面环境给装了个遍了……
ReplyView the author
geeytey
deepin^1
2016-07-05 11:58
#12
本帖最后由 geeytey 于 2016-7-5 20:04 编辑
https://bbs.deepin.org/post/41112
严重支持
有道词典,确实很久没更新了……我现在也是16.04了,装不上。
深度截图,确实是linux下最好的截图 ...

参考链接:媲美QQ截图的Ubuntu截图工具DeepinScrot http://mp.weixin.qq.com/s?__biz=MzAxMTE3MDkyMA==&mid=2654409933&idx=1&sn=549bcb4a205a880aeb4e121d4f670b65&scene=24&srcid=0627oUGkEB7xdV4mM61BIJmM#rd

上面的文章给的包比较老,我在Index of /deepin/pool/main/d/deepin-screenshot/ http://packages.deepin.com/deepin/pool/main/d/deepin-screenshot  找到了比较新的包,版本为 3.1.8-2 ,比 Github 上早一个版本。
但是 3.1.8-2 版本并没有安装成功,尝试 2.0 版本 http://packages.linuxdeepin.com/deepin/pool/main/d/deepin-scrot/ 安装成功。
启动命令为 deepin-scrot ,据此可以创建快捷方式和快捷键。

我还是没法插入链接!!!
ReplyView the author
yutent
deepin^6
2016-07-05 13:04
#13
https://bbs.deepin.org/post/41112
参考链接:媲美QQ截图的Ubuntu截图工具DeepinScrot http://mp.weixin.qq.com/s?__biz=MzAxMTE3MDkyMA==&mi ...

这个早看过了, 也试过了, 2.0不好用呢。
ReplyView the author
geeytey
deepin^1
2016-07-05 16:35
#14
https://bbs.deepin.org/post/41112
这个早看过了, 也试过了, 2.0不好用呢。

基本的功能都有了,截图已经够用了。
ReplyView the author
find
deepin^1
2016-08-25 07:25
#15
楼主你这个在kali里安装有道也好用吗?
ReplyView the author
yutent
deepin^6
2016-08-25 07:32
#16
不要下载ubuntu版,直接下载deepin版,安装无问题,就是划词不能用,一用就闪退
ReplyView the author
yutouyes
deepin^6
2016-08-25 08:02
#17
不能插入超鏈接是用戶組問題
ReplyView the author
SamaelChen
deepin^2
2016-08-25 10:02
#18
其实我说一个很搞笑的事情哈,Ubuntu16.04下载deepin版本的有道词典deb,各种正常。。。
ReplyView the author
zhixiang
deepin^4
2016-08-30 05:03
#19
楼主可以用deepin的源安装deepin截图的,我就是这样干的。
ReplyView the author
gctx
deepin^3
2017-11-04 15:26
#20
楼主可以再给一下链接吗
ReplyView the author

Rankings

  • Weekly
  • Monthly
  • Total