• Homepage
  • Categories
INTERNET VERY SLOW.... (VIA WIFI)(URGENT)
Community Discussion9236 views ·20 replies
Tofloor
cktv8822
deepin^1
2016-09-14 17:09
Author

SLOW CONNECTIONS INTERNET (WIFI)

The internet connection is very slow, and only happens when I am connected via wifi, cable connection is stable.

help, because this problem was already solved in Deepin 15.2.

Too slow Internet connection: Connect to the Internet to browse or download files via Google Chrome and doing speed test.

WIFI check internal controller kernel. because the controller work properly in Deepin 15.2


Conexión a Internet vía WIFI es Super Lenta

la conexiòn de internet es muy lenta, y solo pasa cuando estoy conectado via wifi, la conexión por cable es estable.

ayuda, pues este problema ya estaba solucionado en Deepin 15.2.

Conexion a internet demasiado lenta: Conectarme al internet para navegar o descargar archivos via Google Chrome  y haciendo test de velocidad.

Revisar controlador interno WIFI kernel. ya que el controlador funcionaba correctamente en Deepin 15.2

ReplyFavoriteView the author
All Replies
ing_alexander
deepin^0
2017-09-10 19:53
#1
Hello, this thread have some time but don't have any solution, I found a solution that is working for me and don't need uninstall anything

my case is for the device Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

when we install deepin the defaul config of the device is the next
  1. grep -iR [[:alnum:]] /sys/module/ath9k/parameters
Copy the Code
  1. /sys/module/ath9k/parameters/bt_ant_diversity:0
  2. /sys/module/ath9k/parameters/nohwcrypt:0
  3. /sys/module/ath9k/parameters/blink:0
  4. /sys/module/ath9k/parameters/btcoex_enable:0
  5. /sys/module/ath9k/parameters/led_active_high:-1
  6. /sys/module/ath9k/parameters/ps_enable:0
Copy the Code

but, for the driver ath9k on this device that have wifi and bluetooth combo this configuration is wrong, this device has support of bluetooth coexistence
https://wireless.wiki.kernel.org/en/users/drivers/ath9k/btcoex
so, is necesary enable this feature for the bluetooth not interfere with wifi, the simplest way to see if this is the problem is disable bluetooth  in deepin control panel, only with this the wifi speed improve a lot.

but for solve the issue the correct way is to enable the feature
  1. sudo nano /etc/modprobe.d/ath9k.conf
Copy the Code
in this file we need put these options
  1. options ath9k nohwcrypt=1
  2. options ath9k btcoex_enable=1
Copy the Code

It's important to know that when bluetooth is active searching devices the speet of wifi drop down but not like when btcoex_enable is disabled, the problem now is the deepin control panel, it force the bluettoth device search for looooong time, that interfere with the wifi, to solve this we can install blueman
  1. sudo apt install blueman
Copy the Code


now, start de program blueman
next disable bluetooth from deepin control panel
now start bluetooth from blueman bluetooth menu
with this, blueman take care of the search of devices and deepin control panel stop interfer with the wifi


sorry for my bad english


ReplyView the author
zhangsh
deepin^0
2017-10-11 05:17
#2
https://bbs.deepin.org/post/131490
Hello, this thread have some time but don't have any solution, I found a solution that is working fo ...

thanks, but it doesn't work for me, sad.
ReplyView the author
arcanjobra
deepin^1
2017-10-11 23:16
#3
use program ukuu update kernel 4.13.5
ReplyView the author
melodyzou
deepin^6
2017-10-12 07:02
#4
https://bbs.deepin.org/post/131490
thanks, but it doesn't work for me, sad.

What is your issue? slow network? Could you please be more specific?
ReplyView the author
zhangsh
deepin^0
2017-10-13 05:06
#5
https://bbs.deepin.org/post/131490
What is your issue? slow network? Could you please be more specific?

https://bbs.deepin.org/post/146540#

这个问题,我已经StackOverflow提问解决了。谢谢关注
ReplyView the author
melodyzou
deepin^6
2017-10-16 08:02
#6
https://bbs.deepin.org/post/131490
https://bbs.deepin.org/post/146540#

这个问题,我已经StackOverflow提 ...

Glad to hear that.
ReplyView the author
interfacenode
deepin^1
2016-09-14 19:50
#7
Edited by interfacenode at 2016-9-15 03:53

Please tell me which wifi-dongle you are using; if possible.

Is it Realtek by any chance? I bet it is
The reason? IN 15.3 Deepin is using drivers that had debuffed power-management in regards to some wifi-dongle.



Dime cuál es tu modelo de wifi dispositivo.
ReplyView the author
interfacenode
deepin^1
2016-09-14 20:02
#8
ay que lindo... I thought you were in a rush?

Me too, I'm curious to confirm what I think.. let me know soon senor
ReplyView the author
cktv8822
deepin^1
2016-09-15 18:12
#9
Network controller                : Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Ethernet controller                : Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
ReplyView the author
cktv8822
deepin^1
2016-09-15 18:13
#10
Wireless - Very Slow Internet.
Ethernet - Internet Stable
ReplyView the author
interfacenode
deepin^1
2016-09-16 07:12
#11
https://bbs.deepin.org/post/31490
Wireless - Very Slow Internet.
Ethernet - Internet Stable

Open terminal and issue the following

sudo su && echo "options ath9k nohwcrypt=1" >> /etc/modprobe.d/ath9k.conf

Then restart, tell me if this resolves wifi errors.
ReplyView the author
cktv8822
deepin^1
2016-09-16 18:36
#12
Not working,

although improving the connection is not enough:
Current bandwidth: 10MB
Before: 0.5MB
after 1MB

Is there any other solution?
ReplyView the author
Favaro
deepin^3
2016-09-16 19:24
#13
i have to this Problem
ReplyView the author
horvan
deepin^2
2016-09-16 19:26
#14
Try sudo modprobe ath9k && dmesg | grep ath
ReplyView the author
infuscomus
deepin^0
2016-09-16 19:40
#15
you might want to try a kernel update,

a new kernel module for your wifi might fix some things
ReplyView the author
cktv8822
deepin^1
2016-09-16 20:10
#16

as upgrade?
ReplyView the author
cktv8822
deepin^1
2016-09-16 20:44
#17

Solucioné el problema de la siguiente forma:

Desinstale  Firmware-athero y Wireless-tools

sudo apt-get remove --purge  firmware-atheros
sudo apt remove --purge wireless-tools

Gracias por la ayuda...



Y ahora puedo navegar con el ancho de banda completo. 10/10

I solved the problem as follows:

Uninstall Firmware-athero and Wireless-tools

sudo apt-get remove --purge  firmware-atheros
sudo apt remove --purge wireless-tools

Thanks for the help...
ReplyView the author
infuscomus
deepin^0
2016-09-17 05:15
#18
if that doesn't work you can grab a more recent kernel here

http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.7.4/

I'll be grabbing this one to fix the missing kernel module for my soundcard
ReplyView the author
doctorfreeman
deepin^0
2016-09-17 08:54
#19
So much time, by the way... if you have an Atheros K (see it with "lshw -C network"), use the following on terminal:

echo "options ath9k nohwcrypt=1" | sudo tee  /etc/modprobe.d/ath9k.conf
sudo modprobe -rfv ath9k

sudo modprobe -v ath9k
ReplyView the author
cktv8822
deepin^1
2016-10-18 21:12
#20
not working your solution...  I had to uninstall again the firmware-atheros
ReplyView the author
New Thread

Rankings

  • Weekly
  • Monthly
  • Total